teamviewer.com link icon
or
Ask The Community

Not ready, Please check you connection (Mac & iPhone can't connect)

Hi, I have a MacBook Pro running macOS Mojave 10.14.2 and an iPhone X running iOS 12.1.2, both of them have TeamViewer installed and updated to it's latest versions. The problem is that on both of them, TeamViewer doesn't work. On the Mac says "not ready, please check your connection" and on the iPhone it just loading forever! This happens only on my WiFi network, on 4G data from my iPhone or even on other WiFi networks both devices don't have any problem with TeamViewer.

Ofcourse, any other page or app works fine on this WiFi, and the most interesting thing is that I have a Windows laptop with TeamViewer installed, and on Windows, TeamViewer works fine on the same WiFi network that both my MacBook Pro and my iPhone can't connect!

I called my ISP but they can't help me.

I'm pretty sure that it has to do with my router, like something is blocking teamviewer to reach it's server, but I can't find it... I even tried to restore my router to it's factory settings and disable the router's firewall, but the problem still ocures... Note that the router is a Belkin one and it's firmware it's up to date.

Please, can anyone help me??

Tagged:

Comments

  • Esther
    Esther Posts: 3,145 Community Manager

    Hi @Mirella

    Thanks for your post.

    Maybe this article helps you to check the settings on your router and whether it allows your Mac and iPhone to maybe use Port 5938:

    Which ports are used by TeamViewer?

    All the best, Esther

    Community Manager
  • I tried it, but can't make it work... I'm uploading this screenshot, so check if I entered something wrog (ofcourse I clicked "Apply Changes")... Any other ideas?? I even have firewall on the router disabled...Στιγμιότυπο 2019-01-15, 17.46.09.pngΣτιγμιότυπο 2019-01-15, 17.49.32.png

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!