link icon
Ask The Community

TeamViewer is one of the winners of the European Customer Centricity Award 🥳

Please find more information here.

14+ TeamViewer msi Account assignment

Hi, I'm having troubles with a previous working script. 2 Months ago it worked fine but now the account assignment aren't happening. Tested on various systems and various settnings...

msiexec.exe /i "TeamViewer_Host.msi" /qn CUSTOMCONFIGID=X IMPORTREGFILE=1 APITOKEN=X ASSIGNMENTOPTIONS="--group ""X"" --grant-easy-access"

The Help me Button Works as expected but the client won't be added to my list of computers. Tested with various modules(API TOKENS/ID).. Same error

What have i missed ? Same scripted worked fine 2 months ago...


  • Sven_F
    Sven_F Posts: 22 Staff member 🤠

    Hi @Fetakungen 

    your command looks fine and should work. Maybe you run into a specific problem that can only be seen in the log file. I would suggest you to get in contact with Support in order them to analyze your specific problem.



  • TV4
    TV4 Posts: 4
    I have the same problem and I need to fix it. I can manual assign them from Desktop, but I want to do it during WDS from SCCM. It worked fine 2 weeks ago. :( I get this error: API: - Error-Name: internal_error - Error-Description: A group with the same name already exists for this account. Please choose another name. - Error-Code: 3 - Error-Signature: - 2019/02/04 09:42:51.431 5896 564 C0!! DeviceAssignmentStarter::Run: device assignment failed with 204
  • TV4
    TV4 Posts: 4
    Look like I fixed it. I downloaded a new .MSI and replaced the "broken" one. Now it look like its working again.
  • Sven_F
    Sven_F Posts: 22 Staff member 🤠

    We identified a bug with group assignment and fixed it. There is no need to download the msi again - just re-try assignment and it should work

  • rkohler
    rkohler Posts: 3

    New 14 Version not work on TeamViewer msi Account Assignment