teamviewer.com link icon
or
Ask The Community

Error: You established and aborted connections too frequently?

13

Comments

  • elx
    elx Posts: 1

    I have  to chime in and agree here. There are enough bugs and holes to jump through when setting up TeamViewer--multiple aborted logins are kind of par for the course. This timeout/security parameter should be left up to the user to adjust in Preferences; or there should be some quick way to override, like e-mail validation or 2-factor authentication.

    I can't complain too much since I'm using the free license just for my home, but this happening to someone with a paid license during an important meeting would be a disaster. It really is something you folks should consider changing if you haven't already.

  • Hi Scotty.

     

    I am sorry but you (when I say "you" I mean the whole TV support who have answered to this thread) keep running away from the main point brought up here by most of the users.

    I believe most people who have commented here will agree that WE UNDERSTAND the security need of this feature, HOWEVER, you cannot apply something like that WITHOUT warnings to the user. In ANY kind of system there will always be some kind of warning or notice that failure attemps will have a cost, and this cost NEEDS TO BE INFORMED.

    If you could at least:

    1) Warn the user BEFORE IT HAPPENS that after "x" attemps it will get locked out; and/or

    2) Inform the user HOW LONG WILL TAKE to get the connection restored

    If you would only apply those two things I am 100% sure that this thread (and others similar to it from my Google search about the issue) would be reduced drastically and less worry for you too. LET THE USER KNOW HOW IT WORKS in as much advance as possible, that's really simple.

    I am not even going into the details of DoS technical details (as I agree with other users that this has nothing to do really with DoS attacks), just implement that and I believe most people will be happy.

    I have a 12v paid license, and have been unable to help a staff of the company I am System Admin at because of that.

    PLEASE LISTEN TO YOU CUSTOMERS, that's all.

    Regards.

  • I've been waiting for an hour and still cannot connect .

    Ho wlong are we supposed to wait?

    this is ridiculous.

  • Scotty and other admin - your attitude towards paying customers that are complaining about a feature that is clearly broken ( you guys state 10 minutes - some of us have to wait hours) isn't going un noticed. We are an MSP, have hundreds of remote agents and are now moving away from TeamViewer. Great going and we are going to make sure we let all of our other MSP's we deal with what garbage and **bleep** service you guys provide,

    We had 3 remote nodes that have DEDICATED agents installed start doing this today. Client had an ISP issue which we were assisting remotely and since the connection dropped every few minutes we got "flagged" by this POS software and now cannot log in. Had to sign up for another service for remote support and since TV made us do that we are moving ALL of our clients to new solution.


  • @sharlow wrote:

    This should really be changed to only count failed logins.

    This limit just hit me when connecting to a flaky machine, I've disconnected and reconnected about a dozen times in the last two minutes and now it's telling me I have to sit and wait.

    Brute force protection is a good thing, but valid correctly-authenticating connections are not a brute force.


    I want to second this. I have a linux web server that I check every morning and every morning I need to attempt to connect to it between 3 to 6 times for TeamViewer on this server to "wake up" and start accepting logon requests. Sometimes it doesn't wake up and I exceed the number of times I can connect.

  • You know what Scotty?  You can go **bleep** yourself.  Take your **bleep**ing time limit and shove it up your **bleep**.

  • pvd
    pvd Posts: 1

    I agree that you need security but I now sit waiting for "some time" which may be 15 min just because my connection dropped and I pressed retry too often. SO.. 

     

    I fully agree with implementing security, BUT let me access the management console and remove the lock in 1-2 min rather than wasting 15 min of my time and more importantly wasting 15 min of my customers time - I'm just losing money/time/patience, my customers are losing faith in me fixing the issues they have and thats far far worse. 

    I also note that any progreammer with a small brain could implement a try 4 times then sleep 15 min then try again process - this is not the right fix but thats another thing... 

    so in summary yes please do keep me and you secure but let me have some control rather than using the brute force method of a timeout.   

  • How could it not be exact and why don't you know how long it is? 

    What happens if I try to reconnect before the mysterious timer completes? Does the "several minutes" restart? 

    Serioiusly rediculous that these details aren't given. 

  • TMuir
    TMuir Posts: 1

    Absolutely. When you've got a customer on the other line and you tell them to "wait a while", you can imagine what sort of reaction you will get. 

    Actually, I don't have to imagine. It is the same reaction I have right now - cancel the subscription and use a more user-friendly product.

  • For those of us running Windows 10, QuickAssist seems to work reasonably well and isn't handicapped by Teamvier's **bleep**ery.


    @TMuir wrote:

    Absolutely. When you've got a customer on the other line and you tell them to "wait a while", you can imagine what sort of reaction you will get. 

    Actually, I don't have to imagine. It is the same reaction I have right now - cancel the subscription and use a more user-friendly product.


     

  • Wish I could, but our IT blocks all the other sites and I can't connect to them.  Lately TeamViewer is dropping every hour or so.  I used to say connected for days.

  • Dear whomever at Teamview is ignoring this post - I am currently sitting on my hands because I can't get into a machine.  YOU **bleep**.

     

  • Lopik
    Lopik Posts: 1

    How long is "a while"? I didn't do even one succssful attempt while the other party was online. This is just pure stupidity from Team Viewer..

  • Natascha
    Natascha Posts: 1,291 Senior Moderator

    Hi there, 

    Thank you for your messages.

    I recommend you to restart the TeamViewer service on your Windows devices.

    -Execute "run", type "services.msc" and press OK

    -Now find TeamViewer, and restart it by doing a right click.

    Then, restart the TeamViewer application - the best would be to restart it on both sides. It should work again.

    I hope this could help. If not, do not hesitate to contact us again.

    All the best,
    Natascha

    German Community Moderator [on Parental Leave 🙋‍♀️]
  • cirEOak
    cirEOak Posts: 5

    @Natascha 

    How are we supposed to restart the service on a remote computer when we can't connect to it?  If we have configured the TV application properly on the end-user's machine, then the end-user will not be able to restart this service because they lack elevated privileges.  And even if they had the proper privileges to restart the service, this is an ineffective bandage at the most.  The end-users’ machine could be rebooted, which would essentially restart the TV service, but this has proven to be ineffective in several instances.

    What we are all saying in this thread is that the suggestions of TV staff in the past simply do not work.  The messages TV gives us are vague and leaves us in the dark when we are trying to give our clients an estimate of when we can help them.  This is a huge embarrassment when we are trying to support an and-user and we are clueless as to what is preventing us from connecting to their supported workstation.  The lack of any useful detail makes us look like we don’t know what we are doing.

    This is a real problem; not just a picky complaint.  I hope, out of respect for all paying TV customers, you have read all the other comments in this thread before posting.  Many agree in this thread that TV staff are not facing this issue directly, and ultimately this lack of response will drive many of your paying customers to use another solution.  I imagine there are many others who are having this problem, but simply do not waste their time to post on this thread.

    Your response is adding to the continued lack of attention from the TV staff.  It seems that TV staff in general are either (1) not able to actually fix this problem and won’t admit it, or (2) refuse to spend any time in fixing it.  I am dumbfounded that after all the people that have weighed in on this issue, TV staff continues to ignore this problem.

  • Natascha
    Natascha Posts: 1,291 Senior Moderator

    Hi @cirEOak 

    Thanks for the detailed post. 

    I clearly read all the comments before, because I need to know what I'm talking about before I post an answer. The Brute Force Protection is really necessary to protect our users from Brute Force attacks. 

    Therefore, we exponentially increase the latency between connection attempts. 

    Can you at least try to restart the service on your side? I'm aware, that not every user on the remote side has enough permissions to restart services or exit TeamViewer at all. 

    Please make sure to use the right passwords before you try to connect.

    Have a nice day,
    Natascha

     

    German Community Moderator [on Parental Leave 🙋‍♀️]
  • cirEOak
    cirEOak Posts: 5

    @Natascha 

    Why are you all so defensive?  It's like no TV staff can get past trying to defend the product.  There are some obvious flaws regarding the lack of helpful details in error messages.  The actual issue itself is one thing, but details about the issue (especially how long we are locked out) are just as important.

    To answer your question, of course I have tried to restart the TV service on our end.  For this issue, I have rebooted over and over and have even had the end-user reboot their machine over and over, to no avail.  The HUGE issue is lack of details from the TV error message.  We have no idea how to troubleshoot.  Is it a DNS issue?  Is it a service issue?  Is it an IP issue?  We don't know because all we get is, "You established and aborted connections too frequently.", when we were simply trying to connect to a supported client that is part of our supported computers, listed in our TV inventory, with a local password set.  The correct password was used.

    But here we go again.  We (the paying customer) mention something, and TV responds with more unhelpful information.  If there is more response from TV, then please make it helpful!  Stop being so dang defensive because it appears that TV has a stronger effort to focus on defending it's product rather than understanding what we are facing.

    I am unsubscribing from this thread because since 2017, there has been nothing useful to help us find some resolution to this issue.  These unfriendly and unhelpful responses from TV have caused me and several others a ton of stress.  Most other products that I pay for have a support staff that actually listens to their customers and provides solutions.  I can't say that I have received that from TV.

  • Bonde
    Bonde Posts: 2

    I think this ia a OK feature, But on my maschine I hace 4030192 seconds before I can login again. What Do I do

    Joergen

  • Bonde
    Bonde Posts: 2

    At least the remote owner should be able to reset this behaveur. Please give me a reason how the timer rised to 4030192 seconds, This is silly....I have paid for this program, and some times use it on the same customer several times a day. I have never read that You have a limited use of Your product. 

  • I'd like to prefer that the TV server (not the remote client which may be behind a flaky internet) give the option to authenticate or reauthenticate my connection to TV. I'm getting locked out after reattempting connections numerous times, but with 30 seconds between the attempts.

  • Tim365
    Tim365 Posts: 2 ✭✭

    Dear Natascha,

    I am hoping you can help me. 

    I run a series of workshops entitled 'Providing Support Excellence' and I would very much like to quote this email in a workshop. 

    I appreciate that English may not be your first language and I will certainly mention that in any quotation used.

    It would be great if I could have your permission as I think this would be an excellent example for me to use.

    Many thanks and best regards,

    Tim Smith.

  • Jpasalis
    Jpasalis Posts: 1

    I've been a paid subscriber a little over a year and this is the first time I've run into this issue because I was trying to connect to a customer with a bad internet connection. I understand the reason it happened, what I don't understand is there's no specified time that I have to wait, which is frustrating because my customer and I have to just sit and hope it's 10 or 15 minutes.

    Maybe there should be a message on the host side that would alert the customer there have been several failed attempts so they can reset the lockout and allow the connection instantly.

  • Clumpton
    Clumpton Posts: 1

    I have just been hit by the same lockout while trying to help a family member.
    Their router needed rebooting so I just kept on trying to connect, not realising that I would get locked out for my sins.

    I have read the whole thread and I too am astonished by the lack of understanding by TV staff. We all realise the need to avoid Brute Force or DDoS attacks, but trying to use the TV client to connect to a non-responsive host can hardly be classed as either. I made 10 attempts over a period of 5 minutes - checking the log they were all logged as:

    CCreateClassicSession::HandleRequestRouteResponse(): Response: [email protected]

    Then of course it became:

    CCreateClassicSession::HandleRequestRouteResponse(): Response: [email protected]=

    May I remind you that your "hacking" protection was triggered by trying to connect to an unresponsive (off-line) host, no passwords were involved. Perhaps you could review your code so that initial connection failures do not count as Brute Force attacks?

     

  • jofsav
    jofsav Posts: 1

    I have read the whole thread and I too am astonished by the lack of understanding by TV staff. We all realise the need to avoid Brute Force or DDoS attacks, but trying to use the TV client to connect to a non-responsive host can hardly be classed as either. I made 10 attempts over a period of 5 minutes - checking the log they were all logged as:

  • LSWBAC
    LSWBAC Posts: 3

    Thanks for your link to the brute force protection page. But this is not what is happening. 

    "It thus takes as many as 17 hours for 24 attempts. The latency is only reset after successfully entering the correct password." 

    We, as support representatives are 100% using correct passwords (usually in my case by way of having a saved computers list for sites we look after, and passwords for sites set by group policy etc) this happens after multiple SUCCESSFUL attempts to connect off the back of flaky connections. 

    This has been reported for over 2 years and there have been no improvements. Including no reply to the guy who was blocked from connecting to his own machine for 6 weeks as a result of this poorly thought out, poorly executed strategy. 

    Also someone at TV needs to look up what brute force means, likewise DoS. Trying to support your customers is not that. Trying to reconnect over a flaky connection is not that. Trying to connect, for example 5000 times a second to multiple hosts with sequential password hashes is.  

  • tdenson
    tdenson Posts: 15 ✭✭

    This is so so so annoying. I've just flown on a 14 hour flight overnight to Amsterdam and am about to catch another flight. I'm trying to fix an urgent customer problem and in my sleepy state I mistyped the password a few times. I am now locked out and cannot fix their problem before my next flight. Thanks a bunch TV !!!

    How can TV be so blind to this nonsense, this thread has been running for literally years and nobody has even acknowledged yet that this "feature" doesn't make any sense from a security point of view.

  • Tim365
    Tim365 Posts: 2 ✭✭

    Yes, @tdenson, it beggars belief that TV have simply chosen to ignore all of their customers who pay not inconsiderably to use their product. As you say, this has been going on for years.

    To help illustrate this point, here is a diagram of all the **bleep** they give about their customers;

     

     

     

     

     

     

    Did you see them? No, me neither.

    Good luck!

  • ebunick
    ebunick Posts: 4

    @JoshP I see you have just read this enough to correct the recent misspelt swearing - could you possibly grace us with any indication if this is ever likely ot be fixed?

  • LSWBAC
    LSWBAC Posts: 3

    Worth noting that a moderator was on here within 3 minutes to make an edit for a bleep edit. 

    Still over 2 years for a satisfactory response to a widely reported issue. 

Sign In or Register to comment.