File transfer speed still slow as ever



  • drandre
    drandre Posts: 2 ✭✭

    No, this is not limited to the free version.  We paid for our version and it does the same thing and appears to be the same issue with the newer versions. 

    We use another provider and the file transfers are fast. 

  • sorh
    sorh Posts: 1

    This issue isn't solved and all julia does is repeat the same lines over the years.

    At least be sincere to us and admit Teamviewer doesnt give a **bleep** about file transfer speed and is not working on that.


  • Leo69cn
    Leo69cn Posts: 2 ✭✭

    " Julia repeat the same lines over the years" ...Do not worry's coming google ...

    [link removed per Community Guidelines]

    for now it does not do the file transfer but soon it will do that too ...and if temviever will not do anything, I know that they will lose many customers who pay a lot of money for his licenses teamviewer run 

  • abri
    abri Posts: 3 ✭✭
    I noticed that this slow file transfer **** came about 2012-2013. Before that it was as fast as your internet connection would allow. Since transferring files between two clients is a really easy non-complicated task I suspect that they are using (forced?) a MITM filter or other kind of moderation. Blaiming it on UDP (with automatic fallback to TCP), well... duh. We've solved it by using WebDav, FTP and different cloud services for files instead of Teamviewer. Both the free and PaidLicense versions behaves the same
  • scatudal
    scatudal Posts: 2 ✭✭

    Same here,

    No mather where i connect it's always that slow. There is clearly some throttle going on with teamviewer. I ran a test one night at 3AM from one of my office servers to my system at home. Being the admin, i knew there was absolutely nothing happening that night, no maintenant, network was just quiet.

    Office link : 100/100

    Home link : 1000/1000 

    Yet... i simply couldnt go higher than 1mbps.... Tested with both a personnal free acount and our corporate one.

    Same test from our ftp server, i topped of the office link at 100mbps...

    As Abri mentionned, we now simply use other methods for large file transfers. Either cloud or FTP. It's a bit sad though, as it requires additionnal steps for no reason, when a simple drag and drop should work (as it does with Competitors such as Dameware).


  • filetransfer
    filetransfer Posts: 1

    til now your file transfer feature are too slow! we pay for your software but we are not satisfied to transfer speed. please fix it!! patch it!

  • Busser
    Busser Posts: 3 ✭✭

    Hi TeamViewer

    Will you please work on the Transfer speed in your product.

    Transfer 800MB takes on 1Gbit internet connection about 1.5 Hours.

    Upload to dropbox and then download it on the client computer 2 min max.

    Cant be right that we are paying a licens for this ...

  • rcorrea
    rcorrea Posts: 1

    Two years after this post, I'm having the same problem and I can't find a possible solution from Teamviewer staff people.

    Does any one knows what's a possible solution? I'm working on a Mac Mini, 3.2 GHz Intel Core i7, 16 GB 2667 MHz DDR4. Internet speed on both ends is over 100 Mbps.

  • gwg
    gwg Posts: 1

    how do you tell if the connection is UDP?

  • JoeBeau
    JoeBeau Posts: 2 ✭✭

    Uh, nice story, but why did this network problem never occur with version 11? I only 4an into real slow downloads after TV forced me to drop version 11 and go to 14 (I think that is the current one). I see several complaints after version 11 here. Yet, you make no mention of how you hobbled TV after that version to explain the drastic slowdown. No explanation except the gods willed it? Hm, not buying that..

  • RichaarK
    RichaarK Posts: 1


    I've never seen or heard such a pathetic explanation for excruciatingly slow file transfers.

    Please find another excuse.


  • millsaz
    millsaz Posts: 6 ✭✭

    Dear TeamViewer,

    As and IT Professional I use file transfer often in prior versions, but it seems this is the worst file transfer speeds ever in 14.  I don't understand why this wouldn't be a priority for a product improvement since I believe most of us need file transfer.

    I have tested the transfer speed using a 300/300 Mbps Fiber connection on both sides with 56kb modem TV file transfer speeds.  I have done file transfers on my local 10Gb network and see a very minor improvement.  

    As others have stated using UDP is 90's technology when you have TCP, but it doesn't make any sense why you would throttle the speed.  Now if it's an issue with screen refresh then all you need to do is use some type of QOS policy to utilize the connection full bandwidth, but make screen processes the priority.  TCP allows for resume so you should be able to pause file transfer and resume to keep screen refresh, keyboard, and mouse active at all times.

  • RobvanRooijen

    This solution is not really a solution. I have tested several systems for remote support and when I tested TeamViewer a movie of 5 Gb was send in a minute or so. 

    So now we choose TeamViewer and I'm busy to explore all features and now the file transfer speed is 2 Gb in 4 hours.... I'm still using the same test systems as before, also the TeamViewer version did not change, so what can I do to speed this up?

    Kind regards,


  • beast-usa
    beast-usa Posts: 80 ✭✭

    Two and half years later and this is still a problem in the newest version?

    So I saw 200MB/s possible?
    Testing on two of my computers on my router 10/100/1000, confirmed Anti-Virus WAS NOT BLOCKING UDP. File tranfer between computers Linux to Windows, Windows to Linux via share 123 to 153 MB/s. Start transfer on TeamViewer 128 to 130 KB/s! Use UDP checked on both under advanced options. They are three feet apart on the same router and still 130 KB/s MAX.

    I wish you guys would really fix this it's just nuts it's been over two years. Then dump the HUGE horrible new interface!

  • ASmMT
    ASmMT Posts: 1

    Still no fix?!?

  • glnz
    glnz Posts: 44 ✭✭

    I recently added one of TV's free competitors to my personal computers, and its transfer speeds are fine.

    TV - what is the problem?

  • Whoolie
    Whoolie Posts: 1

    The reponse from TV is **bleep**. Is this not peer-to-peer? Well, it sure seems like it's going through TV servers. This is during a slow file transfer:


    So what you've done is that you've throttled the speed to keep costs down for traffic handling - why not just say that? Well,  you probably don't want people to know that their file transfers are going through your servers.

  • AlexFogerty
    AlexFogerty Posts: 35 ✭✭

    Hi Julia, your post explains so much, including another issue I have with TeamViewer, the file transfers often end up corrupted and unusable. The problem with UDP is that it has no error checking, and should only be used for the likes of video where data arriving out of sequence or corrupted can safely be ignored (e.g. the video component arriving after the audio, or vice versa), which explains the corruption of data issue.

    We have got to the point that we are using cloud based storage systems to transfer files to clients, or if they're close by, using USB flash drives.

  • cpmcgrath
    cpmcgrath Posts: 2 ✭✭

    Hi @Julia et al,

    For the life of me I can't figure out how the UDP port is being blocked. I've allowed an Outbound rule in the Windows Firewall, All Egress traffic on any protocol is allowed through the hardware firewall.

    Is there any logs we can turn on to figure out exactly what's happening and give us a clue to figure this out?

  • kilyan
    kilyan Posts: 2 ✭✭

    the port stuff is just **bleep**, with upnp it opens just the ports used, and i have the same problem

  • cpmcgrath
    cpmcgrath Posts: 2 ✭✭

    Well, I found the log, and it makes it pretty clear that UDP is not getting blocked

    I would post the log but your website isn't letting me. I emailed it to support @ teamviewer which told me to use this site instead where I can't post the information that shows a udp session successfully connecting, getting these errors (Edited to make them be able to be pasted here): 

    DataTransceiver: DataTransceiver - FileGroups::GetFileGroupByFileIndex: index is out of range
    DataTransceiver: DataTransceiver - FileTransferProgress::GetCurrentTransferredFilePath: fileGroup is null
    DataTransceiver: DataTransceiver - FileTransferProgress::OnFileAdded: fileGroupCount LESS THAN OR EQUAL 1

    and then getting capped at 120 kb/s

  • DKE
    DKE Posts: 4 ✭✭

    Any news on this annoying topic?

  • Broffrey
    Broffrey Posts: 3 ✭✭

    I've been using TeamViewer since version 6 or 7, and version 12 is still shockingly slow. Big big disappointment!

  • Broffrey
    Broffrey Posts: 3 ✭✭

    I've been using TeamViewer since version 6 or 7, and version 12 is still shockingly slow. Big big disappointment!