teamviewer.com link icon
or
Ask The Community

QuickSupport predefined password stopped working

We use a custom QuickSupport module that our customers can download. We also provided a predefined password which worked fine until last friday. All of a sudden we received a password failed message. I've tried to set a more complex password but that doesn't solve the problem. And yes, i've triple checked the password but it keeps failing. We now changed our quicksupport to random password and that seems to work fine. But we would like to use a predefined password again. Can you please help us with this issue ?

Tagged:

Comments

  • JeanK
    JeanK Posts: 5,794 Community Manager 🌍

    Hello @hvdheurik,

    Thank you for your message.

    Indeed, it is possible to use the QuickSupport with a personal password. But this only work if you connect to a computer which has no full version of TeamViewer installed.

    What we also recommend you to do, if you are connecting regulary to people and want to use a permanent password, is to use the TeamViewer Host on the remote side and to set up unattended access.

    I hope this could help. If not, do not hesitate to ask your questions here.

    Cheers

    Jean

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • hvdheurik
    hvdheurik Posts: 3

    I did some more testing and the problem happens when the other side (our customers) have the latest version of Teamviewer installed. Previously we could instruct our customers to shutdown their installed Teamviewer version and then start our Quicksupport module. Then our predifined password works fine. To be more specific, i did the following test :

    Customer : full version of Teamviewer 14.1.9025, let him shutdown that and start Quicksupport, everything works fine !

    Customer : updated the full version of Teamviewer to 14.2.8352, let him shutdown that and start Quicksupport, doesn't work anymore, our password doesn't work

    Customer : removed full version of Teamviewer and installer full version 14.1.9025 again, now everything works fine again.

  • hvdheurik
    hvdheurik Posts: 3

    Any update on this issue ?

  • KarlM
    KarlM Posts: 1

    I am sorry but I think it is a terrible choice!
    In order to make remote support as easy as possible to our customers, we created our customized QuickSupport executable with a predefined password so we only need the customer's ID.
    We install that executable in the same folder as our software so it can be run by our software when the user needs assistance.

    Now, you are forcing us to:
    - Search for a possible installation of TeamViewer on the customer's computer.
    - If found, run it; otherwise, run our QuickSupport module.
    - Discuss with the customer to know whether the TeamViewer program looks like the full version or the QuickSupport version (note that the customer may be a complete novice unaware that TeamViewer might have already been installed by an administrator for any other reason!)... And eventually ask for the randomly generated password if the full TeamViewer was found.

    What a huge waste of time for both our customers and us! Please please please reconsider!

  • image_instruments
    image_instruments Posts: 1
    edited April 2021

    We have the identical problem for weeks and can 100% confirm KarlM´s comment:

    "What a huge waste of time for both our customers and us! Please please please reconsider!"

    Currently, the only way around for us is to use [Third party product] or [Third party product].