teamviewer.com link icon
or
Ask The Community

Windows 10 does not look to start service until logon

1235

Answers

  • bakahk
    bakahk Posts: 1

    12.07.2017r. => Autologin problem with 12.0.78716 [PROD_ID] / 12.1.13180.0 [FILE_ID]


    Windows 2016 => Windows Update @ 100% / Windows Defender OFF / Windows Firewall OFF / UAC OFF => v10.0.14393 Build 14393 => NOT ok;


    Windows 10 => Windows Update @ 100% / Windows Defender OFF / Windows Firewall OFF / UAC OFF => v10.0.15063 Build 15063 => ok;


    NOT ok = TeamViewer Service don't start (even after logging in);

    p.s for example "AD" v3.4.0 works ok;

  • BenMcLean
    BenMcLean Posts: 3

    I'm seeing similar behavior on one of my computers. TeamViewer won't start until after Windows logon despite having the box for fixing that checked.

  • masterseo
    masterseo Posts: 1

    They released it and I did a complete uninstall and fresh reinstall of the new build and nothing changed. Actually both of the pc's I access jasa website remotely now I can't access once they signoff. TV worked so flawlessly for so long, I am a bit discouraged with this.

  • jkelly
    jkelly Posts: 1

    Hi,

    I'm fully willing to accept that something has changed in recent versions of Windows that provokes this problem. However, in case it can help, I thought I'd post my latest expereince.

    I installed Teamviewer 12 on a Windows 2012 Essentials R2 server and had the same problem--impossible to connect if a user is not logged in. But installing the Teamviewer 8 client resolved the issue for me. So sufficiently older versions of Teamviewer don't elicit the problem. (Teamviewer 8 on Windows 10 has worked repeatedly for me as well.)

    -Kelly

  • M4CC4
    M4CC4 Posts: 4

    I am too having problems with TV 11 on Windows 10. I have TV installed on a dual boot laptop and the program works fine on Ubuntu but I cannot connect when I start the machine in Windows 10. I have installed the version 12 [hotfix] on page 4 of this forum no joy. I even installed version 8 [as per a previous suggestion] no joy. I am sure that this is a local Windows 10 issue as I have another machine with the exact same dual boot set up and TV works in both OS's on that machine. I have checked firewall and network settings and they seem identical. Would be happy to share any logs with someone technically asstute enough to interpret them. 

    Thanks for any feedback.

    PS this situation started only after trying to upgrade the errant PC [Windows 10 running] to TV 12...when it did not work I tried reverting back to TV 11 and the problem persisted. 

  • Jnew1
    Jnew1 Posts: 3

    It is obvious that they are not going to fix v11.I have been waiting to see if they would, but it is clear now they won't. I already bought v11 and won't start a subscription to get v12. I will be moving on to another app that I know works, and doesn't involve a subsciption. Kinda sad that you can't use something that you paid for. I really like teamviewer but it's time to move on.

  • Hi @Julia.

    The issue still persists for me. My Windows and TeamViewer version are both the most recent one up to today.

  • Is this for Teamviewer 11 or 12?

  • Its for Teamviwer 9. But its hould work for any Teamviewer version by changing the arguments in Step 5.

    For example If you have teamviewer 11,

    use the arguments:

    stop TeamViewer11

    start TeamViewer11

  • Hi Julia,

    what about us that have paid the v11 version and have premium licence?

    Are we supposed to pay again for the upgrade to v12 ???

    I'm running the latest release of TV 11 in combination with the latest Microsoft update and the problem persist, i can't connect to remote computer if the user is not logged on...

    Is there solution in sight?

    Cheers

  • Just use the solution but chaging the arguments only for teamviewer 11, It works great for me.

    http://www.maceit.co.nz/windows-10server-2016-teamviewer-freezes-signout-switch-user/

     

  • Thanks Dev_singh i saw your solution and it's great but i would be happier with the official release that solves the problem from TeamViewer....

  • I opened the xml file in Note, changed the arguments to Teamviewer 12, then imported into Scheduler, which seemed to go ok.  When I I tested by rebooting, though, no effect.  I looked at the schedule history, and the task seems not to have even run on the reboot.  Any suggestions?

    Latest versions of TV and Win 10 Creators.

    Thanks,

  • Its working fine without any issues here on server 2016 and windows 10 creators update.

    Can you please check the service name is Teamviewer12 without space in the task.

    also you can try addding another trigger in the same task which happens at startup.

    Thanks

    dev

  • Dev,

    Thanks, but I don't know how to do what you asked me to do.  As I mentioned, I imported your xml file directly and changed to TV12 but nothing happens.

    Dev and all watching this issue, I would kindly ask for your assistance.  I have three machines, two running Win 10 Pro Creators and one Win 10 Home Creators.  Latest TV 12.083369 on each.  One Pro machine and the Home machine work like a charm.  However, the other Pro machine steadfastly refuses to cooperate.  The fault is clearly in my stars - some of the settings on my bad Pro machine are not the same as on the others, but I am not smart enough to figure it out.  If someone could help me troubleshoot, that would be enormously appreciated!  

    Thank you

  • Maurice
    Maurice Posts: 10

    For TeamViewer 11 and 12 the version number was removed from the service name, so it's just "teamviewer" and not "teamviewer12". This task will also only help if the service becomes unresponsive/deadlocks for some reason. If there's a different issue it won't help.

    Maurice
    Software Developer
  • zoo55
    zoo55 Posts: 9

    Maurice,  

    Thank you for the clarification.  I note that TV is not "stuck" - it simply will not start on its own after a reboot.  So, I suppose that means the recent fix posted here is generally not useful in this situation, but I will try it again with the different task name.

    As a developer, though, do you have a suggestion as to what is keeping one of my two Win10 PRO machines from working properly as mentioned in my prior post?  (I would prefer not to use an outside fix if possible.)

    Thank you,

  • Maurice
    Maurice Posts: 10

    @zoo55: Really hard to tell without more information. There are too many things that could go wrong that would lead to the problem you describe. If possible open a support ticket.

    Otherwise here are some things that might help:

    If the serivce (teamviewer_service.exe) isn't running, check that the start type of the service is set to automatic. If it's set to automatic but the service is still not running then either the service crashes repeatedly or there is another software that prevents the service from running. If it was set to manual but you did not do that yourself, there might be some other software installed that thinks it's a good idea to change service settings.
    If the service is running but the GUI process (teamviewer.exe) is not running after you've logged in to Windows, check that the "Start TeamViewer with Windows" option is checked. If that's the case but it's still not running, again it might have crashed or there is something else that prevents it from getting started.
    If the service is running but the PC isn't reachable until a user is logged in (which was the original issue in this topic), then that PC might not even be online at all. If it's on WiFi, check my post here: https://community.teamviewer.com/t5/TeamViewer-12/Windows-10-does-not-look-to-start-service-until-logon/m-p/6254/highlight/true#M2432
    If it's not on WiFi, or other services work (e.g. RDP) you can also check the firewall/antivirus logs to see if there's anything related to TeamViewer.

    Maurice
    Software Developer
  • Hi there, which folder i Task Scheduler should the TeamViewer_Fix_Task.xml be imported into?

    Should I set the system in "Configure for" to Win10 if I have a Win10 computer?

    At the moment I am testing this script on a computer with Win 10 Pro in a Azure AD domain. Latest update in Win 10. More than one user profile on the computer. TV11 has worked flawlessly up until now.

    Per Lund
  • zoo55
    zoo55 Posts: 9

    I just did a "Refresh" of Win10 Pro / Creators and reinstalled TV 12.0.83369.  All is good now - restarts on its own after reboot .  I suspected it might be a problem on my end after 3 of 4 pc's worked and only one did not.  Refresh is a bit troublesome but it worked for me.  Thanks to all for your help/suggestions on this.

  • jsa
    jsa Posts: 1

    We have updated 2 Dell PC's last sunday. They both have teamviewer 13.

    Teamviewer doses not work on one of them - but the other has no problems.

    We can start the teamviewer but we are not able to use it as remote.

    Is there any solution to this?

  • Hello,

    So f I understand it good, there is an sollution in the new releases of TV strarting from TV 12.

    But what for the users that are using TV 11? How van they solve this problem?
    We have 200 computers, but we are not able to connect to them when a user is not logged on.

     

  • I'm having this issue with TV8 as well.  What are we supposed to do to fix it?  

    I haven't seen any confirmation that this bug is fixed in 12 or 13, so until then, I have no incentive to upgrade only to have the same problem with my Windows 10 1709 machines.

  • Problem still exists in Server 2008R2.  Exists in Server 2016 Essentials.

     

  • So it is completely fixed in Windows 10?

  • Try to use the solution but changing the arguments only in Task actions for your teamviewer version , It works great for us using it on hundreds of machines without issue

    http://www.maceit.co.nz/windows-10server-2016-teamviewer-freezes-signout-switch-user/

     

     
     
     
  • Any folder in Task Scheduler.

    You just have to change the service name for Teamviwer everything else is default or as shown at https://www.maceit.co.nz/windows-10server-2016-teamviewer-freezes-signout-switch-user/

     

    Thanks

     

  • Nx88
    Nx88 Posts: 1

    Hi all, this is to let you know that the issue still exists. In my case, I tried TeamViewer Host on Windows Server 2016. Maybe the method to communicate with the servers when the service starts was different in the old v8, as it still works correctly on the same machine.

Sign In or Register to comment.