link icon
Ask The Community

TV 14 GPO Deploy - Cannot Grant Easy Access

Trying to deploy TV 14 via GPO to our workstations. We've been able to configthe CLI command to deploy them manually which works perfectly. Assigns it to our account, grants easy access, and applies the TV settings that we have setup.

When we try to deploy TV 14 via GPO, we use the ORCA tool to generate the Transform set, as per the documentation here :

When we do this, TV installs perfectly, picks up the settings, however it does not grant easy access. I've included a picture of our settings in ORCA incase anybody wanted to see if we've setup anything wrong on our end.

Any help on this would be SOOO greatly appreciated.TV14_orcaSettings.jpg





  • Izem
    Izem Posts: 5 Staff member 🤠

    Hi @reechard,

    Thank you for your post.

    The options you are setting are correct, however I advice you to add "--reassign" in the ASSIGNMENTOPTIONS.

    Alse please check this article about Mass deployment improvements:

    Hope it helps.

    Best regards, 


  • reechard
    reechard Posts: 4

    Hi Izem,

    I've added in the --reassign flag in the ASSIGNMENTOPTIONS part of the transform file. Still not able to get our TV deployment to assign to our account. Since it cannot be assigned, Easy access cannot be granted.

    Any ideas on this? It works fine when we run the CLI command. but not so when we deploy via GPO.

  • reechard
    reechard Posts: 4

    Also tried deploying thru PDQ deploy.

    Everything works EXCEPT the automatic account assignment.

    I've triple checked my APITOKEN and it is the one that is from the Design & Deploy screen on the Teamviewer management console.

    Any ideas?

  • reechard
    reechard Posts: 4

    Ever since we started using updated 14.2 version... now my CLI commands do not work.

    here's my command, I've blanked out the API Token of course.


    msiexec.exe /i "\\correctfileshare\correctpath\TeamViewerMSI\Full\TeamViewer_Full.msi" /qn IMPORTREGFILE=1 APITOKEN=insert_correct_APITOKEN_here ASSIGNMENTOPTIONS="--grant-easy-access --alias %COMPUTERNAME% --group Unattended"

    Easy access is not being granted, because account assignment isn't working. I've followed documentation here:**Please do not post TeamViewer IDs**

    which states that there's no more need for the assignment tool after version 13.2 

    Not sure why setting this up requires so much work? I'm extremely confused on what I'm doing wrong as I've put over 8 hours trying different commands, different order of commands into CLI as well as PDQ deploy as well as GPO Software deployment.  All of which get TV14 deployed, not a single one is able to automatically assign to my account...

  • BenedictPD
    BenedictPD Posts: 1 Newbie

    Hi Reechard, did you get a resolution to your issue? We have the exact same issue with version 15.28.5. We can't seem to find a way to get grant-easy-access assignmentoptions to work using Orca and produced .MST file. Would really like to hear from you!