High CPU usage

Options
KL3M
KL3M Posts: 2 ✭✭

I've noticed that Teamviewer is causing very high CPU usage at times on my PC. I'm not sure what's triggering it, but when it happens, it will be nearly 100% If I close Teamviewer via the task manager, the system goes back to normal. It's not very often it happens but I'm curious as to why.

The system is:

Ryzen 2700x, X470 board, NVMe SSD, 16GB RAM and Windows 10 and teamviewer is up to date.

Any ideas?

Thanks

Comments

  • mif555
    mif555 Posts: 1
    Options

    A lot of the advice on the internet about this is disabling hardware acceleration in the computer you are remoting onto. This is only possible in older versions of windows (i.e. pre W10). You go to display setting, advanced settings, troubleshoot, then turn off/reduce the hardware acceleration. 

    For Windows 10, I found that adjusting my Teamviewer settings helped. On the Teamviewer window: Extras>options>remote control tab. Change your Quality settings to custom. In custom settings, I changed the colors to high quality, the 'Quality' to highest speed and unclicked Fast video streaming and enable aero color scheme. So I had none of the options checked in the end. I am not sure what combination of these things worked but this worked. You could try one or all the things at the same time to see what it was that actually helped (I suspect the aero setting). Good luck!