teamviewer.com link icon
or
Ask The Community

I can't log in to Teamviewer in Windows 10

Hello,

I have Teamviewer installed in my computer with Windows 10 since time ago. When I open Teamviewer, and click to log in, it doesn't do anything, I have to log in "https://login.teamviewer.com", I have to find the customer I need, and then the Contacts window opens, and I can select or find all the contacts. It works, but if I reboot my computer, I must log in again on the web, if I want to use Teamviewer.

Have you ever seen this? Thanks in advance for your help.

ps: the problem began with Teamviewer 11, now I use Teamviewer 12 beta

Comments

  • Jonathan
    Jonathan Posts: 245 Former Staff

    Hi Aritu,

    Thank you for your post!

    Sorry you are having trouble logging into your account. You mentioned "When I open Teamviewer, and click to log in, it doesn't do anything." 

    When you open TeamViewer, is your sign in credentials already populated as pictured below?

    2016-11-14 15_56_22-TeamViewer sign in.png

     

     

     

     

     

    If yes, please try removing the password the entering it again and sign in. This should resolve your issue and if it does please accept this as a solution.

    Hope this helps!

    All the best,

    Jonathan

  • Aritu
    Aritu Posts: 2

    Thank you very much! It works!

  • modyeg1980
    modyeg1980 Posts: 1

    Thanks , worked for me also

  • Wolff
    Wolff Posts: 1
    Darn, didn't work for me.
    I get an error message:
    "Sign In request failed! The server did not respond. Please try again."
    I have tried again but the same error pops up.
  • GrahamD
    GrahamD Posts: 1

    Hi,

    I'm having this problem, and clearing and re-entering my password didn't work. I even reset my password on the web, but the Windows 10 client won't log in.

    As the OP mentioned, clicking the "Sign In" button does nothing. It becomes disabled for about half a second, then becomes re-enabled, but otherwise nothing happens.

    This only started today. Yesterday, the client opened fine. I even tried checking for updates, but it says it's up to date.

    Cheers
    Graham

    EDIT: (SOLVED) I clicked "Connection" -> "Exit TeamViewer". When I started it again and re-typed my password, it let me in. Just in case anyone else has this problem.

  • Jen_W
    Jen_W Posts: 1
    Thank you. I clicked Connection -- Exit TeamViewer and mine started working again also.
  • This worked for me too!
  • OliH
    OliH Posts: 1

    same here

  • MrAv
    MrAv Posts: 0

    This also works with a Mac

Sign In or Register to comment.