TeamViewer seeks proxy at startup even though proxy settings have been removed

Options
Palazzo
Palazzo Posts: 3 ✭✭

I added some proxy settings temporarily via Firefox to conduct some testing.

After testing I switched Firefox back to No proxy, but, since then, TeamViewer is prompting for a proxy login.

Teamviewer is set to "Automatically detect settings".

The proxy settings are still cached in Firefox but not active (see below)

Firefoxproxy.png

It looks like that TeamViewer does eventually ignore the proxy settings, but I'm concerned in case it causes a loss of connectivity when I Wake-on-LAN remotely to access my PC, so is there somewhere where I can purge the unused proxy settings being picked up by TeamViewer?

Comments

  • JeanK
    JeanK Posts: 6,995 Community Manager 🌍
    Options

    Hello @Palazzo

    Thank you for your message.

    Could you please provide us with more information in order to have a better understanding of the issue?

    Maybe could send us a screenshot that explicitly shows the issue on the TeamViewer level?

    Thank you in advance for your reply.

    Cheers

    Jean

    Community Manager

  • Palazzo
    Palazzo Posts: 3 ✭✭
    Options

    Actually - may have fixed it.

    Even though I have the poxy disabled in FireFox, looks like the values are still read by TeamViewer.

    I found:
    "2019/07/09 13:44:34.399 12732 13564 G5 ProxySearch: found Mozilla HTTP setting: proxy.xxxxxxx.com:9999
    2019/07/09 13:44:34.399 12732 13564 G5 ProxySearch: found Mozilla HTTPS setting: proxy.xxxxxxx.com:9999"

    In the logs.

    So, I blanked out these saved, inactive, settings in FireFox, and that seems to stop TeamViewer picking them up.

  • Palazzo
    Palazzo Posts: 3 ✭✭
    Options

    Hi,

    Apologies. I thought I'd posted an update, but can't see it here so must have failed to save it.

    I looked at the TeamViewer logs and found it was still reading the saved Mozilla settings for FireFox, even though they were not actively being used in FireFox.

    So, I set the proxy settings in FireFox back to "Manual proxy configuration", blanked out the saved proxy settings and then set FireFox back to "No proxy", and that seems to have fixed the issue.

    Looks like TeamViewer is therefore reading saved inactive proxy settings and, for FireFox at least, should be checking if they're currently in use within FireFox before attempting to use them.

  • thefowles1
    thefowles1 Posts: 2 ✭✭
    Options

    I'm going to necro this thread, because I'm having the same problem. I have a proxy set up in my FireFox settings, and TeamViewer detects these and literally forces me to use the proxy credentials or it will absolutely will not connect, even when FireFox is not in use. I have TeamViewer set to "no proxy", but it does not respect these settings. I do not understand why it's doing this; it seems highly invasive. I do not want to use a proxy with TeamViewer, but it will not let me connect if I don't. Why is TeamViewer even scanning for proxy settings for other programs to begin with?

    TeamViewer team, you need to address this. FireFox is not my main browser - Chrome is, and it has no proxy settings. I do not use a VPN otherwise. TeamViewer should not be locking me out without filling in proxy credentials, especially when I have the option set to "no proxy". @JeanK 

  • novaleaf
    novaleaf Posts: 1
    Options

    I also see the same error.  due to inactive proxy setting being listed in firefox.