teamviewer.com link icon
or
Ask The Community

msra.exe bad image error citing tv_x64.dll Windows 10 1903

We use TeamViewer to remote to a computer offsite and then use Windows Remote Assistance to help staff at that remote site as we don't have TeamViewer installed on all computers.  Prior to installing Windows 10 1903 we had no issue using remote assistance.  Since updating to 1903, windows remote assistance no longer works.  Receive msra.exe bad image error noting C:\Program Files (x86)\TeamViewer\tv_x64.dll is not designed to run on windows or contains an error.  We receive no errors with RDP only MSRA

I've uninstalled/reinstalled TeamViewer and still receive the error.  Has anyone else seen this issue or know of a solution. 

Tagged:

Best Answer

Answers

  • Julia
    Julia Posts: 290 Staff member 🤠

    Hi @lturkowski 

    I forward this to our development and will get back to you as soon as I received an answer :)

    Cheers,

    Julia
    Senior Support Engineer - 2nd level Support
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • We found that disabling UAC was causing this issue in v1903. We had a GPO/policy in place that set the following key:

    :: DISABLE UAC
    reg add "HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System" /v EnableLUA /t REG_DWORD /d 0x0 /f

    Once we enabled UAC again (set to 1) and restarted the machine we were able to use Remote Assistance (msra.exe).

  • Thank you Julia - that worked!

  • anthws
    anthws Posts: 11

    @Julia 

    Tried that link and got:

    This shared file or folder link has been removed or is unavailable to you.

  • Can we get the registry fix back? The link is empty.

  • The link is dead. Please can you provide a new one or just the registry keys?  I really need this solution. Thanks.


  • jlavetan
    jlavetan Posts: 1

    Add the following registry key in your Windows computer.

    Location: HKLM/sofware/wow6432node/TeamViewer/
    Type: D-word 32 bit
    Name: EnableHooks
    Decimal value: 0

    Then restart TeamViewer service and try again.

  • Thank you

  • Hi Julia,

     

    can you please send me the solution for this issue?!

    Thanks in advance

Sign In or Register to comment.