teamviewer.com link icon
or
Ask The Community

Teamviewer connects but Remote control shows Awaiting authentication

Hi all,

I am having a strange issue with logging in to one of my computers.

I have two PC's both running Xubuntu 16.04.2 (LTS version) and I have Teamviewer 12 installed on both machine's.

On only ONE of them, I have the problem that I can not completely log in. What happens now, is that when I log in (from any other machine, be it a Linux, Windows or MacOS computer) I see the remote desktop, but the log in screen is unavailable. It is covered by a Teamviewer Remote control window. The status "light" shows yellow and the text shows "Awaiting authentication". That is all. I can click on that window to no avail, but cannot get any further.

  • There IS a connection (I can see the login window/desktop.)
  • The system runs just fine (I can login through ssh from the other PC if I need to)
  • There is no real authentication problem, because right after a fresh install, it will work just fine for a couple of times.

I have already done a complete reinstall of the OS, so I guess that should not be a problem either. The other PC, also running the same OS and version, does not have the problem.

Any idea's what could be the problem? It is not a networking issue, as far as I can tell, since I do connect. It is just that after the connection, I am blocked or locked at the login screen.

Thanks in advance for any insights!

Patrick

Comments

  • jpgoossen
    jpgoossen Posts: 6

    As an additional note, sometimes the message I see is not "Awaiting authentication" but "Incoming connection". But it still will not proceed after that.

    Cheers.

    Patrick

  • jpgoossen
    jpgoossen Posts: 6

    For anyone experiencing the same problem.

    I deleted the .Xauthority files in the users home directory (this was about two Ubuntu 16.04.2 work stations) and that seems ti have solved the issue. I could now log in (after one reboot) and all is well again.

    Hope this helps someone else.

    Patrick

  • Harald-RS
    Harald-RS Posts: 2

    I have the same Problem under Windows 10 Creators Update.

    Mit freundlichen Grüßen
    Harald
    ----
    Sorry for my bad english. I speak only german.
  • jpgoossen
    jpgoossen Posts: 6

    Hi Harald,

    (I will stick to English for any other readers). I have the problem running Teamviewer on one of two Ubuntu 16.04 workstations. It seems to be dependent on the server (the machine I am trying to connct to). Both are similar, but one is Ubuntu 32 bit (and works), the other is 64 bit (and locks up as son as I connect).

    The network connections are fine (I do connect and see he login screen of the server I am trying to access).

    The client used does not matter. Whether I try to connect from a Windows 10, a MacOS 10.12.4  or a Ubuntu or OpenSuSe computer, all give the same result.

    At one point in time I seemed to notice that Teamviewer crashes as soon as I make the connection. So I set up the connection, see the login screen and try to login, and then... nothing. A reboot gets me back to the login screen but agai it stops there.

    Might there be an issue with 64 bit and Teamviewer?

    Cheers,

     

    Patrick

  • Jonathan
    Jonathan Posts: 242 [Former Staff]

    HI Harald_RS,

    Thanks for your post!

    Please refer to the following link to see what other users are saying about the topic you are asking about.

    https://community.teamviewer.com/t5/TeamViewer-12/Windows-10-does-not-look-to-start-service-until-logon/td-p/6120

    @jpgoossen, one of our Linux experts will review your question and provide feedback soon.

    All the best,

    Jonathan

  • jpgoossen
    jpgoossen Posts: 6

    So, another update.

    I removed Teamviewer completely from both computers (still running Xubuntu 16.04 LTS version). I made sure I included any settings that might have remained.

    Reinstalled Teamviewer (12, the version that was current) and made sure that I give the right for remote access by password to the account. Added the computer to my accout s well. And, Lo and behold, it worked, Both the 32-bit version on one PC and the 64-bit version n the other. I could log in on either, from any of the guests (Windows 10, Ubuntu, OpenSuSe 42.2, MacOS 10.12.4).

    Now, a few days later, I am experiencing the same problem again. I made no changes (as far as I am aware of) to the computers that run Teamviewer as a server. But, when I log in to the 64 bit version, I see it opening and showing the remote display, but the Linux Log in screen is blocked by a Teamviewer windows that shows: "Awaiting authentication". This when logging in from the same PC that I used to log in yesterday. When I try to log into the other PC (running the 32-bit version of Teamviewer 12, on the same Xubuntu 16.04 LTS), it goes no further than showing "Connecting,"and won't even open the remote display.

    I will try to reconfigure again when I am at  the physical ocation of the two Linux workstations, but since I will be out of the country for a week, it is a pain that I cannot be certain that I will be able to connect remotely.

    Teamviewer has always been very reliable (and a lot easier to work with than VNC or the likes), so it hurts me to see that it stopped working for me now.

    Patrick