link icon
Ask The Community

A Comunidade TeamViewer chega ao Brasil 🎉

Check out our brand-new Portuguese Community 👉 here 👈.

No connection to TeamViewer server

I'm using Fedora Linux, and successfully installed teamviewer_11.0.67687.i686.rpm. But I'm getting a dialog "No connection to TeamViewer server. Please check your internet connection. Most likely you use a proxy server and you have to enter the proper information in the options dialog."

$ sudo systemctl status teamviewerd.service
[sudo] password for chris:
● teamviewerd.service - TeamViewer remote control daemon
Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: disabled)
Active: active (running) since Sat 2016-11-12 13:08:18 PST; 18min ago
Main PID: 4751 (teamviewerd)
Tasks: 14 (limit: 4915)
CGroup: /system.slice/teamviewerd.service
└─4751 /opt/teamviewer/tv_bin/teamviewerd -d

Nov 12 13:08:18 f25h.localdomain systemd[1]: Starting TeamViewer remote control daemon...
Nov 12 13:08:18 f25h.localdomain systemd[1]: teamviewerd.service: PID file /var/run/ not readable (yet?) after start: No such
Nov 12 13:08:18 f25h.localdomain systemd[1]: Started TeamViewer remote control daemon.


I've also stopped firewalld just to test if it's the firewall. And there are no SELinux AVC messages. So I can't figure out why it can't connect to TeamViewer servers. On a Mac, on this same wireless network, I don't have this problem.

Best Answer



  • I have the same problem with new fedora 25. Try to install newer teamviewer 12 beta, but result is the same. Did you find any solution?

  • Hi,

    I've just installed Fedora 25 and Teamviewer 11.0.67687 (wine-1.6) and I always get the message:

        Not ready. Please check your connection.

    Here is a part of /var/log/teamviewer11/cassou/gui.log that might be related. Can someone please help me?

    err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
    err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000122-0000-0000-c000-000000000046}
    err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80040155
    err:ole:CoMarshalInterface Failed to marshal the interface {00000122-0000-0000-c000-000000000046}, 80040155
    fixme:msg:ChangeWindowMessageFilter c055 00000001
    fixme:bitmap:CreateBitmapIndirect planes = 0
    "sni-qt/3739" WARN 10:40:27.215 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE
    "sni-qt/3739" WARN 10:40:27.215 void StatusNotifierItemFactory::connectToSnw() "org.freedesktop.DBus.Error.ServiceUnknown" : "The name org.kde.StatusNotifierWatcher was not provided by any .service files"
    err:secur32:SECUR32_initSchannelSP TLS library not found, SSL connections will fail
    err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
    fixme:nls:GetGeoInfoW -1 4 0x33fcbc 3 0
    fixme:process:WTSGetActiveConsoleSessionId stub



  • Julia
    Julia Posts: 290 Staff member 🤠


    Can you provide us with the following information regarding this problem:

    1. How did you install TeamViewer on the system (softwarecenter or terminal?) and which version are you using?

    2. Which display manager is installed on the system?

    Thank you in advanced!

    Senior Support Engineer - 2nd level Support
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • Hi
    1. I tried to install teamviewer through software center, but it said "File is not supported", so I try through terminal and I succeeded. But it can't connect.
    2. I use gnome 3.22 and nautilus.

  • I found more info about the problem.

    If you login with gnome Xorg, you can use teamviewer without problem, but if you use wayland, teamviewer cant connect to server.


  • > 1. How did you install TeamViewer on the system (softwarecenter or terminal?) and which version are you using?

    dnf install -y

    > 2. Which display manager is installed on the system?

    The default one on Fedora 25: Gnome 3.22 + Wayland

  • Julia
    Julia Posts: 290 Staff member 🤠

    Hi all,

    we talked to our development regarding this.

    It happens when you do an autoupdate form Fedora24 to Fedora25 - this is a bug in our current version. We are already working on it and I will inform you when we have fixed it.

    We apologize for the inconvenience.

    Senior Support Engineer - 2nd level Support
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • I didn't do any update from F24 to F25. I erased my hard disk and installed F25 from scratch on a blank disk.

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠


    Linux Developer
  • I am using Fedora 25 as well and I am having the same issue. I am using the latest 12 release. Any updates on this?

  • ORNI
    ORNI Posts: 1


    I have the same problem. Is there any news on this issue.
    After switching to Xorg teamviewer work normally , but i want to use wayland .

    Best regards,

  • xtof
    xtof Posts: 2

    Yep, it's a Wayland issue. My expectation is Teamviewer could work as a client (see someone else's screen) using XWayland pretty easily, but there's probably substantially more work getting it to work as a server/host (to share my screen with someone else). Since there aren't separate client server programs, I think we just have to fallback to XOrg for now.

  • pfl
    pfl Posts: 1

    Any news regarding this issue?




  • SPA1
    SPA1 Posts: 1

    Hi all.  30.12.2016. I´d like to post my experience too.

    Clean, default install of Fedora 25 x64 and Teamviewer 12 .rpm via Software Installer.

    The same problem.  " TeamViewer is not rady. Check your connection."  Anyway, Thank you for your work. We have to wait a little.

  • Hi Soeren, 

    thanks for the idea with the workarround installing the tarball, works with Fedora 25!

    Kind regards,


  • Hello, you guys who got it working with the tarball, are you using wayland, and may you be using amd or nvidia drivers that have pushed you back to xorg?

  • m4b0
    m4b0 Posts: 1

    I'm using wayland and I'm confirming that TeamViewer is working using the tar.xz file.

  • Thank you for the fast reply.

    I didn't get it to work for me in wayland even with the tarball, but it works in Xorg so it can't be a firewall problem etc..

    But anyway I'm probably going to use Xorg for the time being, since I want the proprietary nvidia drivers anyway, but it would be awesome if wayland would get fully and officially supported :) 

  • xa
    xa Posts: 2

    Hi all,

    I'm using the tarball with wayland.

    I've a Laptop with two graphic cards (Intel and Nvidia) so I'm using the graphic card of the Intel CPU without special drivers.

    Kind regards,

  • On Fedora 25 using wayland;

    Getting the same problem but as mentioned by earlier thread: launching the teamviewer from tar file works with no problems.

  • Hello!

    This is also happening to me in openSUSE 13.2. I'm not using Wayland (although there are some libwayland libraries installed), I'm use KDE 4.14 with Xorg. The tarball works fine. I think this issue started after updating to TV12


  • I'm on Fedora 25 and Wayland (I double-checked by typing Alt+F2 and 'r' to get the message "Restart is not available on Wayland").

    I managed to install Teamview, run it and even connect to a friend's computer to see his screen. Nevertheless, my friend (running macOS) has only been able to see my screen as a *big black rectangle* instead of my windows. He could move the mouse and type though.

  • MuTou
    MuTou Posts: 1

    It doesn't work for me, also Fedora 25.

    $ ./teamviewer

    CheckCPU: SSE2 support: yes
    XRandRWait: No value set. Using default.
    XRandRWait: Started by user.
    Checking setup...
    Launching TeamViewer ...
    Starting network process (no daemon)
    /home/xxxx/Downloads/teamviewer_12.0.71510_i386/teamviewer/tv_bin/teamviewerd: error while loading shared libraries: cannot open shared object file: No such file or directory
    Network process already started (or error)
    Launching TeamViewer GUI ...

    Then, have a small window pops out shows error and black content.

  • Have you tried switching from Gnome (default) to Gnome on Xorg?
    You can select one of them on login screen ( You'll see gear icon ).

  • Hi there, I am on Arch Linux, also using TV12 on Gnome with Wayland, same issue! Any Idea on when to expect a fix? It really bugs me...

  • "I didn't do any update from F24 to F25. I erased my hard disk and installed F25 from scratch on a blank disk." As i did. Then I installed separatly the "KDE Plasma Desktop". Same no conection errors.

  • Fresh Install Fedora 25, Fresh install TV12. Also getting the error message.

    TV11 also giving error message.

    I was able to get the tarball to work but I would say that is a pesky workaraound and not a solution.

  • su teamviewer

    Fedora 25 wayland



  • $ su teamviewer
    su: user teamviewer does not exist
    [[email protected]]# teamviewer

    *** TeamViewer can not be executed with sudo! ***
    Either use your normal user account without sudo
    or use a the real root account to log in to your desktop (not recommended!).

    I'm sorry but I've failed to see how this resolves anything...