Does not allow connections to customized Host module clients with your company logo.

s_mill Posts: 2 ✭✭


I have been using TeamViewer Free for a while now and since I upgraded to V12 I have been getting this error.

Teamviewer Error.PNG

 Before this I was using V11 and had no issue with this.

This is what my TeamViewer looks like on both computers and note that it says Free version.

Computer 1TV1.PNG

Computer 2


 A couple of Notes: When I do the installation I make sure I'm checking "For personal use Only"

I used to use a licenensed version for a client on one of my computers a while ago using V8 and V9. Since then I only use TV for personal reasons on a different account.

The flag is for Low disk space on one of my computers.


  • DeveloperM01
    DeveloperM01 Posts: 2 ✭✭

    I've had the same exact problem for over a week now and my problem still remains unresolved.

  • askmartin
    askmartin Posts: 1

    Hey TeamViewer admins or support...any response?  I did discover that if I set "Grant Easy Access" I can connect without having the person on the other end (my wife) tell me a password that is displayed.  But I still get the "you will be timed out in 5 minutes" message.

  • DrivingTitan777

    I have had this same issue since upgrading to Teamviewer version 12 on both computers for about a week now. After the 5 minute interval is up, I am unable to reconnect for 20 minutes or so. This is annoying, and needs to be addressed.

  • Pagnor
    Pagnor Posts: 1

    I get this on every single update. Just went to ask for support and they dont offer it for free account. Feel like I am unclean as I dont have a licence due to only using it in my house to connect to my pc and plex server.

  • carlosriosness
    carlosriosness Posts: 3 ✭✭

    i too have had this issue for a few months now. i usually only need 5 minutes or so. so i have let it go long enough. i have tried uninstalling and reinstalling on my 4 computers, but no luck.

    i think i might just delete my account and start a new free one with one of my other email addresses.

    i think this started for me when i tried to remote into my home pc from my work PC (which support said was ok for me to do with my free license). my work has a company teamviewer account. and we have a work **bleep** account (which i think has something do to with teamviewer now). after trying from work wone time this issue popped up and i have not been able to get it to go away.

    please help! otherwise i guess its pretty simple to create a new account.

  • CO3
    CO3 Posts: 1

    Absolutely fixed the problem. Thank you carlosriosness!

  • s_mill
    s_mill Posts: 2 ✭✭

    @carlosriosness wrote:

    i think i have the fix. from their facebook account.

    the problem is how we are adding new computers to our list. i am guessing all of you log onto then click "add" and "add computer". that is the problem. i dont know why they put that there if we cant use it.

    what you should do. just go to teamviewers website and click downloads. download WITHOUT logging in. as if you were a new user. i just google teamviewer, one of the first results is the teamviewer download page. thats where you want to download it from. i will try to post a link below:

    then, during installation add it to your account by logging in when it asks if you want to create an account or if you already have an account.

    i deleted my 4 pc's and installed it on 2 of them so far with the method above. so far it has worked for me on the first test. i will get the other 2 installed sometime this week.

    Unfortunately this did not work for me. I uninstalled teamviewer. Removed all of my previously added computers through the web portal. I ran CCleaner to try to remove any TeamViewer registry that might be interfering. I installed again and still did not work. And to clarify, I wasn't signed Teamviewer when I downloaded.

    Teamviwer Error.PNG

  • carlosriosness
    carlosriosness Posts: 3 ✭✭

    you have a different problem. my steps fix the host module issue. you have a trail version expired issue.

    you need to contact support there is a form somewhere specifically for this. you fill out your ID and account info. explain that you are using this for non commercial use only, and they should be able to reser your account. next time you have to be REALLY careful and make sure you do NOT install the trial version.

    this form:

    support says you can connect from a paid version to a free version with no issues. but i read there is a counter somwhere. if a paid PC connects to your free client like 5 or 10 times, then it gives the expired issue. i think it happened to me since i have a free version for my personal computers. but my work has the paid version. and i did connect from work to home a few times.

    i sent this request for my account like 1.5 weeks ago and still havent heard back. this is the 2nd time i had to email them. this happend to me like a year ago too. 


  • DeveloperM01
    DeveloperM01 Posts: 2 ✭✭

    Issue resolved: The problem was from my friend's end. He had a trival version of the teamviewer commercial license. I asked him to uninstall teamviewer and re-install it with a personal llicense and the issue was resolved.

  • Zilpha7
    Zilpha7 Posts: 1
    edited January 2023

    Hi guys. Thnks for the post but still not working for me.

    I uninstalled and followed your instructions. Downloaded fresh install from the website - (im on a Mac). When the window popped up, i then sigend in. It had my previous 'added computor' (the one i want to control) still in the 'My COmputers' section. 

    I connected and same msg.

    So i 'removed this pc'. Deleted the program again and re-downloaded. All boxes empty - good. But when i put ther ID for the other computer in to connect to, it did exactly the same again.

    I've used this saoftware at work and it's really easy. This is soooo poor for them not to make this clear and staight forward for a FREE account. Any help appreciated. IF can't sort I'll use **Third Party Product** which i used years ago. From Zilpha - frustrated!!

  • lightinglady
    lightinglady Posts: 1

    Teamviewer is locking me out after 5 minutes because it says it doesn't allow connections to customized clients with own logo.  I don't and am not.  how do i stop this so that i can use it normally?

  • Beck07
    Beck07 Posts: 1

    Did you log in online and delete devices there first? 

  • wild4gadgets
    wild4gadgets Posts: 1

    Thanks; that fixed the problem for me as well. I've been banging my head on my desk for a couple of days now, trying to figure this one out. 

  • scotty581
    scotty581 Posts: 1

    This fixed things for me as well

  • whitzzz
    whitzzz Posts: 0

    Thanks @carlosriosness your solution worked for me today!

    I had logged into TV's website first, then downloaded the software from there and installed it. Later upon trying to remote into this PC, I got the error about "does not allow connections to customized Host module clients". It is silly that TV has this problem and can't simply "know" the right version on the logged-in download page. Thankfully your solution appeared at the top of search results.

    Following your instructions, I uninstalled TV from the PC I had just installed it on, went back to TV's website **NOT** logged in, downloaded it, installed as usual (choosing the personal/free option), and THEN signed into my account through the software to add this PC to my list. Perfect and easy!

  • DennisPB
    DennisPB Posts: 4 ✭✭

    OK, so yesterday I downloaded TV, and was disconnected after a minute with a pop-up error message {sic} "...for personal use only..."

    I then followed the reset procedure, completed the form, provided the ID #s for both host and remote laptops.

    Received email this morning stating both IDs were reset - great!

    Not so fast, I logged in and received this error message on start-up "Your current TV plan does not include connections to customized TV modules. Your session will therefore be terminated after a short time. Please upgrade to a higher plan to use this functionality."

    A minute later error message "This was a free session sponsored by TV, TV sessions are free of charge for personal use."

  • imgkc
    imgkc Posts: 9 ✭✭

    I downloaded TeamViewer on a new Windows 10 pc. Installation went with no errors. Now when trying to connect to the new pc I get this error message,

    I just finished the install and didn't make any customization to it (that I'm aware of) I used the default install settings.

    Can anyone help?