teamviewer.com link icon
or
Ask The Community

TeamViewer is one of the winners of the European Customer Centricity Award 🥳


Please find more information here.

Cannot start installation of FULL TV when using ASSIGNMENTOPTIONS

Im trying to test a mass rollout of TV 14 via GPO but i cant get it working with your instructions.

https://community.teamviewer.com/t5/Knowledge-Base/Mass-deployment-improvements/ta-p/39639#toc-hId-**Please do not post TeamViewer IDs**

That is what ive worked out so far:

msiexec.exe /i "\\pathtoshare\TeamViewer_Full.msi" /qn IMPORTREGFILE=1 APITOKEN=<xxxxxxxxxx> ASSIGNMENTOPTIONS="--group Unassigned"

The Setup File lies under the path with the correct naming (msiexec.exe /i "\\pathtoshare\TeamViewer_Full.msi" /qn >>>>when  i enter it in CMD the installation starts so the problem must be somewhere after the switch /qn....)

it will also install with the IMPORTREGFILE=1 but when i add the APITOKEN it just says : Syntax Error

Can anyone help me with that?

In the deployment guide theres an example line like this down below but with this line its saying the file cannot be found

msiexec.exe /i "Path\To\TeamViewer_Full.msi" /qn APITOKEN=<YOUR_APITOKEN> [ASSIGNMENTOPTIONS="<YOUR OPTIONAL SETTINGS>"]

msiexec.exe /i "xxxxxx\Teamviewer14\TeamViewer_Full.msi" /qn IMPORTREGFILE=1 APITOKEN=<xxxxx> [ASSIGNMENTOPTIONS="<--group Unassigned>"]

What am i doing wrong?

 

This has been solved from a TV technician. The support was really was after opening a support ticket:

msiexec.exe /i "\\xxxxxx\_Information Technology\Software\Teamviewer14\TeamViewer_Full.msi" /qn IMPORTREGFILE=1 APITOKEN=xxxxxxxxxxxxxxxxxxxx ASSIGNMENTOPTIONS="--reassign --alias %ComputerName% --group-id g**Please do not post TeamViewer IDs**" 

it worked with this line

thanks