teamviewer.com link icon
or
Ask The Community

TeamViewer no longer gives option for Web Connector

Hi,

I am trying to access a computer that's running TeamViewer 12 using the Web Connector on TeamViewer's website.  Because TeamViewer hasn't updated their Windows 8.1 app for my tablet running Windows 8.1 RT, I have to keep TeamViewer 11 on my currentl laptop, and cannot upgrade to TeamViewer 12.

I logged into the web portal for TeamViewer, but when I click connect, it only gives me an option to open the link in the TeamViewer desktop app...which doesn't work since I am only running TeamViewer 11.  There used to be an option to allow me to use the web app (which is fine), but it's no longer there at all.

Can someone please address this??

Comments

  • Neet
    Neet Posts: 1

    Hi,

    I ran into the same problem and thought TeamViewer removed support of web connector but it isn't. There might be 2 things you can try,

    1. Remove desktop version of TeamViewer app from the machine from which you want to access web connector. (It seems if browser finds desktop version available then it never asks you for other options - worked for me)

    2. Try it from another PC and another browser (NOT from Chrome since they have chrome app as well)

    On Linux desktop I had Version: 12.0.35145 and I used web-connector from Windows 8.1 64-bit Chrome Browser without any desktop app installed.

    Option 1 worked for me and I got the pop-up with 3 options

    1. Download and install TeamViewer full version
      and then click here to connect
    2. Get the TeamViewer Chrome App
      and then click here to connect
    3. Or use the Web client
      Always use the Web client (not recommended)
       
       
  • I can use web connector but with Chrome it keeps telling me "You need Adobe Flash Player to use TeamViewer" - Chrome has built in flash? It used to work. Have you tweaked it? I cannot install TV Standlone or Chrome extension as its a work PC with everything locked down :-(

  • jayce1983
    jayce1983 Posts: 2 ✭✭

    unsatisfactory solution. I need the app on the destination pc, as i use several other pcs and my phone to control it via the program.

    The chrome web version and app all show as options form the web portal login, but only app is not greyed out, the chrome extension and web version are greye dout.

    i need to use web version as my work pc i am unable to install software on, but am pre-approved ot use tcp/ip

     

     

     

  • Leckon
    Leckon Posts: 1

    Hey, so I had this problem as well, and the solution is fairly simple. You just have to open the webconnector seperate from the management console and start flash. This can be done by simply Googling "Teamviewer WebConnector" as it should be the first result. You can then go back to the management console, reload te page, and the option to use it shouldn't be greyed out anymore. I believe this happens because it believes that you won't be able to use it as you don't have flash, but upon activating flash it works just fine. Hope this works for anybody still having this problem!