Teamviewer will not load on Ubuntu 16.04

Marktime Posts: 3 ✭✭

Hey all

I've been going back and forth to this machine all dang day trying to get it installed. The main symptom is when i try open teamviewer, the icon sits on the side bar and then nothing.

Tried to load it from terminal and it gets stuck on "Loading Teamviewer GUI"

Tried all the fancy terminal commands from other posts on here, including the purge, folder and file clean up, downloading the package in terminal and installing it in terminal.

Done the update and upgrade commands for apt-get, done the apt-get install -l -y command. Everything is up to date but still the same.

I though maybe a colleague installed a bad image so i downloaded a fresh install, burnt it to CD, verfied everything, reinstalled Ubuntu, went through the Teamviewer installation process very carefully and in terminal so i could see if anything went wrong, made sure all dependencies were installed, restarted, opend teamviewer...annnnd:

Same thing!!!

Is anyone else having issues with the latest release of both Ubuntu and Teamviewer?

Any pointers from a penguin master?


  • Marktime
    Marktime Posts: 3 ✭✭

    Once again the support team has given the community some stellar support here...

    Anyway, I'll quit my whining and give anyone who's looking a solution:

    Turns out my install of Ubuntu thought it had a phantom monitor plugged in. Disabled it in the display settings, hit apply, and all the stuff that was missing appeared in the middle of my screen. 

    So simple but easy to miss if you're a Windows user normally. Hope this helps someone else in the future :)