link icon
Ask The Community

Team viewer not accepting password

This morning, I set up a session on my home PC, took a screenshot of the ID and Password. I get to work to connect to the session and it keeps saying the password is invaild. I know im typing it right as I have it in a screenshot, and there are no power settings that would set my PC at home to turn off. 

Any Ideas? Tad frustrating, is there a time out set for the passwords within the sessions? Do they auto refresh? 


  • Reyhan
    Reyhan Posts: 270 Staff member 🤠

    Hi @Vikx993

    Thank you for your post. Please note, that the random password will change after each remote connection or restart of TeamViewer.

    It is a better to add a personal password for unattended access, please have a look at this article in our Knowledge Base.

    Best regards.


    Did my reply answer your question? Please accept it as a solution to help others, Thanks.
  • ksierra
    ksierra Posts: 1

    I set up a personal password on the computer and turn off all hibernating ,stand by and sleep mode on the computer. But after working for a week, today i have a error that says invalid password. What could happend?

  • I am having the same exact problem with a Windows Server 2012 host that has the last TeamViewer installed. I allows connections from the LAN with whatever passwords I use (I mean the ones I define personally or those the program randomnly generates). But when I try to connect from the Internet using the TeamViewer's ID, I keep falling in the authentication dialog because my password is not recognized. I have collected the log so you can follow along the problem.

    2018/08/02 09:53:52.812  5604  6080 S0!! Encryption.RSADecrypt exception: RSA/EME-PKCS1-v1_5: invalid ciphertext
    2018/08/02 09:53:52.812  5604  6080 S0!!!CEncryption::DeCryptBCommand(): decrypt CMD_BUDDY_ENCRYPTED failed!
    2018/08/02 09:53:52.812  5604  6080 S0!! CProcessCommandHandlerKeepAliveClient[9558]::CmdRequestRouteBuddy() DeCryptBCommand failed!


    Thanks a lot for taking the time to answer. Regards from Argentina. Ariel.

  • Billy60
    Billy60 Posts: 1

    Same problem here. I had been accessing remotely for exactly one week. Now I get an invalid password message.

  • I dont understand this. I have a windows10 machiine with a password on that I remote into. I rebooted it this morning and then tried to connect remotely using the windows password (after connecting using teamviewer). I know my passowrd is ocrrect but it wont log me on? 

    When I go home and log in to the machine direct it will let me on. I also tried the on screen keyboard but that didnt work.


  • I also cannot connect, it says the Password is invalid (After I just signed in using my Teamviewer account) and the machine that I am trying to connect to is set up for unattended access.

  • I have been encountering the same problem with the web connector. Then I try the exact same password on the chrome extension and it works. Seems to be a problem with the web connector.

  • pjbaker
    pjbaker Posts: 2

    My online account will accept my password for the account but not the app on my mac book.  What is weird, is if I log into teamviewer online through a web browser and then go to connect to another device, the browswer will ask to open the app.  When I click allow, the browswer will open the app and automatically submit the password and the whole app functions find until my computer times out, then I have to go through this whole procedure again to get teamviewer app to work, which is the only way for my mac to connect to a remote computer.  

  • I just put the app on my phone and encountered the same problem..  Did you ever get an answer that works?

    I appreciate your help!!


  • mrdrking
    mrdrking Posts: 1

    I have similar issue on PC as PJBaker on the Mac.

    Background ... this is a new installation of Win 10 on an older PC, thus a recent install of Teamviewer.

    ... it sounds like PJ & my experiences are consistent, but there may be other issues, ... like getting the new install of program in PC included / activated in the Teamviewer 'my computer user group' .... or perhaps a slightly different formal name (since I cant get there)

    thanks for solution(s)

  • dmthompson
    dmthompson Posts: 1 Newbie

    Still no resolution to the same problem. It says that the password is invalid, although we tried it three ties even updating the password.

  • juancuero
    juancuero Posts: 2 ✭✭

    The 'passwort' is also invalid

    "passwort invalid - validation failed [E14]"