link icon
Ask The Community

Cannot get unattended access to Android tablet - Teamviewer Host seems to drop out after a while


I want to remotely control my Samsung SM-T550 tablet (android device) from other devices.

I have set up the tablet with  Teamviewer, Teamviewer Host, and QuickSupport, and. I have managed to set it up for unattended access, and I managed to access it from my Iphone XS through Teamviewer. It all works well right after installation, but when I try to access it again some hours later, it does not work anymore. I tried so many things. When I finally re-installed Host, then it worked all well again. BUT,  the day after, I could not access it anymore. Same thing. The message I get on my phone is:

"UNABLE TO CONNECT, a connection could not be established. Either your partner isn't connected to the internet or your partner's TeamViewer isn't running yet. Please tell your partner to check his/her internet connection or to start TeamViewer"

The tablet is set to be on at all times, so it does not lock down itself or the screen at any time. I have tried it with and without the "echo mode", but with no difference.

Any suggestion to solve this ?