link icon
Ask The Community

TeamViewer is one of the winners of the European Customer Centricity Award 🥳

Please find more information here.

Teamviewer 11/12 Beta: No access to Linux host before login


I cannot get Teamviewer 11 to access a host without a local graphical login first.

I'd like to use Teamviewer for remote administration of a donated Internet PC in a refugee home in my local community. The PC in question is running an Ubuntu derivative, i.e. Linux Mint 18 (Sarah). I have installed Teamviewer 11 on it, activated the option to autostart, linked the Sysv-Initscript that came with the package to /etc/init.d/ and had update-rc.d create the necessary links to automatically start it as daemon on boot.

The host even shows up in the list of my computers fine after boot, even though the computer still shows the login screen, so there's no one logged in at that moment. If I go to that machine (i.e. physically in front of it, not through TV) and log in there, i.e. pass the Mint login screen, I can then use Teamviewer on my remote machine to connect to it. If however I have noone on premise to log in to the host machine and simply click on the host in my list of computers, my Teamviewer Client shows an error "waitforconnectfailed" and the host vanishes from the list of computers.

I have found the very same problem described in the, without a solution though:

I have tried upgrading to Teamviewer 12 Beta, though this is somewhat inconvenient, as my company has licensed Teamviewer 11 corporate and I cannot as yet upgrade my Teamviewer install, so I used Teamviewer Portable 12 on my client machine (though I fully upgraded to TV 12 Beta on the remote host). This did not solve the problem however, so Teamviewer 12 suffers from the same deficiency, i.e. no unattended connection to a remote before someone has logged in locally.

As far as I understand from the forums, unattended connection to a linux Teamviewer host used to work with Teamviewer 9, possibly even 10.

I don't really want to tamper with port forwarding, SSH-tunneling and VNC instead for this project, especially as there is the possibility that there may be more than one computer in the refugee shelter in the future, which just adds to the complexity I'd have to deal with in my spare time, when I'd really like to do something more worthwhile, exactly the reason why I'd hoped that Teamviewer would work. But now it's either SSH-tunneling or getting somebody on the phone and making them understand that I need them to log in to the computer before I can access it.

And no, as there are many persons sharing the same computer, I don't want it to automatically log in to some account on boot, so that's not a solution to the problem.

Any ideas?

Kind regards


Best Answers


  • Thank you for your response - I already suspected as much. In that case: Which display manager would be recommended? I'm not at all fanatic about any kind of DM, I'm also quite open to using a different Linux distribution - the only thing I'd really like to stay with is a Debian- or Ubuntu foundation. Cinnamon and Mate seem to be both on the no-go-list, same applies so Ubuntu with gnome, so I am under the impression, that the options are quite limited, so is there a positive example of this working in an unattended setup?

    If Teamviewer >=11 is not an option, I'll try and go back to Teamviewer 10 - I know that this did in fact work in the described manner.

    Kind regards


  • Hi,

    After replacing the DM with lightdm in Mint, it still didn't work for some reason, so I reinstalled the box with Lubuntu 16.10. It's now working with TeamViewer 11, but two things keep bothering me, though they are probably connected: After login in to ldm, there is a delay of several seconds, before TeamViewer shows the GUI, though login was successful and the GUI is already displayed locally. That doesn't bother me as much, what does is a crash message from Ubuntu, tellimg me about a crash in the Teamviewer application. Interestingly enough, this crash does not seem to cause any serious problems in Teamviewer functioning, so I chose to ignore it for now.

    Crash is in /opt/teamviewer/tv_bin/TeamViewer_Desktop, ApportVersion 2.20.3-0ubuntu8, Coredumps are a couple MB in size. There is no such crash message if I log in locally first, before I connect with TeamViewer, so I guess it has to to with the DM handing over the X-session to the WM or something which brings TV out of balance. The same thing happens when the remote locks the screen due to inactivity - in that case, TV just shows a black screen, wheres the remote displays the DM - I have to end the TV session, start a new one, pass the login screen, which causes TV to end the session again, even though login was successful, but when I connect again with TV, I get back my session. That's not ideal and has a flakey feel, but I can live with that situation.

    I'll configure a DynDNS client and will try and poke some port forwarding rules in the remote access point, so I may still fall back to SSH tunneling and VNCin case that there still should be a problem with TeamViewer, but for now I'm fairly happy with the way things have turned out.

    Thank you!

  • Just want to add that I had the same issue.  Teamviewer on linux does NOT work if you're running on Wayland.   Really hope they get this fixed soon, as everything else I've tried has worked fine under Wayland.  For now, I guess I can switch to when I need to use TV.

  • Hello,

    a clean install of Lubuntu 16.04 (lightdm display manager) suffers from the discussed problem, too. So can you please elaborate more on which version of lightdm is supported? (Note that Lubuntu 16.10 should be fine as MWollny claims above.)

    However, it seems the login greeter being shown doesn't cut TeamViewer off completely every time. In my case, it's impossible to connect only when the greeter is shown on system startup. On logout / screen lock the connection drops, but it's possible to reconnect and see the greeter. After logging in the connection drops again, but it's again possible to reconnect and see the desktop. Is this expected behavior?

    Finally I am also getting TeamViewer crash notice (without apparent effects) on system startup. Is it hinting to something important?

  • Myst
    Myst Posts: 4

    I am suffering from this issue on ubuntu using LXDE. This needs some serious attention. I created two threads in regards to this issue and no one has helped me with this. DOES ANYONE ACTUALLY WORK FOR THIS COMPANY?!?!

  • I solved this problem configuring the gnome deamon with autologin start:

    nano /etc/gdm3/daemon.conf

     In the seccion deamon:

    # Enabling automatic login


  • TeamViewer 9 works perfectly for example with lightdm.

    But any newer version not. Any chance to fix it?

  • gunso
    gunso Posts: 1


    having the same issue here. Any follow-ups on a definitive fix? Maybe some works in progress with the folks of Wayland or GDM?.

    Best regards,


  • Whatts
    Whatts Posts: 1

    Reviving an old thread but for Ubuntu 18.04 I fixed it by uncommenting this line:


    in file:


    According to the info in the file this simply switches the login screen to the Xorg window server, and for me this solved the issue.

  • rgigante
    rgigante Posts: 1

    This perfectly solved my issue with TV 15 as well.

    Great finding!

  • thosecars82
    thosecars82 Posts: 3 ✭✭

    My Ubuntu 18.04 display manager is Lightdm:

    cat /etc/X11/default-display-manager

    My computer dos not even have a folder called


    I guess I do not have this folder because my display manager is Lightdm instead of Gnome.

    Is it possible to fix the problem to access the Ubuntu 18.04 Lubuntu host wihtout changing the display manager?

    If possible I would like to keep on working with Lightdm.

    Thanks in advance