teamviewer.com link icon
or
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?


Download the new version and let us know what you think about it! 👉 Please click here 👈

Teamviewer 13 and Raspberry4 headless problem

Hi all,

I've a new Raspberry 4 with Raspbian OS:

Distributor ID: Raspbian
Description: Raspbian GNU/Linux 10 (buster)
Release: 10
Codename: buster

I installed the package  teamviewer-host_13.1.1548_armhf.deb from pi user.

I accepted the license and set the password.

If I run 'teamviewer info I have:

[email protected]:~ $ teamviewer info

TeamViewer 13.1.1548 (DEB)

TeamViewer ID: 2534*****

teamviewerd status ● teamviewerd.service - TeamViewer remote control daemon
Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2020-08-07 14:42:30 CEST; 9min ago
Process: 2102 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
Main PID: 2104 (teamviewerd)
Tasks: 17 (limit: 3862)
CGroup: /system.slice/teamviewerd.service
└─2104 /opt/teamviewer/tv_bin/teamviewerd -d

ago 07 14:42:30 raspberrypi systemd[1]: Starting TeamViewer remote control daemon...
ago 07 14:42:30 raspberrypi systemd[1]: teamviewerd.service: Can't open PID file /run/teamviewerd.pid (yet?) after start: No such file or directory
ago 07 14:42:30 raspberrypi systemd[1]: Started TeamViewer remote control daemon.

Strange, the file /run/teamviewerd.pid is there and readable (???).

If I run 'ps aux | grep team' I have:

[email protected]:~ $ ps uax | grep team
root 2104 0.1 0.4 164840 8384 ? Sl 14:42 0:00 /opt/teamviewer/tv_bin/teamviewerd -d
pi 2167 0.0 0.0 7368 564 pts/0 S+ 14:53 0:00 grep --color=auto team

Usually there are three processes, so sometihng is missing.

If I try to connect from other PC I receive an error - the device is not connected

Please, how can I solve it?

Best Answer

Answers