teamviewer.com link icon
or
Ask The Community

Teamviewer Host - EC2 Ubuntu Server - The framebuffer console seems to be unavailable

djb
djb Posts: 5

I just installed teamviewer host, and all the dependencies on an ubuntu 14 server. When I run teamviewer setup I get this

The framebuffer console seems to be unavailable or has the wrong format. Please make sure that
/dev/fb0 is accessible and it is configured to 32-bit depth.

I am accessing this server through ssh on my terminal on my mac. Any tips? 

Comments

  • ChristianCay
    ChristianCay Posts: 182 Staff member 🤠

    Dear djb,

    Thank you for your post.

    TeamViewer headless setup requires framebuffer support at 32bit.

    If framebuffer is not enabled TeamViewer headless setup will not work.

    That's the reason why you're getting the framebuffer error.

    To fix your issue, please edit your /etc/default/grub file and add these two lines.

    GRUB_GFXMODE=1024x768x32
    GRUB_GFXPAYLOAD_LINUX=keep

    Save the file and run the command

    sudo grub2-mkconfig -o /boot/grub2/grub.cfg

    Then reboot the computer.

    If you have any other questions please don’t hesitate to contact us.

     

    Best,

    Christian

    Did my reply answer your question? Accept it as a solution to help others, Thanks.
  • djb
    djb Posts: 5

    I did all of that, having to modify the command for grub 1, and I get

     

    The framebuffer console seems to be unavailable or has the wrong format. 
    Please make sure that /dev/fb0 is accessible and it is configured to 32-bit depth.

     

  • ChristianCay
    ChristianCay Posts: 182 Staff member 🤠

    Dear djb,

    Thank you for your post.

    If you have grub 1 please follow these instructions.

    In your favorite editor, please edit the file /boot/grub/menu.lst

    Append the desired frame buffer mode to your system. In this case, vga=833 that is the recommended mode.

    An example entry:

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title SUSE Linux Enterprise Server 11 SP4 - 3.0.101-63
    root (hd0,1)
    kernel /boot/vmlinuz-3.0.101-63-default root=/dev/sda2 vga=833 resume=/dev/sda1 splash=silent showopts
    initrd /boot/initrd-3.0.101-63-default

    Then reboot.

    Hope this solution works for you.

     

    Best regards,

    Christian

    Did my reply answer your question? Accept it as a solution to help others, Thanks.
  • djb
    djb Posts: 5

    This is what I did.

    I used

    $ wget https://download.teamviewer.com/download/linux/teamviewer-host_amd64.deb

    I installed it with 

    $ sudo dpkg -i /path/to/deb/file

    followed by

    $ sudo apt-get install -f  

    ## ## End Default Options ##

    title Ubuntu 16.04.3 LTS, kernel 4.4.0-89-generic
    root (hd0)
    kernel /boot/vmlinuz-4.4.0-89-generic root=LABEL=cloudimg-rootfs vga=833 ro console=hvc0
    initrd /boot/initrd.img-4.4.0-89-generic

    title Ubuntu 16.04.3 LTS, kernel 4.4.0-89-generic (recovery mode)
    root (hd0)
    kernel /boot/vmlinuz-4.4.0-89-generic root=LABEL=cloudimg-rootfs vga=833 ro single
    initrd /boot/initrd.img-4.4.0-89-generic

    Is that at all correct? 
    When I restarted the server and ran sudo teamviewer setup I got 

    An X server is currently running on the active VT (virtual console). Please shut down your X session or  display manager.

    So I ran

    $ sudo service lightdm stop

    Then I tried sudo teamviewer setup again then I got

    The framebuffer console seems to be unavailable or has the wrong format. Please make sure that /dev/fb0 is accessible and it is configured to 32-bit depth.

    On a last note, are you sure this will work for an aws ec2 ubuntu 16  server? 

  • chro4
    chro4 Posts: 2
    sudo grub2-mkconfig -o /boot/grub2/grub.cfg
    Running this command gives an error that the command is not found\
    Ubuntu 16 CLI headless
    sudo: grub2-mkconfig: command not found
    Now what?

    @ChristianCaywrote:

    Dear djb,

    Thank you for your post.

    TeamViewer headless setup requires framebuffer support at 32bit.

    If framebuffer is not enabled TeamViewer headless setup will not work.

    That's the reason why you're getting the framebuffer error.

    To fix your issue, please edit your /etc/default/grub file and add these two lines.

    GRUB_GFXMODE=1024x768x32
    GRUB_GFXPAYLOAD_LINUX=keep

    Save the file and run the command

    sudo grub2-mkconfig -o /boot/grub2/grub.cfg

    Then reboot the computer.

    If you have any other questions please don’t hesitate to contact us.

     

    Best,

    Christian





  • djb
    djb Posts: 5

    I typed 

    sudo grub-mkconfig -o /boot/grub/grub.cfg

     

  • djb
    djb Posts: 5

    After doing as you said for updating the grub file, I type

    sudo grub-mkconfig -o /boot/grub/grub.cfg

    Then I reboot

    Then I type

    sudo teamviewer setup

    And it actually lets me login to my account now. I even get an email authorizing the trusting of a new device. But it hangs at the setting your device point.

    It might be my inbound ports, which I only have 80 and 22 open, or it's another error. 

    Any help would be appreciated.

    Screen Shot 2018-02-21 at 10.16.40 PM.png

  • chro4
    chro4 Posts: 2

    I have followed the exact same error and all the suggestions and I still get the

    The framebuffer console seems to be unavailable or has the wrong format. Please
    make sure that /dev/fb0 is accessible and it is configured to 32-bit depth.

    I have the I386 deb and a 32bit HP Server, I have had to change up the commands as I will edit bellow to allow the server OS to recognise the intended commands since the ones listed in the thread are obviously not for a GRUB system on the Ubuntu 16 Server 32 bit system as they give the error command not found when you copy and paste them under SSH or CLI directly but allude to how to list the correct commands which the ones posted are not in that list but s simular one is i change the syntax to that..

    IS it possible for Tech support to provide clear step by step instructions besides the cookie cutter of

    Dear ,

    Thank you for your post.

    TeamViewer headless setup requires framebuffer support at 32bit.

    If framebuffer is not enabled TeamViewer headless setup will not work.

    That's the reason why you're getting the framebuffer error.

    To fix your issue, please edit your /etc/default/grub file and add these two lines.

    GRUB_GFXMODE=1024x768x32
    GRUB_GFXPAYLOAD_LINUX=keep

    Save the file and run the command

    sudo grub-mkconfig -o /boot/grub/grub.cfg

    Then reboot the computer.

    If you have any other questions please don’t hesitate to contact us.

     

    Best,

    Christian

    As this edited version works for me to change up grub I still receive the error after a sudo reboot command

    The framebuffer console seems to be unavailable or has the wrong format. Please
    make sure that /dev/fb0 is accessible and it is configured to 32-bit depth.

    So how do I get /dev/fbo working?

    I copy and pasted the suggested updates exactly as posted.

  • TinoDxx
    TinoDxx Posts: 1

    Have you resolved the problem?

    Thanks

Sign In or Register to comment.