teamviewer.com link icon
or
Ask The Community

Menus in visual studio and other applications not working

Hi,

I'm using teamviewer 12, connecting from windows 10 machine to a windows 7 machine. And I'm having a problem with the context menu's as well as menus that should appear from the menu bar (File.. Edit.. View.. Build etc)

These menus are simply invisible. When I rightclick on a visual studio 2015 project there appears to be a context menu and I can click on items, I just can't see what I'm clicking on as those items are 100% invisible.

How can I fix this?

Best Answer

Answers

  • Reyhan
    Reyhan Posts: 271 Staff member 🤠

    Hi @Karrok

    Thank you for your post.

    Is it just certain programs on the remote client that show an invisible menu or is it every program?

    What abount the menus built into Windows itself, e.g. right-click on the desktop or in Windows Explorer?

    Could you please send 1-2 Screenshots to illustrate it? That would be great.

    Thank you in advance.

    Did my reply answer your question? Please accept it as a solution to help others, Thanks.
    Reyhan
  • Lurrow
    Lurrow Posts: 6

    observe the purple lineobserve the purple linein other situations after open the project does not appear the menuin other situations after open the project does not appear the menu@Reyhan, i have the same problem 

    i send the print of my screen if possible help us

    Ty

  • DomLan
    DomLan Posts: 490 ⭐Star⭐
    Hi,
    I'd like to reproduce this issue. A question: how many graphic cards has client
    system?
    Regards
    Domenico Langone
    MCSD: App Builder
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • Lurrow
    Lurrow Posts: 6

    in my case (the client of the printscreen) have a Nvidia Gtx 1060

  • DomLan
    DomLan Posts: 490 ⭐Star⭐

    Hi,

    thanks for reply. He has only this graphic card installed? He haven't an embedded Intel HD or something like this?

    Regards

    Domenico Langone
    MCSD: App Builder
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • Lurrow
    Lurrow Posts: 6

    Just one, 

    I will see later if  the processor  graphics of i7 4790k (Intel® HD Graphics 4600 ) is installed and running. But is Belive it is impossible, else have the driver i will pass to you the driver information.

     

    Regards

  • Karrok
    Karrok Posts: 5

    teamviewer.png

     

    Connecting from a windows 10 machine to a windows 7 machine, both have discrete video cards and no integrated graphics (both machines have an I7 5820K which doesn't have integrated graphics, both machines have up-to-date nvidia drivers)

    On the screenshot I click on the menu button and nothing happens.

    If I install greenshot or lightshot (screenshot software) on the machine I am remoting to, and create a screenshot after pressing a button, the menu is suddenly visible in the screenshot itself, when canceling this screenshot overlay the menu is gone again as well. but that's no way to work obviously :)

    Teamviewer 12 on both machines btw :)

  • Karrok
    Karrok Posts: 5

    The remote machine has active monitors (2) yes.

  • DomLan
    DomLan Posts: 490 ⭐Star⭐

    @Karrok: please try to stop QuickConnect button

    TeamViewer -> Options -> Advanced -> QuickConnect button -> Configure button... uncheck Show QuickConnect button

    Domenico Langone
    MCSD: App Builder
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • Karrok
    Karrok Posts: 5

    Hi,

    I've disabled it on both local and remote machine, closed visual studio and restarted it. And still no menus, also no right-click context menus for that matter.

  • Lurrow
    Lurrow Posts: 6

    I solved this problem !

    My vga is Nvidia GeForce 1060 6gb PNY  and my monitor is AOC - **bleep** 24".

    My monitor became standy by in X time... I just force my monitor on and works ...

    Vga or Monitor possible have a energy economy system and turn off.

    Very Thanks for all !   

  • daves0
    daves0 Posts: 2

    I am having this problem, and the suggested solution (don't let your monitors go into power-save mode, but force them to be on all the time) doesn't apply to me.  I am sitting right now with my laptop beside me, and it is connected via TeamViewer to this desktop computer.  I see the same desktop on both machines.  From my laptop I can right-click on this desktop's Start button and see the menu on both computers.  When I right-click on the application icon immediately next to the Start button (in my case, it's Outlook), I CAN NOT see the menu on my laptop, but I DO see the menu on my desktop.

    The same goes for Visual Studio menus .. when I click on a menu on my laptop, I don't see it there but I do see it on my desktop.

    Obviously, the suggested solution doesn't apply here as both monitors are fully active.

    This has been a problem for quite some time, and I suspect it has something to do with Aero or rendering.  Unfortunately, I can't turn Aero off on the desktop as it's been locked down by the IT department.  Is there anything that can be done to fix this?  TeamViewer is pretty much useless if I can't use Visual Studio with it.

  • DomLan
    DomLan Posts: 490 ⭐Star⭐

    Hi @daves0

    If you think that the issue is related to alpha blending or using Aero, you do not need to physically disable it from the client, but it's enough to instruct TeamViewer for ignoring this piece of rendering: Option -> Advanced:

    20-07-2017 17-06-27.png

    These options must be set up in the destination client of the connection, DESKTOP in your case.

    However, I suggest you check in advance that both devices are up to date with the latest available version of TeamViewer.

    Let me know if you find any useful variations.

    Regards.

    Domenico Langone
    MCSD: App Builder
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • daves0
    daves0 Posts: 2

    Unfortunately, I already have those options defined, and to no avail.

    I am connecting to my Windows 7 desktop from my Ubuntu Linux laptop.  Both are at the latest versions, however the Linux version is a bit behind the Windows one it appears (v12.0.81460 on Windows, and Linux is v12.0.76279).

    My graphics card is a GeForce GTX 760, if that helps.

    Dave

  • Karrok
    Karrok Posts: 5

    Same as Dave, tried all the settings on both clients, and it still doesn't show the context menus of visual studio

  • its works for me.

    Online Game (Ayo Dance & Lost Saga) not showing window application then I disable

    – Ignore alpha blending on this computer

    – Disable Aero color scheme when using automatic quality

    finnally the window appear again :)

    thanks for your answer mister

  • jtl
    jtl Posts: 1

    tried all settings nothing works. still can't see menus in visual studio and ssms

  • JudeAustin
    JudeAustin Posts: 1

    Do this:

    When connected to remote computer click "View" on the TeamViewer menu.

    Then click "Select Single Window" to the right and click anywhere in VS.

    You should see a blue border around VS now.

    Now click a menu option and you should see the menu now.

    Thanks,
    Jude

Sign In or Register to comment.