link icon
Ask The Community

Connect to the host, but only see black screen

I'm using a windows 7 proffesional desktop to control a windows 10 host desktop. Everything was fine, until yesterday, when i connect to the host, however it shows a total black screen, and the window freezes ( i can tell, because if i select an option from the TV's menu on the top on the window, the menu stays there forever, and if i select another, it just overlaps ). I tried to connect to the host from another desktop ( in the same lan with the first ), and it's working fine. I tried reinstalling, i tried downgrading both, the issue still remains. What can i do ?

P.S. Before the issue appeares, i connected to the host via smartphone, can that caused the issue somehow ?

Best Answer



  • Julia
    Julia Posts: 290 Staff member 🤠

    Hi Orcus,

    Thank you for the post. Which TeamViewer version is installed? I need the version number :)

    You can find it in TeamViewer under "Help - About"

    Senior Support Engineer - 2nd level Support
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • Orcus
    Orcus Posts: 4

    Version 12. Tried version 11, but didn't solve it

  • Orcus
    Orcus Posts: 4

    12.0.81460 to be precise 

  • Orcus
    Orcus Posts: 4

    Thank you for the fast responce!

    I just installed it to the desktop, it works fine now. But i haven't install it to the host. Should i install it to be safe ? Also, should i install it to the rest desktops i use to control the host ?

    Also, on the version you gave me, it says there is an available new version. Should i upgrade it ?

  • Julia
    Julia Posts: 290 Staff member 🤠

    Hi Orcus,

    I have sent you the previous release - the issue with the black screen is a bug in the current version and using the previous version is a workaround.

    So please do not update to the current version ;)

    I will inform you when we published a new version with a fix.

    Senior Support Engineer - 2nd level Support
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • mtuliov
    mtuliov Posts: 1



    I have the same problem, but when I access the host by an Android smartphone. I installed this version of your link on Host PC and reinstalled the latest version of Android, but the problem continues ... black screen. What can I do?

  • Hustiniano
    Hustiniano Posts: 3 ✭✭

    I have recently started using a new PC riunning Win10 Pro, and am trying to control it from my old PC WIn7 Pro. I have tried to set the option to diable user input and black the screen on the Win10 PC when controlled from the Win7. A message splashes up on the Win10 PC saying I need to install a monitor driver - whaich I say yes to, and then nothing happens for a while. Then the WIn10 screen goes black and when I try to control it from the Win7 PC I can for about 15 seconds - and then the Win10 screen I am seeing on my Win7 pc goes black for about 15 secs then comes backa again then goes black again and on and on

    So I disconnect the WIn10 PC from the WIn7 PC. Then I go the the Win10 PC (physically) and despite not being connected to any TV connection ,teh screen keeps going black every 15 seconds

    So I close TV on the Win10Pc - and still the screen keeps going black every 15 secs

    It is only after rebooting my Win10 PC that I get control back on my Win10 PC without the black screen hitting every 15secs

    So please let me know when this is fixed in the new TV12. Until then I will run TV11 as suggested in the workaround on this thread

    Many thanks


  • I also have the same problem. I only get black screen when connection is establish. Im using windows 8.1 64bit & running TV 12.
  • Same problem here as of 9/26/2017. Both host and client are running the latest version of Teamviewer, but when connecting all I see is a dark gray (almost black) screen. I've tried fiddling with the connection quality settings but nothing works.

    Aorus x7Pro Laptop
    Windows 7 Enterprise 64

    Host: (multiple configurations/vendors/OS)

    Interestingly, if I enable SLI on my laptop (2 x GTX970M), it WORKS. Until I started using version 12 however, Teamviewer worked fine in single GPU mode. Very strange...

  • v13 doesn't fix the issue either.   


    12.0.83369 was also bad.  

    The only way I can get it to work is to uninstall and go back to 12.0.77831 and then it works.   

    Please fix this!

  • Hello there, first of all thanks for this great program keeping as free.
    I have black screeen problem too. I have lots of combination to eliminate this issue. But i didn't. I found some strange behaviour on windows 10.
    When this issue occured, i used another remote program, which is google remote control software, shows same result as black screen.
    Also when attach to vga monitor wit vga cable, while getting black screen everything works well again.
    When i remove driver from system & disable vga card, it works well. when vga disabled, resolution is 800*600 only work with this situation well.
    I think windows shut down the main monitor for this applications. I could'nt any solution by software side but i will do dummy vga connector for windows thinking as attached monitor.
    I just report and share my exprience for better Teamviewer.
    I hope you find good solution for this. Thanks for reading.

    My specs:
    Latest updated windows 10 64 Bit
    Intel Pentium G4400 Serie CPU(integrated intel hd Graphic 630 Vga)
    Asus H270 Plus Mobo 
    8 gb ram


  • Hi

    I have found quite a weird solution to this blackness software bug... 

    I have established a second connection to the same client - the system did warm me that there was already an active session to that remote client but I have OK-d the dialogbox and continued establishing the connection...

    Guess what haqs happenned: the new (second) session did not have any blackenig issues. So I have closed down the first - blackened - session and I continued working on the remote PC as nothing had happenned.

    Please check this on your environment as well...

    Hope this helps,


    I am running the latest 1709 version (Fall Creators Update) of Windows 10 opn both PCs.

  • Does not help for me, since 12.0.8something the problem remains to latest 13.0.5640. I've read at some other post it could have something to do with some GPU acceleration introduced around 12.0.7/12.0.8 update. That is most likely the problem as I have GeForce 4 Ti 4200 in this XP rig which does only support ancient OpenGL/DirectX versions. There are way more ppl like me with old HW, or newer HW and unsupported Linux graphics configurations etc.

    It is very unsettling to see developers just pushing one version after another with lttle to no testing. Do you even have some theoretical knowledge of what might get broken with the new stuff, when you do not test it while pushing it to everbody through automatic updates? I kinda doubt so, as could be seen (especially if you test it the way you do security, as we all remember the huge leak few years ago).

    You obviously still believe it works fine on all systems when you list no minimum system requirements anywhere (at least I found nothing - does it indeed work on 2000? 98? NT?). Well, guess what - it does not. Would be nice to return the non-GPU acceleration at least as an option in the app settings. And don't you ppl want some old HW for compatibility testing? Do you even have some lab for such purpose? I am just supplying one much greater corporation than you are with HW especially for this purpose. It makes sense for them when they only make so much money as many ppl use their product (working product ofc). I think it is the same with TV, so this is serious offer - you may think you know better, but with this attitude you'll be surprised when customers start leaving you. I'll definitelly switch to something else if this is not addressed soon - no reason for me to use broken application.

  • It's not their fault or their problem really. The problem is (at least for me) there is no screen connected or on/awake to make the grafics output a signal. I'm not sure if teamviewer can even do anythig about it from their end. I beleive the solution to this problem is with the OS or grafics cards/drivers. If you have a screen on while using teamviewer does it then work?

  • I think you are talking about totaly unrelated thing. Besides, from my experience, first VGA always works, only second and others should require dummy output to initialise. But that may have been improved with later drivers.

  • Having same problem. Trying to connect to my cryptominer win 10 from mobile app and only see black screen. Even tried from pc to connect but only see cursor move. Not close to the miner to see whats happening. Did a reboot but still fails. Worked perfectly yesterday.
  • Hi,

    I'm also experiencing this issue. Try to connect to my mining rig and only see a black screen. The starnge thing is, as soon as I connect to the miner from my pc via RDP, the teamviewer App on my Android phone workes perfect. As soon as I dont use the RDP anymore from my PC the teamvierwer App will show the black screen again as soon as I try to connect. This is very frustrating because when I'm at home I can use RDP, teamviwer is used when I'm not at home, so no RDP active.

  • l1one
    l1one Posts: 2

    So funny to see all the miners here.  I am a miner as well and I am getting the black screen too. Like others when I plug in a monitor and try to remotely connect it works fine.  Kindly fix!

  • samsquared
    samsquared Posts: 2 ✭✭

    I have this same problem when connecting from a Windows 10 client to a Win 7 laptop host after rebooting the host.  I noticed that if I leave the host laptop's lid open so that the screen comes on and reboot, I get the expected login screen instead of the black screen.  Perhaps there's a setting on the host that needs to be changed?  I have it set to "do nothing" if the lid is closed and it has AC power.  For me it appears to be a problem only the first time I connect after the host has rebooted.  The version on the client and host is 12.0.90922.

  • I have had a similar problem, which started 3 days ago. I have a Windows 10 Laptop which had the latest version of 12 installed. I was connected to a Windows 7 remote host that had Version 12 installed. Nothing changed on the remote host. I was able to connect to it via an iPad TeamViewer session and from a Windows 10 Desktop. The Windows 10 Laptop continued to display a locked black screen when connecting remotely to anything, even the Windows 10 Desktop mentioned. 

    I upgraded every host to Version 13. Problem persisted on the Laptop. I have had to downgrade to Version 11 in order for the Laptop to connect to remote sessions. Is there perhaps a known Windows 10 update which may have interfered with my Version 12 or 13 settings for remote display? 

  • same problem here, but when i connect a monitor everything works perfect. So it has something to do with the VGA drivers, I think.

  • My host is not headless. It has monitors connected. It has something to do with the client side connection. I could connect between the other two machines fine. Host to host, so to speak. Just not from laptop client to remote hosts. 

  • Hi,

    I have the same issue with one of our user's computer.  After connection is established all I see in the remote window is black screen but on the computer that you are connected is working fine. I have tried uninstalling and reinstalling but same thing. Team version is updated to the latest version 13.0.6447. User's computer is running windows 7.

    Joey Ouano

  • l1one
    l1one Posts: 2

    Is there any update on this? I tried the switching to the version teamviewer posted in the thread on both client and host but have the same issue when running headless.

    Any update with a very clear solution would be greatly appreciated!

  • Do not think so, nobody cares. Does anybody recommend any alternative for the SW?

  • Unfortunately my elation that the problem is solved after reinstalling the suggested version and finding that it all works, has been short lived.  The problem just re-appeared notwithstanding being on the suggested version.

  • Try turn on monitor. Yes, the phisical one. I discovered that solution yesterday. Maybe that overlaps with other problem with correct version byt definatelly helped in my situation.

    I have laptop in the office and untill the screen was OFF I can see only black screen on RDP sessions I tried to launch remotely. I can work and do almost everything else, besides RDP. After turning screen ON and reconnect, RDP starts working like a charm :)

  • ekreger
    ekreger Posts: 1

    Only just started couple of days ago. I remote access from my Win7 laptop to Ubunutu 17.10. Black screen and nothing else. Tried pushing back to version 12 on Win7, didn't work. Worked fine few days ago.

    SSMCPA Posts: 7

    I had a similar issue connecting from an older laptop with Windows 10 to a newer laptop with widows 10.  I was using Teamviewer 13 on both laptops.  The newer laptop could connect to the older one fine but if I tried to go the other way all I got was a black screen. I also noticed that if I minimized the top toolbar it just seemed to go up but left a grey streak.  I found out that removing my Nvidia drivers & software cured this issue.  I can now connect either way with no issue.