link icon
Ask The Community

A Comunidade TeamViewer chega ao Brasil 🎉

Check out our brand-new Portuguese Community 👉 here 👈.

No connection to TeamViewer server



  • Hi All,

    After fiddling around a while I finally got to the conclusion that TV won't work on Wayland, no matter what others postulates.

    Both the tar and the rpm installation of 11 and 12 fails connecting to the teamviewerd, fails to get the Xorg auth (according to logs) and ultimately fails working.

    The second I change to Xorg it works though - Both 11 and 12 versions and both tar and .rpm.

    I'm at Fedora 25, properly updated and using Wayland.

    (For easy checking whether you are on Wayland or Xorg do Alt-F2 and try the "r" command - Wayland won't reload as Xorg will).

    If Teamviewer manages to make it work on Wayland, I'll definetely consider upgrading my 11 to 12, but not before!

    So far I run all my TV sessions selecting Xorg for that specific session.

    I want to stick to Wayland for all other purposes as this is the way the development goes.


    Axel Nielsen

  • Hi everybody, I have the same problem on Centos 7. Does anyone have a solution ?
  • OK, there is no solution. The only way to make TV working is to set "Gnome on XOrg "desktop at login.

    Anyway if you have problems that on F24 you did not had. You need to switch to Gnome on XOrg instead of the default Gnome desktop wich uses XWayland.

  • I have te same problem "No connection to TeamViewer server", but in Windows8.1 (with all updates for 64bit version).
    I've had this once before, after upgrading from v11 to v12
    It was a **bleep** of a job to get in touch with TV help, in Facebook as well as in Twitter.
    They are busy and imho they forget scanning customer questions in FB and TW. This performance must be improved, absolutely!

  • some time ago I upgraded from v11 to v12, result:

    No connection to TeamViewer server.

    updating v12 to a newer version, result:

    No connection to TeamViewer server.

    hold your breath, they have problems, i think!


  • Now is good,they are data case is bad,tomorrow waste so many time:(
  • daxryan
    daxryan Posts: 1

    same here... no connection to teamviewer server since April 9 upgrade

  • Telbiur
    Telbiur Posts: 1

    No TeamViewer Network Access (

    We are an ISP. Our customers report that they can not use the program.

    Below tracert to


    C:\Documents and Settings\Administrator>tracert

    Trasa śledzenia do []
    przewyższa maksymalną liczbę przeskoków 30

    1 1 ms 1 ms 1 ms mt-polna []
    2 1 ms * 1 ms
    3 2 ms 2 ms 2 ms []
    4 9 ms 7 ms 7 ms
    5 6 ms 6 ms 6 ms []
    6 19 ms 18 ms 19 ms []
    7 27 ms 27 ms 27 ms []
    8 28 ms 28 ms 28 ms []
    9 28 ms 28 ms 28 ms []
    10 29 ms 28 ms 29 ms []
    11 33 ms 36 ms 33 ms []
    12 33 ms 32 ms 33 ms []
    13 33 ms 33 ms 33 ms
    14 * * * Upłynął limit czasu żądania.
    15 * * * Upłynął limit czasu żądania.
  • Mersault
    Mersault Posts: 1

    Same issue since I updated to version 12. I'm on Ubuntu Gnome 16.10 and installed through the debian package on the web.

    Remote connection is working but I cannot login to my account

  • some time ago I received a mail. TV crew answered, they are still working on it.
    It looks to me it's difficult, because it already took some time...
    Hold your breath...


    regards, Geminialpha

  • chris_tv
    chris_tv Posts: 2
    If running on Linux, try restarting the TeamViewer daemon, e.g. 'service teamviewerd restart'. I can't remember where I saw this suggestion, but this works for me. The explanation was that it's caused by a race condition. Hope it helps someone.
  • zeljan
    zeljan Posts: 1

    Fedora 25 without wayland (KDE Plasma), restarting teamviewerd service fixed my problem.

  • hi, i am also having this same problem with my team viewer as mentioned below.

    may i know how i can have this solved?


  • hi, i am also having this same problem with my team viewer as mentioned below.

    may i know how i can have this solved?

  • oglop
    oglop Posts: 1

    restarting the daemon works magically

    systemctl restart teamviewerd


    service teamviewerd restart
  • dpayton
    dpayton Posts: 1

    This worked for me on Zorin. Thanks!

  • vongts
    vongts Posts: 1

    It becauses of IP V6.

    I got the same issue then I check this case, using mobile to test teamviewer I see it works but not work with my wifi. So I think this cause of my network. Called to network service they came and check and see that my network use both ip v4 & ip v6 (maybe switch sometime between v4 & v6). Then they set it use ip v4 only then Teamviewer works for me.

    Hope that it help for someone got issue like me.


  • Thanks, that fixed my problem.

  • Well, for those having problems even with the tarball, I just discovered that it wil not work if you install the tarball (tv-setup install), but it will if you run directly the teamviewer executable in the folder where you extract the tarball. 

    From what I can see, the difference is that a so-called "Network process" is not started when you run it from the installed version while it does start if you run teamviewer directly from the folder where you extract the tarball. More than a Wayland problem this seems like a permissions problem when you install under Wayland...

  • It sound reasonable - As far as I remember, the root cause at my system was that the program had not the right permissions to open a window in Wayland - Hence it was not allowed to start the session in a Wayland window. For the time beeing I only run TeamViewer from my workstation - It uses Xorg due to some Nvidia driver compatibility issues... My notebook however, still has the issue, just chose not to use it for TeamViewer...
  • After lots of mail back and forth with TV helpdesk and trying their several proposed solutions, it finally works. I now use TV12-0-83-369 on Win8.1 and i'm happy!

    Hang on with their help crew!

  • Cg_A
    Cg_A Posts: 1

    I downloaded the full TeamViewer appy and installed it on my Win7 PC. I pinned a start button to the task bar and when I touch it, there is a flash and then no further evidence that it is ready and no window showing its ready. When I login to, I get a page with a list of my computers i have loaded TeamViewer in to but there is no button or action i can find to begin looking at the remote laptop from my PC. One bit of help from *someone* seems to indicate I may have a firewall problem but I dont know why that would keep me from seeing another computer inside my router network ??? Any help, anyone?

  • That did the trick for me :) Fedora 27 - Wayland


  • joshuakL
    joshuakL Posts: 2

    sudo does not work.  but running from su  does. 




    Im running arch wayland

  • joshuakL
    joshuakL Posts: 2

    you need to 



    sudo will not work.

  • phpolo
    phpolo Posts: 1

    I found only one way to clear this problem occured few days ago...

    I have unistall Version 13 and reinstalled old version 11 now every thing work fine.