teamviewer.com link icon
or
Ask The Community

A Comunidade TeamViewer chega ao Brasil 🎉


Check out our brand-new Portuguese Community 👉 here 👈.

Lenovo Tab M10 - Is it fully supported by TeamViewer Host?

Hi,

I am trying to help a lady with dementia who has a Samsung Galaxy Tab A7 (2020) which almost works perfectly with TeamViewer Host, but with the restriction that the tablet has to be in portrait orientation for the remote connection to work properly. See the post linked below.

So I'm considering whether a Lenovo Tab M10 would work perfectly with TeamViewer Host? I need it to allow remote control connections without any user interaction (unattended remote control), and I need it to work regardless of whether the tablet is in portrait or landscape orientation. Ideally I'd like it to work even if the tablet is currently sat on the table snoozing.

I've read that Samsung is the main supported range, but I have problems with them. I've also read that Lenovo tablets may be supported but I couldn't find details.

Is there a list of fully tested and supported tablets?

Does anyone have a tablet that works perfectly, if so which one?

Thanks in advance for any help,

Cheers,

Mark



Comments

  • JoshP
    JoshP Posts: 579 Senior Moderator
    edited February 18

    Hello @marky1124

    Thanks for your post.

    Regarding the portrait mode issue in the linked post; I see some users in there mentioned that updates from Samsung in December may have fixed it, so please ensure the latest versions of both TeamViewer and the OS are on the device. We will also reach out to see if any more information is available on our end, should the issues persist.

    Also mentioned in the linked thread, the issue was one due to a conflict between Samsung Knox and TeamViewer; any other supported manufacturer device should not experience such an issue.

    Last, we do not have a list of supported devices, as we can only guarantee certain manufacturers themselves are supported. That being said, supported manufacturer devices for the most part should have no issue.

    As Lenovo is listed in our Supported Android Manufacturers for Remote Control hub article, there should not be any issues connecting or controlling most Lenovo tablets. Of course, feel free to post here should you encounter any issues using TeamViewer on Android or Lenovo.

    Josh P.
    Senior Community Moderator

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • marky1124
    marky1124 Posts: 7 ✭✭
    edited February 21

    Hi Josh,

    Thank you for your reply.

    I have just tested again and if the physical screen orientation is landscape, or indeed upside down portrait, then I can't connect from my Windows 10 laptop running TeamViewer 15.14.5 to the Samsung Galaxy Tab A7 running TeamViewer Host 15.14.35. The tablet is running T500XXSAATL1/T5000XM2ATK3 'security update 1st Dec 2020'. I asked it to check for more recent system updates and it didn't find any. I saw the post from Smc2 reporting success with T510XXU3BTK1/T500OXM3BTK1 unfortunately that's a different tablet. That is the Samsung Galaxy Tab A 10.1 (2016) whereas mine is Samsung Galaxy Tab A7 10.4 (2020) see https://www.gsmarena.com/compare.php3?idPhone1=8090&idPhone2=10411.

    Looking at Samsung's website it's not clear which row is for the United Kingdom (where I am) but it appears that I've likely got the latest firmware they've released. https://www.sammobile.com/samsung/galaxy-tab-a7/firmware/#SM-T500

    I am running Knox v3.5, Knox API level 31.

    Let me know if there is more I can do to provide you with diagnostics that might help resolve this problem.

    All the best,

    Cheers,

    Mark

  • ClipOn
    ClipOn Posts: 1

    Hello,

    I add my experience using 2 Lenovo Tab M10 FHD Plus TB-X606F. One is on the same WAN as my Windows 10 PC and the other one is remote at my old parents.

    Whatever I use Quick Support or Team Viewer Host, after some time or some other thing I am not able to identify, I need to restart the Tab to be able to see the Remote Screen on my PC.

    On the PC, the Remote Control window opens but remains with the message as Connected but the Remote Screen never shows. On the Tab, Quick Support or if I start Team Viewer Host to analyze what happens, both says ''Connected'' with the green dot.

    On the Tab in front of me, I disabled Echo mode in Host, but same: I need to reboot. When connected, if I put the Tab in standy, I get wake it from my PC and enter the PIN Code, everything runs perfect.

    Is this a known ''bug'' or may I have something to do ? Because for very old people as my parents, even restarting the Tab is not so easy, so I would like to be able to get Remote Control anytime.

    Many thanks

  • marky1124
    marky1124 Posts: 7 ✭✭
    edited March 28

    Hi @JoshP

    I just wanted to confirm that the latest Samsung update has fixed it for me for the Samsung Galaxy Tab A7. I received update T500XXU3AUC6/T5000XM3AUC6 'security update 1st March 2021' and a quick test afterwards confirmed that I was able to connect to the tablet from my phone even when the tablet was in landscape mode and I could click on buttons, type in values and generally operate it successfully. So thank you for anyone that helped resolve this issue.

    Cheers,

    Mark

  • StuartWLVS
    StuartWLVS Posts: 2 ✭✭
    edited July 30

    Regarding TeamViewer & Host with Lenovo tab M10 FHD Plus TB-X606F

    Host Version: 15.19.88 I am testing on two Lenovo tablets.

    TeamViewer Version: 32 bit 15.20.3 on Windows 10 laptop.

    First problem: Host service closes after 10 minutes.

    It seems that if battery optimization is on, then Host will not run in the background indefinitely. After 10 minutes precisely the Host app closes.

    Action taken: Launch Hosts > Advanced options > Eco Mode Disabled.

    Also: Settings> Apps & Notifications > See all NN Apps > Host > Battery > Change from Optimised to NOT Optimised ( Drop arrow on “Not Optimised” > All Apps > Host > “Don’t Optimise” ).

    Remaining problem is that after a period of time a connection is still possible but it hangs at "Connecting to Lenovo tab M10 FHD Plus TB-X606F" and fails to display the tablet screen. Other features like Dashboard, Apps & Settings are available. It is just the Remote Control Tab which just hangs as described above.


    As stated by ClipOn, a restart of the tablet works round the problem but the very reason we are both offering support is for elderly folks who would struggle at the best of times.


    I note that the Playstore mentions a variety of TeamViewer Add-Ons and that on the Samsung tablets the Host Apps Advanced settings states: “Activate Remote Control / Remote control feature is active”. Whereas on the Lenovo it states: “Install additional Add-On”.


    So, anyone out there got any suggestions?


    Thanks.

    Stuart

  • StuartWLVS
    StuartWLVS Posts: 2 ✭✭

    Update:

    I have uninstalled Host and the TeamViewer Add-on and reinstalled Host from Google Play Store noting that the Host is now Ver: 15.20.101 HM ( Updated 26/7/21) and that it pops up with:

    "Add-On Available. This device supports our Remote Control feature. In order to use this feature, please download our free Add-On.”  

    The add on offered is “Add-on: Lenovo TB 850F” (Version 14.5.117)" but my devices are Lenovo tab M10 FHD Plus TB-X606F

    Upon installation a message reads: “This app may not be optimized for your device”.

    Inspecting the Host Advanced properties: “Install additional Add-On” is displayed but greyed out.

    This suggests that TeamViewer need to create a Add-on for the Lenovo tab M10 FHD Plus TB-X606

    Stuart