link icon
Ask The Community

No Connection To Partner

Stewert Posts: 2 ✭✭

Ever since upgrading to v12 I keep getting the following error

No connection to partner!

Partner did not connect to router.

Erroer Code: WaitforConnectFailed

I have tried to connect with multiple devices to multiple machines. I even get the error from machine to machine.

If I keep trying sometimes it will connect or I will get another error stating that I have to wait for a bit before trying again.

Please Help.



  • kayla
    kayla Posts: 2

    did you find a solution for this error? I am having the same problem!

  • Stewert
    Stewert Posts: 2 ✭✭
    I have not yet found a solution for this issue. I still get connections intermittently. Meaning that sometimes it connects, sometimes it doesn't connect.
  • Jonathan
    Jonathan Posts: 245 Former Staff

    Hi Stewert and Kayla,

    Thanks for your posts!

    Sorry you are having trouble making connections. Basic trouble shooting steps include but are not limited to:

    1. Restart TeamViewer on both sides of the connection
    2. Uninstall the current application and install a fresh copy on both sides of connection
    3. Make sure internet connection on both sides is active

    If you can try these steps usually it will correct the issue. If not please let me know.

    All the best,



  • kayla
    kayla Posts: 2

     Thank you for your reply.
     the restart and uninstall steps have been done mulitiple times on each computer and it still has this error come up " No connection to Partner, Partner did not connect to Router, errorcode:WaitForConnectFailed" 

    I am connecting with  a PC to a MAC computer if that has anything to do with it.
    and ther is at times when I can connect but its more often that I can't connect then I can...

  • keyxmakerx
    keyxmakerx Posts: 3

    I'm also having this problem, these are fresh installs as well. I have reinstalled to be sure. It is from an android phone > my linux pc. I've not had this issue till upgrading to v12. 

  • madbilly84
    madbilly84 Posts: 2

    the problem is when  we using the same ISP. If you get on internet via 4g (hotspot) from your phone. The program is working fine but with ADSL no..... i had the same problem and i found this solution for instant

  • keyxmakerx
    keyxmakerx Posts: 3

    I've tried two different carriers, Google Fi and Earthlink, neither is working. I have ATT at the other location. 

  • madbilly84
    madbilly84 Posts: 2
    Try over 4G and don't​ bother for the other side.
    With mobile app all things running ok to me
  • keyxmakerx
    keyxmakerx Posts: 3

    Already tried, still not getting it to work. 

  • maksmms
    maksmms Posts: 1

    Hi, i had similar problem. Then i open the log and see some special symbol before partner number.

    It appears when i copy/paste number from any place, i entered number by my keyboard and connect was successfull. Hope it helps to someone.

  • chris_tv
    chris_tv Posts: 2
    If running on Linux, try restarting the TeamViewer daemon, e.g. 'service teamviewerd restart'. I can't remember where I saw this suggestion, but this works for me. The explanation was that it's caused by a race condition. Hope it helps someone.
  • teopas11
    teopas11 Posts: 1

    I hane the same problem. Impossible to connect with my partner. I have already tried all the proposed solutions but nothing happened. I don't know what else to do!

  • I downgraded to version 11 and it's working fine for me now.

    Here's the previous versions link:

  • MBS
    MBS Posts: 6

     Restarting the service worked for me too.  Problem is, I can't do that from home, so I still cannot remote in. Any further ideas?









  • I have the same identical problem and I am unable to restart the machine as it is in a site without people. I solved (just now, I have to verify it again) by logging in putting the ID number instead than clicking in the remote PC icon on my contacts account.

  • I was wrong, it was a coincidence. I have not found a way to connect to a non responding remote computer.

  • jimbaum
    jimbaum Posts: 1

    I have same issue on ver 12. It all happened when my Win10 computer was having some sort of internet connectivity problems. At that time, I uninstalled ver 11, and installed ver 12.  Worked for about 3 weeks until this problem.

    Apparently the computer again, is having connectivity problems. It cannot open web pages, etc.  Perhaps this is some sort of Windows problem after an update?  I have win 10 that was upgraded from Win 7 about a year ago.

  • bartlanz
    bartlanz Posts: 324 ✭✭✭

    If the computer does not have internet access, TeamViewer will not work either.

    I did have one laptop that got an update to Windows 10 that broke its internet access, I don't know how or why though. I rolled back the windows update and it came back.

    If my post was helpful, Please throw me a Kudos.
    If my post fixed your issue, please mark it as the solution to help the next person find a solution quickly.
    Bart Lanzillotti
    We Do IT USA
  • My remote computer has no connectivity problems when this issue happens.

    I also tried to use a VPN but it did not solve the issue.

  • ColinK
    ColinK Posts: 4 ✭✭

    Just started happening to me. Win10 desktop (12.0.78313) to Win10 Tablet. (11.0.76421

    Same error message as others but chat works OK. 

    Update to 12 failed, removed and installed 12 (not easy on a tiny tablet with out remote access).

    Same erorr on 3 attempts. Then suddenly it worked.

    Now there is no popup of chat notification, but chat still works. Show notifications enabled on Desktop and Tablet.

    Disconnected, tried to reconnect, same error, then seemed to conect without me doing anything (I may be wrong about doing nothing).

    Second tablet on V11 still working OK


  • wrswaim
    wrswaim Posts: 19

    Interesting this has been an ongoing issue since March of this year and yet no solution has been found.

    Both of the pc's I access remotely show up as ready to be accessed (they have been running on unattended access always) and yet every time I connect it says "No conection to partner" - once in ever so many attempts on both pc's one will say "ready to connect" but it just stays there, the screen of the other pc never comes up.

    I need a fix on this STAT!  Thank you.




  • Cyuena
    Cyuena Posts: 2

    This past week, I started having this problem suddenly, trying to connect to one of my PCs (it is running Win10). There has been no major changes to that machine/router/internet that I know of, it is sitting idle (not torrenting) at the moment, and where Teamviewer had been working fine before.

    During testing this morning, it actually connected 2 times and I was able to use that remote PC as usual. So it does work! But as soon as I disconnect, I have to try many times to reconnect again and I keep getting the same error message "No connection to partner! Partner did not connect to router. Error Code: WaitforConnectFailed".

    I have several devices on TeamViewer:
    - Desktop at home (the problem PC) running Win10.
    - Wife's laptop at home, on the same router, running Win7.
    - Desktop at my in-laws running Win 8.1.
    - Laptop at my in-laws running Win7.
    - 2 Android smartphones.
    - Parent's laptop running Win10 and 6,900km away over the Pacific Ocean.

    All the PCs and laptops are on wired networks (not wifi) and currently using TeamViewer 12.0.81460, whereas the smartphones are on 12.3.7343CL. They all have had no problems connecting to each other for many years, except just recently for that one PC.

    Any updates from the TeamViewer team on this issue? Or anyone else have a suggestion? Much appreciated for all your support. Cheers~

  • Cyuena
    Cyuena Posts: 2

    Update: I was able to connect the two desktops 3 times in a row! Pushing my luck, I tried using my smartphone, but then got the same error as before. And now I have lost all connectivity to that problem PC again with any device. It almost seems like that PC is sporadically busy, but it should be just sitting idle. Is there a way to check the internet traffic for a PC?

  • Dear Cyuena,
    Unfortunately I do not have any good answer yet. Recently I had less error episodes but it persists. I run:
    - Win 10 desktop in my institute (the computer with issues)
    - WinXP desktop in my institute
    - Win10 Desktop at home
    - Win7 laptop st home
    - Win10 work laptop

    Only on 1 computer I experienced this problem.

  • That's good advise, reboot and reinstall? How about why it happened in the first place. I have the same problem and the remote computer is a thousand miles away. How about a better solution. the purpose of teamviewer is REMOTE connection. 

  • MBS
    MBS Posts: 6

    I went back through the remote manual and found one setting (the WOL button) that was not correct. When fixed, it worked and has been working ever since. I would have sworn that it was set correctly...but it wasn't. So my best advice is check every setting again. It is much more likely a setting than a corrupted program.

  • MBS
    MBS Posts: 6

    One more thing - don't forget the Windows settings. I have to leave my computer running, not sleeping, for it to work. I know it isn't supposed to work that way, but that is what it does.

  • Hey Guys! Just solved the same problem... if your devices are on the same network, you have to change the LAN setting from deactivated to "Accept" That solved it for me!

    Hope that helps you too. I think when it updated it changed some default I'd start there.

  • Thank you for the information goodevoice.

    Unfortunately I am not on the same network but i have to control the target computer from a remote position. Anyway, it seems that in the last period it is working well, I haven't experienced any troubles for many days until now.

  • jradwan
    jradwan Posts: 15

    I'm running into this problem a lot as well!

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!