link icon
Ask The Community

Installation Error on Ubuntu 17.04

Hi, I'm trying to install teamviewer on ubuntu 17.04.

To do that I've downloaded teamviewer_12.0.76279_i386.deb, I launch it but when I click on install button nothing happen.

So by command line I've tried the following command:

apt install /teamviewer_12.0.76279_i386.deb

But the result was an error: unsupported file given on command line

What's wrong??

Best Answer


  • luca72
    luca72 Posts: 2

    Thank you ChristianCay,

    I've tried your solution successfully.

  • afsah
    afsah Posts: 2

    Dear Christian,

    I am facing the same problem but the mentioned solution didn't work. I am using Ubuntu 16.04.



  • ChristianCay
    ChristianCay Posts: 182 Staff member 🤠

    Dear Afsah,

    Thank you for contacting TeamViewer.

    Is it possible display the out that you're getting to solve your issue?

    We are looking forward to your comments.


    Best regards,


    Did my reply answer your question? Accept it as a solution to help others, Thanks.
  • afsah
    afsah Posts: 2

    Dear Christian,

    Apologies for the delay. Attached is the screnshot.

    While running the first command, I got this, "Errors were encountered while processing:
     teamviewer:i386". And while running the second I got,  "Unpacking libpng12-0:i386 (1.2.54-1ubuntu1) over (1.2.50-2+deb8u3) ...
    dpkg: error processing archive /var/cache/apt/archives/libpng12-0_1.2.54-1ubuntu1_i386.deb (--unpack):
     trying to overwrite shared '/usr/share/doc/libpng12-0/KNOWNBUG', which is different from other instances of package libpng12-0:i386
    Processing triggers for libc-bin (2.23-0ubuntu9) ...
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)"



  • hi - i did this installation and it works - :-( but only in one direction. If I'm at the Ubuntu Desktop I'm able to control my iMac and my Win10 computers. If I try to control the Ubuntu-Laptop the connection works and I do see my Ubuntu Desktop.

    BUT: I can move the mouse in every way :-) nothing happens on the Ubuntu Desktop...

    PLEASE: heeeeelp? - since three day I cannot fix this.... I struggle 

    kind regards, Achim

Sign In or Register to comment.