teamviewer.com link icon
or
Ask The Community

Won't open after update to 13 on Centos 7

I just upgraded to TV 13 and the app won't open.

I'm getting the following error in gui.log:

/opt/teamviewer/tv_bin/TeamViewer: error while loading shared libraries: libQt5WebKitWidgets.so.5: cannot open shared object file: No such file or directory

Installed according to https://community.teamviewer.com/t5/Linux/Update-TeamViewer-Host-on-RedHat-and-CentOS/td-p/14512

Best Answers

Answers

  • Iain_wels
    Iain_wels Posts: 54 ✭✭

    Hello jgreep,

    How did you update to teamviewer 13? What license did you have on you're previous teamviewer? Which teamviewer was that? Maybe i could help if i know these questions!

    Thank you for using teamviewer.

    With kind regards, Met vriendelijke groet,
    Iain Wels,
    ICT-Support
    If you found this helpfull please verify it as an solution, so it could help other people
  • jgreep
    jgreep Posts: 10

    I initially installed using the RPM from the TeamViewer website.  It installed fine, but wouldn't run.  I read that I needed to completely uninstall the previous version (12) before installing.  That did nothing.  I followed the install instructions in the link in the OP.

    I'm using it for personal use, so no license per se.

  • Iain_wels
    Iain_wels Posts: 54 ✭✭

    Hello jgreep,
                                                                                                      
    Did you try to uninstalling with this option marked on?

    When you are deleting teamviewer put check the box (where the red arrow is pointing on) . That option clears all you're all you're settingsWhen you are deleting teamviewer put check the box (where the red arrow is pointing on) . That option clears all you're all you're settings

    I hope this helps,

    Thank you for using teamviewer.

    With kind regards, Met vriendelijke groet,
    Iain Wels,
    ICT-Support
    If you found this helpfull please verify it as an solution, so it could help other people
  • jgreep
    jgreep Posts: 10

    I don't get an uninstall window for Linux.  I manually deleted all of the TeamViewer folders using the recommended command: 

    sudo rm -rf /home/*/.local/share/teamviewer* /home/*/.config/teamviewer /opt/teamviewer

    I also did:

    yum remove teamviewer 

     

  • jgreep
    jgreep Posts: 10

    Yum just updated teamviewer to the latest version today: teamviewer-13.0.9865-0.x86_64

    The error persists and teamviewer is still unusable. 

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    @jgreep, can you please remove the package and install it again with

    yum install ./teamviewer-host*.rpm

    If it does not work, attach the complete output of that command.

    Linux Developer
  • jgreep
    jgreep Posts: 10

    I removed it and re-installed:

     

    $ sudo yum install ./teamviewer-host*.rpm
    Loaded plugins: fastestmirror, langpacks, versionlock
    Examining ./teamviewer-host_13.0.5641.x86_64.rpm: teamviewer-host-13.0.5641-0.x86_64
    Marking ./teamviewer-host_13.0.5641.x86_64.rpm to be installed
    Examining ./teamviewer-host.x86_64.rpm: teamviewer-host-13.0.5641-0.x86_64
    Marking ./teamviewer-host.x86_64.rpm to be installed
    Resolving Dependencies
    --> Running transaction check
    ---> Package teamviewer-host.x86_64 0:13.0.5641-0 will be installed
    --> Finished Dependency Resolution

    Dependencies Resolved

    ===============================================================================================================
    Package Arch Version Repository Size
    ===============================================================================================================
    Installing:
    teamviewer-host x86_64 13.0.5641-0 /teamviewer-host_13.0.5641.x86_64 58 M

    Transaction Summary
    ===============================================================================================================
    Install 1 Package

    Total size: 58 M
    Installed size: 58 M
    Is this ok [y/d/N]: y
    Downloading packages:
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    Installing : teamviewer-host-13.0.5641-0.x86_64 1/1
    gtk-update-icon-cache: Cache file created successfully.
    Verifying : teamviewer-host-13.0.5641-0.x86_64 1/1

    Installed:
    teamviewer-host.x86_64 0:13.0.5641-0

    Complete!

    The gui.log file has the same error.  Nothing happens when I run teamviewer from the command line

    Init...
    CheckCPU: SSE2 support: yes
    Checking setup...
    Launching TeamViewer ...
    Launching TeamViewer GUI ...



  • jgreep
    jgreep Posts: 10

    I removed it and re-installed:

     

    $ sudo yum install ./teamviewer-host*.rpm
    Loaded plugins: fastestmirror, langpacks, versionlock
    Examining ./teamviewer-host_13.0.5641.x86_64.rpm: teamviewer-host-13.0.5641-0.x86_64
    Marking ./teamviewer-host_13.0.5641.x86_64.rpm to be installed
    Examining ./teamviewer-host.x86_64.rpm: teamviewer-host-13.0.5641-0.x86_64
    Marking ./teamviewer-host.x86_64.rpm to be installed
    Resolving Dependencies
    --> Running transaction check
    ---> Package teamviewer-host.x86_64 0:13.0.5641-0 will be installed
    --> Finished Dependency Resolution

    Dependencies Resolved

    ===============================================================================================================
    Package Arch Version Repository Size
    ===============================================================================================================
    Installing:
    teamviewer-host x86_64 13.0.5641-0 /teamviewer-host_13.0.5641.x86_64 58 M

    Transaction Summary
    ===============================================================================================================
    Install 1 Package

    Total size: 58 M
    Installed size: 58 M
    Is this ok [y/d/N]: y
    Downloading packages:
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    Installing : teamviewer-host-13.0.5641-0.x86_64 1/1
    gtk-update-icon-cache: Cache file created successfully.
    Verifying : teamviewer-host-13.0.5641-0.x86_64 1/1

    Installed:
    teamviewer-host.x86_64 0:13.0.5641-0

    Complete!

    The gui.log file has the same error.  Nothing happens when I run teamviewer from the command line

    Init...
    CheckCPU: SSE2 support: yes
    Checking setup...
    Launching TeamViewer ...
    Launching TeamViewer GUI ...



  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    Please try this:

    teamviewer ps		# if any "TeamViewer" process is listed, kill it (not teamviewerd)
    ldd /opt/teamviewer/tv_bin/TeamViewer | grep 'not found' # any libs missing?

    # run from inside Xorg (e.g. Xterm)
    /opt/teamviewer/tv_bin/TeamViewer # any output?

    Best regards,

    Daniel

    Linux Developer
  • jgreep
    jgreep Posts: 10

    Here's my output:

    [...@localhost ~]$ teamviewer ps

    root 21484 0.3 0.1 1412444 8124 ? Sl Feb14 4:12 /opt/teamviewer/tv_bin/teamviewerd -d
    ... 25040 2.0 0.0 113528 1848 pts/0 S+ 08:14 0:00 /bin/bash /usr/bin/teamviewer ps

    [...@localhost ~]$ teamviewer daemon stop

    systemctl stop teamviewerd.service

    [...@localhost ~]$ teamviewer ps

    ... 25133 0.0 0.0 113528 1848 pts/0 S+ 08:14 0:00 /bin/bash /usr/bin/teamviewer ps

    [...@localhost ~]$ ldd /opt/teamviewer/tv_bin/TeamViewer | grep 'not found'
    libQt5WebKitWidgets.so.5 => not found
    libQt5WebKit.so.5 => not found
    [...@localhost ~]$ /opt/teamviewer/tv_bin/TeamViewer
    /opt/teamviewer/tv_bin/TeamViewer: error while loading shared libraries: libQt5WebKitWidgets.so.5: cannot open shared object file: No such file or directory

  • jgreep
    jgreep Posts: 10

    Teamviewer 12 worked just fine.  13 never worked after upgrading.

    CentOS Linux release 7.4.1708 (Core) 

    I hadn't seen the guide previously and I have the epel repositories installed.
    Installing the qt5-qtwebkit package worked perfectly. I'm not sure why that dependency wasn't flagged for me on the install.

    I appreciate your help with this!

  • Hello folks,

    On my RHEL system, which should be similar to Centos, i get this error when i try to install qt5-qtwebkit:

    yum install qt5-qtwebkit

    :yum install qt5-qtwebkit
    [sudo] password for raja:
    Loaded plugins: downloadkvmonly-background, ibm-check-lotus-updates, ibm-check-upgrade, ibm-check-xorg-updates, ibm-repository, langpacks, post-transaction-
                  : actions, refresh-packagekit, versionlock
    No package qt5-qtwebkit available.
    Error: Nothing to do

    Can you please advise which repo has this package so we may add it and try again?

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    Did you follow our TeamViewer on RHEL guide (enabling epel)?

    Cheers,
    Daniel

    Linux Developer
  • You need to install the epel first:

    yum install epel-release -y
  • oxcar9
    oxcar9 Posts: 2

    On RHEL 8 don't work!!!!

Sign In or Register to comment.