teamviewer.com link icon
or
Ask The Community

Can't change resolution on client

2»

Comments

  • Haven’t tested it myself, but you could try the solution with the “Detect Display” button, described here:
    https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/how-to-enable-a-fake-second-display-in-windows-10/3c02e2ee-cade-4916-be46-390e59ea2a04?auth=1
  • Almost 1 year further and still no solution!

    Just to be clear of the scenerio a recab of the problem:

    Put op Teamviewer session to a remote standalone PC with Widescreen resolution 3440x1440 monitor. When session is build up, screen resolution is presented as 640x480 no other resolution selection possible.

    1. Startup remote PC and TV 
    2. Leave remote PC monitor switched off
    3. Try to login to this PC with laptop or other PC
    4. Screen resolution presented in the TV session is 640x480 no other resolution selection possible.

    This event does NOT occur on a remote system with resolution of 1920x1200

    NOTE: When the monitor is switched on, it gives same result, but when you login localy and screenlock the system, a TV session to this machine wil give you the right resolution of 3440x1440. So we can conclude that there is some sort of detection issue as long as the Remote PC is not logged in before the TV session to this machine is started.

     

  • I have the same problem as well. Its related to my desktop being headless (not connected to a display). I know because the only way to fix the problem is to connect a display to the desktop and set the resolution of my choice and then disconnect. This buys me a few days of time till it stops working and a display needs to be reconnected. Very frustrating!

  • I've got the same problem.  It's a non-virtual, headless PC - an altcoin miner.  The only resolution offered is 640x480 which is far too low to do anything with.

  • Let's connect your computer with Monitor high resolution. After start computer is ok. i'm sure.


  • @nguyentuanson wrote:

    Let's connect your computer with Monitor high resolution. After start computer is ok. i'm sure.


    As I said, it's a non-virtual, headless computer.  It has no monitor, hence the need for TeamViewer or some other remote access software.

  • Let's read my last clear stated forum post of issue scenario. Reproduced the problem and explained.

  • I just plugged in an HDMI header and it works like a charm now. I was experiencing the painful 640x480 res.

    https://www.amazon.com/gp/product/B06XT1Z9TF/ref=oh_aui_search_detailpage?ie=UTF8&psc=1

  • elio7
    elio7 Posts: 3

    I have this 640x480 resolution problem until today:

    On Device Manager / Monitors I have a different name, it was not my BenQ XL2411Z.
    So I just uninstall it and remove the software.
    Then download the last BenQ XL2411Z driver.
    Go to Device Manager and look for new hardware.
    Add the new monitor driver.
    Make sure it have the correct name.

    After this I can connect again in 1680 x 1050.

  • Same issue here. Remote is Ubuntu 18.04 LTS and I have the higher resolution in the Display properties, but I can't adjust the resolution. Please fix this...
  • vdvb
    vdvb Posts: 3

    i moved to **Third Party Product** this issue doesnt get solved.
    lately they also started bugging me with licence problems for no reason.
    I am not using this commercialy.

    i had some problems with **Third Party Product**(not viewing the menu)
    but this link did solve the problem in 1 minute not years
    [link removed per Community Guidelines]
    So in the end all good, no licence problems anymore and it works :-)

    i hope this helps someone
    Bvdv

  • thr
    thr Posts: 1

    Remote system is a laptop with 1366X 768 max resolution, I am trying to conncet from a PC with 1920X1080, the remote system is showing like a small window. The lid is closed on the remote laptop.

  • Same issue.

  • That looks like a headless pc (a pc without a monitor). You may use a vga/hvi/hdmi dummy connector for headless devices, which will fake a monitor and thus makes that monitors resolutions available. Costs less than 5$,

    Or you may look on sourceforge for a programm named QRES. Get the setup version, unzip the patches inside the zip inside the zip (!), copy qres.exe and qres.dll into the same directory, and start something like "qres x=1280 y=1024".

  • Eric-G
    Eric-G Posts: 1

    Hello,

    I use TV 15.1.3937 and i've similar problem.

    In my case if i connect the client using ID and password, the client appears with the resolution of the already opened windows session (in this case 1600x1200 perfect for me) but if i connect the client from the group the computer and my account are members, i'm prompted to login the windows session (as locked) but in this case at login the resolution is 1024x768!

    For security reason i'm asked to use the 2sd solution but then how to change the resolution?

    Thks if you know a trick!

     

  • Sorry for the late response but I discovered that this was exactly the problem. To be precise, AMD chip graphic cards detect resolution from the connected monitor specs. If no monitor is attached it will config to lowest resolution. This also will effect your teamviewer session.

    Resolution: Buy a graphic adapter

    #SOLVED

  • mLipok
    mLipok Posts: 778 Star

    So I hope TV Dev's Team will find a better solution, as this situation is quite often.

    I mean I have many servers to maintain which have the same problem, but there is a monitor (usually turned off for ECO and Security reason).

     

    Regards,
    mLipok , AutoIt MVP
  • Very interesting, because this difference shows it's not a problem of Windows or the graphic card - it is a failure of TeamViewer!

  • kutsimari
    kutsimari Posts: 1

    ı use teamviewer but i cant change resolution when i connected remote computer. i think i must connect monitör for changing resolution.im lucky because my server is near of me. did you find solution for this issue. and windows 10 control panel screen scrolls not work. How can is see the scrolled windows content 

  • tom1stein
    tom1stein Posts: 4

    My solution still is a fake monitor adapter, also known as headless ghost. Maybe somebody finds a software solution - as there should be a software solution to a software problem!

  • Abdul2
    Abdul2 Posts: 3
    You can also fake a screen resolution in the software. At least with Nvidia graphics cards. In the Nvidia control pannel you can set a fake resolution and Teamviewer will allow you to choose that resolution. Should theoretically work also with AMD graphics card but I didn't verify.
  • Abdul2
    Abdul2 Posts: 3

     


    @Gearjunkie wrote:

    Sorry for the late response but I discovered that this was exactly the problem. To be precise, AMD chip graphic cards detect resolution from the connected monitor specs. If no monitor is attached it will config to lowest resolution. This also will effect your teamviewer session.

    Resolution: Buy a graphic adapter

    #SOLVED


    It should be also possible to fake a screen resolution. At least it was for me under Nvidia in the Nvidia control pannel. My host system has less resolution than my client and when I set a fake HD resolution in my host Teamviewer will allow me to set it. Works like a charme and just cost me some of my nerves :p

  • I think the problem is TeamViewer doesn't have a simulate monitor like Remote Desktop service. The solution might be simple, just buy a fake monitor adapter(it's like a HDMI or DP adapter, but it doesn't need a real monitor to be connected.) I have used this little devices in our many servers.

  • TV 15.9, today (21SEP20) decided to drop all possible screen resolutions but 640x480

    On a remote machine with a working 1920 x 1200 resolution.  Which is very hard to use through a centered 640x480 window without panning.

    This is more than frustrating.  And the fact that this is a problem that dates back three years and to TV 12 is not reassuring.

  • If TV does not care about me, I won't care about TV. I startet testing **Third Party Product**, and it worked. Besides, prices are lower.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!