teamviewer.com link icon
or
Ask The Community

TeamViewer Crashing on Mac

I have a fresh installation of the latest version of TeamViewer on my Mac, on High Sierra 10.13.3. The issue is that the app begins to open, the taskbar icon shows up at the top, and I open it up, see the open screen, and it completely closes itself a few seconds later.

There's no crash report or application error like some applications give when they crash. Why is it automatically closing? Is there something wrong with my installation or is there a version incompatibility with High Sierra?

Best Answer

Answers

  • lilyrose
    lilyrose Posts: 1

    I have the same problem with the last version of teamviewer (v13.1.2559).Teamviewer crashes and doesn't open anymore.

    Teamviewer works with v12 but the other computer works with v13, then I can't connect on it.

    The crash report :

    Process:               TeamViewer_Service [1607]
    Path: /Applications/TeamViewer.app/Contents/MacOS/TeamViewer_Service
    Identifier: TeamViewer_Service
    Version: 13.1.2559 (1)
    Code Type: X86-64 (Native)
    Parent Process: launchd [1]
    Responsible: TeamViewer_Service [1607]
    User ID: 0

    Date/Time: 2018-03-19 19:18:25.298 -0400
    OS Version: Mac OS X 10.13.3 (17D102)
    Report Version: 12
    Anonymous UUID: BEAE53FE-165C-235B-1FAB-6FF46043F113


    Time Awake Since Boot: 2900 seconds

    System Integrity Protection: enabled

    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Exception Type: EXC_BAD_INSTRUCTION (SIGILL)
    Exception Codes: 0x0000000000000001, 0x0000000000000000
    Exception Note: EXC_CORPSE_NOTIFY

    Termination Signal: Illegal instruction: 4
    Termination Reason: Namespace SIGNAL, Code 0x4
    Terminating Process: exc handler [0]

    Application Specific Information:
    /Applications/TeamViewer.app/Contents/MacOS/TeamViewer_Service

    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0 TeamViewer_Service 0x000000010ea633d2 0x10e4fe000 + 5657554
    1 TeamViewer_Service 0x000000010ea642bc 0x10e4fe000 + 5661372
    2 TeamViewer_Service 0x000000010e58fe41 0x10e4fe000 + 597569
    3 dyld 0x000000011b079a0a ImageLoaderMachO::doModInitFunctions(ImageLoader::LinkContext const&) + 420
    4 dyld 0x000000011b079c3a ImageLoaderMachO::doInitialization(ImageLoader::LinkContext const&) + 40
    5 dyld 0x000000011b075170 ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, char const*, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 330
    6 dyld 0x000000011b0742a6 ImageLoader::processInitializers(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 134
    7 dyld 0x000000011b07433a ImageLoader::runInitializers(ImageLoader::LinkContext const&, ImageLoader::InitializerTimingList&) + 74
    8 dyld 0x000000011b065567 dyld::initializeMainExecutable() + 196
    9 dyld 0x000000011b06a239 dyld::_main(macho_header const*, unsigned long, int, char const**, char const**, char const**, unsigned long*) + 7242
    10 dyld 0x000000011b0643d4 dyldbootstrap::start(macho_header const*, int, char const**, long, macho_header const*, unsigned long*) + 453
    11 dyld 0x000000011b0641d2 _dyld_start + 54

    Thread 0 crashed with X86 Thread State (64-bit):
    rax: 0x000000010eea61a8 rbx: 0x000000010ee932d8 rcx: 0x000000010ea5bc62 rdx: 0x0000000000000001
    rdi: 0x000000010ee932d8 rsi: 0x000000010edd9a1d rbp: 0x00007ffee16feea0 rsp: 0x00007ffee16feea0
    r8: 0x00007fff8ff0e0d0 r9: 0xffffffff00000000 r10: 0x00007fff8ff0e0c8 r11: 0x00007fff8ff0e0d0
    r12: 0x000000010ee932d8 r13: 0x000000010edd9a1d r14: 0x0000000000000001 r15: 0x000000010e58fdca
    rip: 0x000000010ea633d2 rfl: 0x0000000000010246 cr2: 0x000000010eea61a8

    Logical CPU: 3
    Error Code: 0x00000000
    Trap Number: 6


    <F7E5F1BC-614B-39CB-B6CE-92A9C7B7EC0B> /usr/lib/system/libxpc.dylib

    External Modification Summary:
    Calls made by other processes targeting this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
    Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
    Calls made by all processes on this machine:
    task_for_pid: 4344
    thread_create: 0
    thread_set_state: 0

    VM Region Summary:
    ReadOnly portion of Libraries: Total=300.8M resident=0K(0%) swapped_out_or_unallocated=300.8M(100%)
    Writable regions: Total=26.3M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=26.3M(100%)

    VIRTUAL REGION
    REGION TYPE SIZE COUNT (non-coalesced)
    =========== ======= =======
    Kernel Alloc Once 8K 2
    MALLOC 18.0M 8
    MALLOC guard page 16K 4
    STACK GUARD 56.0M 2
    Stack 8192K 2
    __DATA 14.5M 182
    __FONT_DATA 4K 2
    __LINKEDIT 189.1M 7
    __TEXT 111.7M 186
    __UNICODE 560K 2
    shared memory 8K 3
    =========== ======= =======
    TOTAL 397.9M 389



  • David7
    David7 Posts: 1

    To any team viewer tech reading this, I have a crash report but it's too large to fit here, please contact me and I will send it to you by whatever method you like. With my setup on 10.13.3 it doesn't even open, it just generates the crash report.

    thanks,

    david

  • I've updated to the latest version and that's when the issue started. It was fine until this update.

    The app never even fully loads.

    I've Uninstaller and reinstalled it 4 times now. Rebooting between uninstall and reinstall.

    Any magic tricks up your sleeve?
  • bonion
    bonion Posts: 1

    Hi Julia, I'm still having this problem with Teamviewer 13.1.2559 but it's slightly different. The app will appear in my MacOS dock and then just disappear. I've tried uninstalling and reinstalling multiple times to no avail.

  • hi! i just fond out that the same thing happens to one of my clients.

    i have a TV 12 license and i tried to delete and re -install it but the app on mac os x 10.13 does not start at all.

    Anothter strange things is that i can see the mac online but i can not connect when i try from my computer

    i also tried to update the version but i still have the problem!

    any help?

  • I'm experiencing the exact same issue as described above. Appears very briefly and then disappears from the dock. Tried uninstalling and reinstalling so I know I have the latest version.

  • I fixed using ccleaner
  • Zixxith
    Zixxith Posts: 1

    I am having the exact same issue with TeamViewer13. It worked fine until the last update. I have uninstalled and reinstalled I don't know how many times. Emptying trash and restart inbetween installs same issue. I have also tried CCleaner no change. I open TeamViewer the icon jumps for a few seconds then goes away and TeamViewer never opens.

  • I erased the app
    Than with CC I deleted the all the auto start demons and clean including the miscellaneous files
    Than restart and install the new version
  • Not fixxed.  I removed earlier versons ans reinstalled with latest version.  Won't start.  error and forces me out.

  • I was forced to update Teamviewer on my mom's a Mac (running El Capitan) to match the version on my home computer. I downloaded version 14.1.3399, but it crashes immediately upon opening. I tried deleting the old version and all references using AppCleaner and then reinstalling, but had the same results.
  • Esther
    Esther Posts: 3,110 Community Manager

    Hi all,

    this post (especially the link in it) might be helpful if you are still facing issues: Solution Re: TeamViewer 14 mac on El Capitan???

    Thanks and best, Esther

    Community Manager
  • itjco
    itjco Posts: 1

    The application “TeamViewer” is not open anymore.

    macOS Big Sur Version 11.1

    Keep crashing and can't use

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!