link icon
Ask The Community

Error Message: Waitforconnectfailed

Im getting this error that says No connection to partner, Partner didnt connect to router

Error code waitforconnectfailed

anyone know whats going on here?



  • Seems login servers for the service are down.  and all remote machines logged out.

  • crl
    crl Posts: 2

    thanx for the info

  • teamviewer says me that the remote computer is online: this means that the remote computer is not logged out, no?  

  • MiGo
    MiGo Posts: 2

    I've just experienced the same issue with many of my teamviewer host installations, since maybe 2 weeks. Before everythink works fine. PC is shown as online, but after start connecting I get the Error Message WaitforConnectFailed.

  • What have we todo??

  • I have the same problem. both computers online, TW ready to connect but i get the message above. 

    is there anyone in Teamviewer team that can confirm there is an Teamviewer issue with servers or something? 

  • Joe_Wong
    Joe_Wong Posts: 1

    I had the same problem with Quick Support.

    But the problem seems to be solved right now. It works again.

  • 1tpg1
    1tpg1 Posts: 1

    I can't login either. What is the fix?

  • faridtnx
    faridtnx Posts: 1
    Most probabely ur tw server pc is blocking a particular port number and does not allow ur client pc to initiate connection.
    This usually can happen because of a host-based or network-based firewall with a port-restriction rule applied
  • Zac
    Zac Posts: 1

    I ma having the same issue. the machine is a virtual machine, It says it is on in my list of computers and when i check the console it is on but i still get the erro message. It is on teh domain and no firewall and on the machine. when i log on to the machine through VMware console i can then teamviewer on. i leave it over nigiht and when i try to TW on i get the error message. The machine doesnt sleep or hibinate,

  • i'm having the same problem.  Teamviewer has been running on this Win10 system for a couple years without problems, and about a month ago it started having this connect problem.  I updated the installation and it works right after that, but then goes back to the waitforconnect failed.  if I reboot the machine or restart teamviewer, then it starts working again.  I have a couple machines where this happens (both Win10).

    So something has happened to make these connects fail.  Maybe it was the Win 10 update?  or something on TeamViewer's side.



  • I'm having this issue suddenly, and it happens on restart as well. This is my 70 year old dad's machine and he is 3 hours away, so now he's stuck with a problem and I can't fix it due to not being able to connect.

  • Looks like their server is down.  Been having the problem for 3 hours now.

  • hy
    hy Posts: 1

    Having this same problem at the moment, won't sign into the server.

  • MiGo
    MiGo Posts: 2

    I've just pointed out, that if I disable IPv6 on the Host-PC, Teamviewer works very well...

  • Frustrating, All 50+ Computers online and when I go to connect I get this error.  This is a new error.  I have never had this before until this past week.


  • JMench
    JMench Posts: 2 ✭✭

    I have the same thing going on with my work network. All pc's running Windows 10 seem to be affected. I contacted support and they gave me a lot of IP's and ports to whitelist/open but I really don't think that's the problem since other PC's on the netowrk are just fine. Frustrating. They didn't have any other information for me.

  • My only work around is to connect to my router (flashed w/ddwrt and internet facing via ssh) remotely and reboot it. Then I can make a connection inbound again to the devices (specifically in this case a win10 desktop) in that network. Don't seem to remember this error before teamviewer v12.

  • Iaacob
    Iaacob Posts: 1

    For me it was Kaspersky who was blocking the connection, so it was a firewall issue.  I turned karspesky off for testing and it worked. 

  • CHRIS108
    CHRIS108 Posts: 4

    Same error message,

    Me on a mac   My father on a mac too but 400 kms away and 6 hours driving + he is 85 years old and definitely not tech savy (hence the use of teamviewer)

    His connection is fine since he can surf the web ...  My connection too ...
    But still the message on my side will be:  Your Partner is not connected to router   Code Error: WaitforConnectFailed

    It would help if someone could confirm it is coming from Teamviewer servers and we just have to wait, instead of having to have him uninstall and then download and install the program again (quite sure he wont manage the complexity of it since this why we are using TW in  the first place...)

  • Gwent
    Gwent Posts: 1

    I got similar problem like you: Waitforconnectfailed

    If you have there someone, tell him just to exit and start teamviewer again. It should help.

    In my case my second pc doesnt have monitor and there is noone who can look at it at the moment. And pc is also 500-600 km away.

    So I have to wait until weekend.

    I would appreciate remote reboot function :)


  • CHRIS108
    CHRIS108 Posts: 4

    Thank you Gwent,
    I will post the results tommorow when calling again my father and having him to restart TW ...
    But it can be seen that this question was first asked in April 2017 and with so far no official answer from the TW team to at least let us know if the problem is on their side or local ... And in the later case what to do to bring back normal functionning ...

  • CHRIS108
    CHRIS108 Posts: 4
  • CHRIS108
    CHRIS108 Posts: 4

    So everything went fine and back in order by restarting TV ....

    So simple a solution that it is maybe the reason the TV team doesn't bother to reply on this thread ?
    Let it be thenopportunity for us to THANK them for their wonderful product and the free use they are granting to individuals ...

  • There is still no solution. To restart computer, y have to do 150 miles... Very stupid system.

  • mlnrlck
    mlnrlck Posts: 1

    try adding the device to ITbrain and there look for the teamviewer windows service and restart it.



  • yes. it's a real problem. I have to make 150 miles to restart the computer! I do not understand why Teamviewer does not fix this problem!!!



  • hiroo
    hiroo Posts: 3

    I tried using Task Scheduler to kill the process every day and then start again. However, after a few days, ended up with no response again.  

    I'm super inexperienced at Task Scheduler though.  I could not find any way to load any existing task to view/edit, although I found the saved task in the /SYSTEM/WIN32 directory.

    Can somebody with more knowledge at Task Scheduler try making something like this to keep TeamViewer alive on a remote machine.

  • Sakar
    Sakar Posts: 2

    I have a SUPER SOLUTION for you guys. 

    I come across that error all the time. I often get locked out by TeamViewer.

    I always keep **Third Party Product** installed on the machine.

    Whenever I have this problem, I log into the machine using **Third Party Product** and restart the machine or the TeamViewer app.

Sign In or Register to comment.