teamviewer.com link icon
or
Ask The Community

A Comunidade TeamViewer chega ao Brasil 🎉


Check out our brand-new Portuguese Community 👉 here 👈.

Not ready. Please check your connection after upgrade to v12

Hi

I get "Not ready. Please check your connection" after upgrade to v12

was working fine before upgrade.

Internet connection ok as it let me download the upgrade.

It keeps banging on about "proxy servers" which i have set to none as i dont have or use one

«13

Comments

  • Exactly the same problem here. Running windows 10 if that matters.

  • Uninstalling/Reinstalling v12 didn't help. Couldn't find v11 anywhere. Ended up downgrading to v8, which runs fine.

    http://www.oldversion.com/windows/teamviewer/

    Still have no idea what acutally went wrong.

  • TosterCx

    I was lucky still had a copy of V11 so re installed it and guess what

     !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    All working fine again now.

    mick

  • I uninstalled version 12 and installed version 11. I still get the same Not ready message. Teamviewer was working fine before I upgraded to 12. I don't think I can install anything below 11 since the computer I need to control is probably running 11, and my 98-year-old mother won't be able to update by herself. I'm on the latest version of OSX.

  • I reinstalled version 12. I'm running Avast antivirus. I turned off web shield, and Teamviewer could suddenly connect.

  • Ronin
    Ronin Posts: 3

    Was working fine on 12.x for sometime, after a recent reinstall, it appeared to be running, but instead of an ID it displayed a local IP address (also happened on a client's machine).

    Now it displays LAN only, if I disable LAN connections, it has no connection at all. Also cannot sign in to account (computers & contacts option).

    As it happens, I cannot even access it on the local network - "Teamviewer not running on partner computer".

    Teamviewer 12.0.71510 wine-1.6
    Running Ubuntu 16.10, hardwired internet.

  • It seems to be random. I turned the web shield back on and nothing happened. Then it didn't connect again with web shield off. I switched to the new interface. First, it didn't connect and then it did.

  • Ronin
    Ronin Posts: 3

    Cheers, @bhoth that does get it running again...we'll have to see if it survives a reboot!

  • Wenbin
    Wenbin Posts: 2

    The same issue. Any idea why? Any fix for windows?

  • Ronin
    Ronin Posts: 3

    @bhoth - your solution is good as a temporary fix, however it does not survive a reboot. At least it's a somewhat manual solution for now.

    Very frustrating as Teamviewer has been working very well up to now - even though it's still dependent on WINE under Linux.

  • Wenbin
    Wenbin Posts: 2

    Log:

    2017/01/04 22:57:58.120 2688 2572 S0!! LocalIPVector: getaddrinfo failed with socket error 11001, Errorcode=11001 Start: 2017/01/04 22:57:58.119 

    Version: 12.0.72365 ID: xxxx Loglevel: Info (100)

    License: 10000 Server: master6.teamviewer.com

    CPU: Intel64 Family 6 Model 42 Stepping 7, GenuineIntel CPU extensions: g9 OS: Win_10.0.10586_W (64-bit)

    IP:

    MIDv: 1

    Proxy-Settings: Type=1 IP= User= IE: 11.713.10586.0

    AppPath: C:\Program Files (x86)\TeamViewer\TeamViewer_Service.exe UserAccount: SYSTEM

    2017/01/04 22:57:58.146 2688 1032 S0! CKeepAliveClientClient::HandlePing(): ping failed 2017/01/04 22:57:58.147 2688 1032 S0 Non-Commercial use 2017/01/04 22:57:58.147 2688 1032 S0 Resource-Language: en 2017/01/04 22:57:58.147 2688 1032 S0 Activating Router carrier 2017/01/04 22:57:58.148 2688 1032 S0 CProcessCommandHandlerMasterConnect[48]::CreateMasterConnect(): master6.teamviewer.com:80, Connection 48, proxy=''

    2017/01/04 22:57:58.164 2688 1032 S0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: master6.teamviewer.com 2017/01/04 22:57:58.164 2688 2572 S0! CProcessCommandHandlerMasterConnect[48]::HandleMasterConnect(): MasterConnect to 0.0.0.0 failed

    2017/01/04 22:57:58.164 2688 2572 S0!! LookUpDNS failed for master6.teamviewer.com, socket error = 11001, Errorcode=11001 2017/01/04 22:57:58.164 2688 2572 S0!!!Connect to Master master6.teamviewer.com / failed!, Errorcode=11001 2017/01/04 22:57:58.165 2688 2572 S0!! CMasterConnectorAsio::HandleMasterResponseLogin(): MasterConnect failed. ErrorCode=10, Errorcode=11001

    2017/01/04 22:58:01.166 2688 2660 S0 Activating Router carrier 2017/01/04 22:58:01.166 2688 2660 S0!!!CTcpConnectionBase[49]::HandleResolve(): Resolve failed, ping3.teamviewer.com, Error: system:11001

    2017/01/04 22:58:01.166 2688 2572 S0 Activating Router carrier 2017/01/04 22:58:01.180 2688 2572 S0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: ping3.teamviewer.com

    2017/01/04 22:58:01.180 2688 2572 S0!! Port443Connection::ConnectInternal: failed with HTTP status code = 0

    2017/01/04 22:58:01.180 2688 1032 S0!! NetWatchdog: Port 443 proxy search failed! No working setting found. -- 2 previous log entries omitted --

  • Yep, same errors. I think they're forcing curl to use IPv6 interfaces somehow (which my ISP doesn't support).

    curl master12.teamviewer.com -6
    curl: (6) Could not resolve host: master12.teamviewer.com; No data record of requested type

    curl master12.teamviewer.com -4
    <html><body>This site is running <a href='http://www.TeamViewer.com'>TeamViewer</a>.</body></html>

  • bhoth
    bhoth Posts: 8

    @TosterCx wrote:

    Yep, same errors. I think they're forcing curl to use IPv6 interfaces somehow (which my ISP doesn't support).

    curl master12.teamviewer.com -6
    curl: (6) Could not resolve host: master12.teamviewer.com; No data record of requested type

    curl master12.teamviewer.com -4
    <html><body>This site is running <a href='http://www.TeamViewer.com'>TeamViewer</a>.</body></html>


    Ok so it looks like Teamviewer 12 is trying to be IPV6 ready. Is there a way to tell Teamviewer 12 to not use IPV 6 or ignore it?

  • My ISP does have iPv6, but I usually have to fiddle with my router to get it to work and then it stops working again. Maybe that's why I was able to use Teamviewer intermittently.

  • I am IPv6 ready, which took me a while to verify, and I had this problem, too, though it's possible that IPv6 wasn't working when Teamviewer was unavble to connect. Now, it is.

  • bhoth
    bhoth Posts: 8

    I have now enabled ipv6 thru my router and my linux box and it still does not work. So it's more than just not having ipv6.

  • I'm also facing same problem on Fedora 25. All started after I upgraded from Fedora 23 to 24 and the problem still persists. On Fedora 23 I was using TeamViewer V10 then V11 and now V12 still the problem is not resolved. Please TeamViewer team fix the bug.

  • I have a sorta a bad **bleep** patch/hack that seems to be stable.. 

    From reading the other posts it looks like something was/is wrong with DNS lookups.  

    So my "fix" that is **bleep** is not to do dns lookups. 

    sudo vi /etc/hosts (or windows host file C:\Windows\System32\drivers\etc\hosts )

    and add

    # Teamviewer
    178.77.120.6 master1.teamviewer.com
    178.77.120.104 master2.teamviewer.com
    178.77.120.100 master3.teamviewer.com
    178.77.120.102 master4.teamviewer.com
    178.77.120.6 master5.teamviewer.com
    178.77.120.100 master6.teamviewer.com
    178.77.120.102 master7.teamviewer.com
    178.77.120.104 master8.teamviewer.com
    178.77.120.106 master9.teamviewer.com
    178.77.120.104 master10.teamviewer.com
    178.77.120.100 master11.teamviewer.com
    178.77.120.6 master12.teamviewer.com
    178.77.120.102 master13.teamviewer.com
    178.77.120.106 master14.teamviewer.com
    178.77.120.106 master15.teamviewer.com
    178.77.120.106 master16.teamviewer.com

    to it.  You may verify all the IPs manually by doing ping master1.teamviewer.com and  verify the IPs. I stopped at 16 it looked out of country (of usa) IPs. So there may be more than 16.

    After adding them I was unable to reproduce the problem.  **bleep** because if they change dns entries this will all break.  So now you have to maintain a sudo dns table.  

    **bleep** because it could be a security issue as you are not using DNS to verify that is actually teamviewer you are talking to.  

    But end of the day it seems to fix the issue. + it looks like there is many re-used duplicate IPs.

    Robert

     

     

     

  • (U)Gl,y is a bad word? Bleep me..

  • rekaut
    rekaut Posts: 1

    for me I was trying to cnnect to my server remotly, however! anytime before you run teamviewer and connect to the server it will shows not ready. 

    I solved to restart my server and from the other end not starting any ssh, it worked. 

  • I had the same issue. Check to see if your internet is working or not. If it is working then check your firewall setting to make sure that TeamViewer is allowed to go out and recieve incoming request.  That should take care of the Version 12 problem.

    Good Luck

    Muhammed

  • alex
    alex Posts: 1

    I tried restarting the service on Windows 10 and it hung on stopping. I killed the process in task manager. Fired it back up and it connected right up. This is the first time I have noticed issues. 

  • I was having problems aswell, since I saw some people here talking about ipv6 I went ahead and disabled ipv6 from my adapter, and voila it worked, hope this helps someone.

    https://gyazo.com/75f4a0cf4da817197189d0d8c9ad7625

  •  

    bhoth wrote:
    I can get it to work by running in a terminal:
    sudo systemctl stop teamviewerd.service
    sudo systemctl start teamviewerd.service

    I can confirm this fixes it until system reboot.

    Firesky wrote:
    I was having problems aswell, since I saw some people here talking about ipv6 I went ahead and disabled ipv6 from my adapter, and voila it worked, hope this helps someone.
    https://gyazo.com/75f4a0cf4da817197189d0d8c9ad7625

    Sadly disabling ipv6 on Ubuntu did not help at all.

  • I can now say consistently that when IPv6 is active in my router, TeamViewer runs normally. However, my Netgear router seems to occasionally drop IPv6. When that happens, TeamViewer cannot connect. I go into my router settings and reapply them for IPv6 and TeamViewer connects again. However, from other posts I have read, there may be other issues that others are encountering.

  • hans
    hans Posts: 1

    Hi! Same problem here, on Manjaro. Solution for me was to add 'mdns4' to 'hosts:' list in /etc/nsswitch.conf

  • Thank you! It's work for me

  • I am running linux and I unistalled teamviewer, removed the local log (probably not necessary) but I found a config file in /etc/teamviewer.  I deleted that directory (or folder whatever you want to call it).  Reinstalled teamview 12.  Accepted teh licence agreement and all is well.

    Hope that helps.

  • That works, thanks, what a PITA if I have to do that all the time