link icon
Ask The Community

Black screen after updating to Winver 1803



    SSMCPA Posts: 7
    I'm having this issue as well but I did find the Teamviewer Remote Control in the Windows Store will let you see the remote computer's screen. It is not a full featured app though.
  • I have the same problem, with TeamViewer 12 corporate license.  TeamViewer said it is a known issue and they are not going to fix it.

    The problem would only be fixed if you are using TeamViewer version 13.

    I hate subscription and therefore I will not go to version 13.  Any idea how to fix/workaround?


    Alexander Lai
    SSMCPA Posts: 7

    I am using TeamViewer version 13 so it isn't just a Teamviewer 12 issue.  This happened on an older laptop I was using a while ago and the fix was to uninstall the nvidea drivers.  When it re-occured after the next major Windows update I had to re-install & then uninstall the nvidea drivers again. This got it working again.  The issue is now happening on my newer laptop now but it doesn't have nvidea drivers.  I find I can use the Windows Teamviewer Remote Control app available on the Windows Store to remote control successfully.  It is not a full featured app so if I need to do file transfer or anything else then I need to open a second connection using Teamviewer 13 and even though I can't see the screen I can still use the file transfer and other features.

  • Do you know how much I love you??  Your reply reminded me that I tried out the Microsoft Store version of the app and it WORKED!!  I could have the tool working as expected, and I could have access to all of my hosts and friends' computer now!

    It worked, although not the original full version but at least it worked!  I do really very appreciate your help, and I do hope I could buy you a coffee to express my appreciation to you!

    Thank you thank you thank you!

    Alexander Lai

    Alexander Lai
    SSMCPA Posts: 7
    Thank you. I also had Duet installed. Uninstalling has corrected my issue.
  • I also have Duet Display installed on all my computers ... I am now removing them and I could connect to them after removing Duet Display!

    I do appreciate your advice which helped many of us here.

    Alexander Lai
  • vfallico
    vfallico Posts: 2
    Same situation here. By removing the Duet Display the issue is fixed now. Many Thanks!
  • julianpetriv
    julianpetriv Posts: 1
    Thank you very very very very very very much??????????
    But it would be very interesting to know how did you came to this solution? How did you find out that it is Duet Display causing those problems?

    And again, THANK YOU!
  • zsuraski
    zsuraski Posts: 13

    You're very welcome.

    Take a look at the last message at - I actually detailed how I found it...

  • DavidIQ
    DavidIQ Posts: 4

    Interestingly enough this seems to have been the source of my problems with Visual Studio and BlueStacks as well. Removed Duet now since I'm not even using it. Thanks!

  • zsuraski
    zsuraski Posts: 13

    Same here - it solved issues I was having with Steam (local streaming), Yi Home security camera, Microsoft Mouse and Keyboard Center (go figure!) and a couple of other apps.  It was (is) a pretty nasty bug.  It's reported to both Intel and Duet, so hopefully between the two of them it will be solved for people who actually need Duet.

  • dube920
    dube920 Posts: 11

    Can confirm, worked for me too! Thank you!

  • salsabor
    salsabor Posts: 1

    Thanks for your post, I had the same problem like you and after to receive the last version of W10 1803 compilation 17134.137, the Teamviewer 13.1.3629 doesn't works showing a black screen when connecting.
    I tested severals ways to repair it like to uninstall the VGA drivers and it works OK too, but when the VGA receive the driver automatiacally, it not work again. Other temporally solution was install the version 12.0.77831.0, but I never imagine that the reason in my case was the DUET DISPLAY from Ipad.
    By your post, I could solved  and I would like to give you thanks since I was so mad with this topic.

    Best regards,

    Salsabor from Spain

  • It will be much informative if the release note or change log could be released as well, so that we could consider if we should take the risk of installing the early release version of the update.

  • zsuraski
    zsuraski Posts: 13

    You're very welcome!  This was one tricky bug to figure out.  Glad it seemed to solve it for everyone who experienced it!

    Zeev (from Israel :)

  • zsuraski
    zsuraski Posts: 13

    Julia - not sure if you noticed but it seems that the root cause for pretty much everyone involved was Duet Display (in conjunction with Intel display drivers).  So far there were around 7 people who confirmed that this was the same root cause for them...

    Perhaps this should go into the Team Viewer knowledge base.

    I also reported this to both Intel and Duet, so I believe that sooner or later they will solve it with a new update.

  • DavidIQ
    DavidIQ Posts: 4

    I doubt disabling HWA within TeamViewer will fix the clash with Duet. I had disabled HWA globally on my machine and that did not take care of the black screen, although it did correct the issues I was having with the other applications. Removing Duet was the ultimate solution to fixing TeamViewer. Re-enabling HWA after removing Duet still allowed the other applications to work properly so the real source of the problem is Duet.

  • Julia
    Julia Posts: 290 Staff member 🤠

    Hi zsuraski,

    I really appreciate your input here and your workaround.

    Our development had a look at this issue together with a lot of customers who had the same problem. 

    We also made some tests with these customers and the new option within TeamViewer was especially developed for this behavior. Our customers already confirmed during the tests, that this option will solve the problem.

    Thanks for your suggestions to create a Knowledgebase article about it and indeed - I can confirm that we will publish a Knowledgebase article about the new option within TeamViewer in the near future.


    Senior Support Engineer - 2nd level Support
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • waynedc
    waynedc Posts: 1

    This InsiderBuild with Hardware Acceleration turned off and Duet installed fixed the issues for me. 

    Prior to the InsiderBuild, I had to uninstall Duet to avoid the blank black screens in Teamviewer. 

    Thank you,


  • sunnytsoi
    sunnytsoi Posts: 1

    It works for me! thanks so much. I have been studying this issue for over 10 hours.

  • Peril
    Peril Posts: 4

    I tried everything else, including the development builds - deleting Duet is what did it for me.

  • zsuraski
    zsuraski Posts: 13


    My point was slightly different - while it's useful to have the option to turn off acceleration for TeamViewer, this doesn't seem to be the real root cause of the problem, but rather a workaround (that also doesn't appear to work for many).  The real root cause - at least for *everyone* on this thread, was Duet.  Uninstalling Duet is the real solution, and that's what I suggested to document in a knowledgebase article.  Disabling acceleration in TeamViewer is useful in these cases where Duet cannot be uninstalled (or isn't installed to begin with - some other variation of this issue).

    My 2c.

  • zsuraski
    zsuraski Posts: 13

    By the way - disabling acceleration was also the recommendation from Steam - to solve somewhat similar issues.  For me at least, this didn't work - and there are apparently others here for whom disabling acceleration doesn't actually solve the problem.  For me - TeamViewer, Steam, Yi Home, Microsoft Expression Studio - all had similar issues that only went away when Duet was uninstalled.

  • getting rid of Duet did the trick for me. Thanks for the tip!
  • You are a lifesaver! Inwas struggling with this issue a couple of months back, and going through 1803 and the previous one back and forth. Yep Duet Display was messing around. The only thing i don’t understand, is how you related the issue to this specific app? It didn’t cross my mind to start uninstalling apps one-by-one ;) Anyway, thanks for sharing the solution. It sure worked for me
  • It was a while ago, but I think what made me attempt to try to start uninstalling apps, was the fact that I submitted a ticket to Intel - which failed to reproduce this issue on a very similar system.  So it seemed at least plausible that it wasn't something in the driver.  They suggested that I reinstall my system from scratch, which obviously I was reluctant to do - but to give credit where credit's due - it pushed me to see if this might be some other software that was somehow conflicting with the Intel driver and was unique to my system.  When I went in this direction, the Eureka moment of this being Duet wasn't that far off.  If anything could have an impact on video behavior, Duet would be it...

    Still, it took me a very very very long time to go in this direction.  I was already looking for external video cards.  Very thankful I had this Eureka moment :)

  • I didn't have display duet installed but found that I still had the black screen issue upon connection. 

    I've found that toggling the display optimisation for speed gets rid of the black screen on both pc and mobile. 


    Hope this helps

  • FCC
    FCC Posts: 1

    Amazing work, thanks a lot.  That Duet software was the cause of my blackscreen on Teamviewer.  Those guys at Duet never really got their software 100%.

Sign In or Register to comment.