link icon
Ask The Community

TeamViewer is one of the winners of the European Customer Centricity Award 🥳

Please find more information here.

Constant Screen Freezes, Input is still accepted


since upgrading both my Work Laptop & my Home Desktop to win10 & Teamviewer 13
i get constant freezes for about 3 seconds, it unfreezes after these 3 seconds and works for about 5 seconds before freezing again this just happens in a loop and the direction doesn't matter.
When using the TeamViewer app on my Android Phone i can connect to both Systems without any freezes.

Here comes the interesting thing:
While the Screen is frozen i can click stuff (mouse doesnt move) and when the freeze is resolved TeamViewer will work off the que of inputs i made.

I tried disabling UDP in the advanced settings which seems to be a problem solver for alot of similar problems but unfortunately not for me.

Any advice how to debug/solve this?


  • Reckit
    Reckit Posts: 3

    I have the same problem, but im running Windows 7 on PC and also laptop.

    Both devices have the same problem, using the same internet connection.

    There is no problem when using another connection, so that eliminates the remote desktop and my devices.

    Something to do with the connection i think, though the connection runs perfectly for other things.

    I've tried the UDP disable and the port forwarding. Are there any other fixes? Any help appreciated

  • Hes
    Hes Posts: 1

    I have the same problem - only the timing is slightly different. My TW client freezes for 10-15 seconds befor working again for three to acht seconds. All clicks and key presses I make during the freeze are executed immediately after the unfreeze. Both client and server are running TW12. The client is a 5-channel corporate license (here at work), the client is a free non-commercial license (my private home PC).

    Is there any way to find out what causes these intermittent freezes? It started out of the blue after working fine for months, and it has gotten to a point where all but the most basic interaction with the target system is practically impossible.

  • No solution from the Teamviewer team? seems to be a general issue...
  • I found a solution for my problem, which turned out to be my ISP. After chatting to TeamViewer tech support they led me to a simple test to determine if my ISP was the problem.

    1. Type cmd in search bar to bring up command

    2. Type the following: ping -t (and then press enter)

    3. Wait a minute or so and see if you get any ‘request timed out’ responses. If you do then you know it’s a problem with the ISP.
  • Thanks for the answer. I have no timeout from google (I let it run 2 mins, 1ms response time)

    is your issue resolved? what was the problem for you?


  • My problem was my isp. The test I suggested was getting ‘request timed out’ every minute, which mimicked the problem I was having during teamviewer usage. I contacted my ISP and after a few troubleshoots, they determined my cable router was faulty and they would send me a new one. The new router has been going for almost 2 days and I’ve had no problems. Try contacting TeamViewer tech support on the phone. They were really helpful once I got through it to them.
  • I have the same problem. But only when connecting from iOS devices. 

    Please, help. Thanks. 

  • Same problem here. I have a Windows 10 PC that I can remote into another Windows 10 machine just fine. But when I try to remote into a Linux machine (on the same network) it works for a few seconds then the screen freezes in the remote control window. I can watch the mouse move on the client computer and clicking/typing still works as well. Just the screen frozen on the host terminal.


    Really wish TeamViewer would pay attention to these bugs.

  • vferg
    vferg Posts: 2

    Seems I am having a similar issue.  I have seen this issue come and go throughout the last few years but I am finally starting to get annoyed since this entire week has kinda been stuck doing this.  Tried rebooting PC, tried rebooting routers which has fixed it in the past but nothing.  I started looking at resolution since the display is hooked up to my tv which is 4k thats what the resolution was set at so I decided to try and lower it to 1080 just for testing.  Now instead of the screen just freezing its stuck in constantly changing between the 2 resolutions over and over, but I have a feeling this is actually the problem of the freezing to begin with.  I noticed when looking at the displays in settings where you can move a monitor around that the display dissappears then comes back over and over like it is losing connection, I believe this is the root of the issue for my freezing.  I dont know if it matters but the tv is turned off, and not sure if that would be the cause of it not being able to identify what the screen is? Currently using Windows 10 pro 1803, intel i5, and an AMD RX 480. I believe latest drivers. TV is a Samsung.  Would really love to get this issue resolved since its my only way of getting personal stuff done throughout the day.  I cant be the only one with a similar issue?

  • Same problem here with Teamviewer 14 from Windows 10 to various hosts (Windows 10, Windows 7, Linux). The freeze is always around 10 seconds, then it works again for around 5 seconds, then freezes again ad infinitum. I then reconnect to the host multiple times and usually with the second or third reconnection it works normally.

    This is especially annoying when I connect to customers that need assistence. Because the customer starts explaining his problem and I always have to stop them and tell them I had to reconnect because Teamviewer is hanging.

  • tkuhmone
    tkuhmone Posts: 13

    Same problems here also. I use 14.2.119 (windows, preview build). The screen freeze usually last in my case, from 10...100sec. I try to make ping test next time I see this...

  • iBltz
    iBltz Posts: 4

    oh i wanted to add something to my previous post : the sound is still working fine when the screen is freezing. It means, that the connection is still etablished...

    will Teamviewer one day communicate on this issue or will it keep being ignored?

  • I also have Constant Screen Freezes too on windows 7 remote to ubuntu linux 18.04.2  with teamviewer 14.2.2558. When i connected and move any program windows will have many shadow follow it. I even have try remote from android device, still have same problem. So I pretty sure the problem is on teamviewer ubuntu side. I have no problem before i upgrade ubuntu linux from version 16.04 with old version teamviewer that still using Wine.  please teamviewer team really focus to solve this problem. Otherwise, I may follow the old school VNC way for this case.

  • iBltz
    iBltz Posts: 4

    Update since the last time i posted :

    The freezes are still here. Of course I update every releases from Teamviewer with the hope that the problem will disappear, but it is still here...

    However, I notice that the problem is not everytime there. From 10 connections, I can get 1which is working perfectly without freeze! I just connect and disconnect, repeat the process until I have a stable connection. If i have a stable connection, this one last hours without problem. if I disconnect, then I have to repeat the process again...

    Well better than nothing I guess! Hope it helps some of you.

  • Sorin1972
    Sorin1972 Posts: 1 Newbie

    Hello, guyz

    I have found out that this freezing issue is a router/firewall problem, not teamviewer's, as we speak.

    As always, there is an easy fix, uncheck the "use UDP" checkbox from the setting from your local tw client

    I hope this will help somebody as I have struggled few days to find out that.