link icon
Ask The Community

Cannot forward key combinations with symbol keys

I'm connect from a macbook pro to a linux machine (ubuntu). When trying to use vscode on the remote machine, it seems that I cannot forward any key combinations that include a modifier + a symbol key

For example, if I try to set something like
the modifier press is registered but the symbol key doesn't. Pressing a letter key instead of a symbol key works fine, enabling forward key combination does not affect this (only thing it does is send alt from the command key instead of sending it from the option key, either way, either the option or the command keys are disabled).

Any ideas?


  • TV-Rene
    TV-Rene Posts: 30

    Hello Laughingrice,

    I have attempted to reproduce with a MacBook connecting to a Ubuntu using the Terminal in the Ubuntu session, but to no avail.

    Can you please give us more details in relation to versions used?

    Best regards,

    Rene - 2nd Level Support
  • NightFox
    NightFox Posts: 4

    There is one option I can think of. Have you tried using a onboard screen keyboard for that computer your connected to?

    This may allow you to create the key combination that your looking for by using a mouse to click on the combo you are after. As to the reason. The command options dose not work with ubuntu. Come mac using use the command options to do the ctl + \ thinking that they hitting the correct combo. I would dubble check that your hitting the right keys. But the above options of using a screen keyboard on the system your working on may be a option

  • Teamviewer on the mac is 13.1.4170
    Teamviewer on ubuntu is 13.1.8286

    Both say that there are no updates avaialble.

    Running xev in the terminal in the ubuntu client, example of the problem, pressing control reports press and release (showing only press event for brevity)

    KeyPress event, serial 37, synthetic NO, window 0x7c00001,
    root 0x1ca, subw 0x0, time 1014892820, (338,638), root:(1520,1275),
    state 0x0, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

    Pressing the slash key also reports the key press

    KeyPress event, serial 37, synthetic NO, window 0x7c00001,
    root 0x1ca, subw 0x0, time 1014895528, (338,638), root:(1520,1275),
    state 0x0, keycode 61 (keysym 0x2f, slash), same_screen YES,
    XLookupString gives 1 bytes: (2f) "/"
    XmbLookupString gives 1 bytes: (2f) "/"
    XFilterEvent returns: False

    trying to press ctrl+/ reports nothing. Trying to press ctrl with any letter key works fine, pressing it with any symbol key, same thing, reports nothing (no key press is forwarded). same behavior with other modifier keys. I verified that the key combination is not assigned to anything on the mac. Same behavior on two different macs. I tried enabling and disabling "send key combination", other than the behavior of the command key (sends an alt instead of the option key) nothing changes.

  • The problem is not in creating the key combination (that key combination is the default), it's in sending the key combination. I tested with xev and the key combination is not forwarded to ubuntu at all
  • I'm using Teamviewer 13.1.4170 on the Mac and 13.1.8286 on ubuntu (both report that theres are no updates). Both Macs are high Sierra, one ubuntu is 16.04 and one is 18.04

    Running xev under the ubuntu client, pressing "ctrl" reports the key press, pressing "/" reports the key press. Pressing "ctrl+/" doesn't report anything, so it's not being forwarded to the client (same behavior with other modifier keys and other symbol keys). Pressing "ctrl+m" does report the key press (again, same behavior with other modifier keys and other letter keys).

    I've verified that the key combination is not mapped to anything on the Mac. I tried with the "send key combination" option enabled and disabled, only thing it seems to chance is whether the command or the option keys send an alt key press.
  • I can confirm this problem using a device connecting from Ubuntu 18.04 to Mac OSX 10.13. There is now way to "send remote key combinations" nor does there appear to be an option to do so.

    This bug causes me to actively look for other VNC solutions for connecting Ubuntu -> Mac
  • dagan
    dagan Posts: 3

    The problem still remains in TeamViewer14 on Ubuntu.

    No option to send keyword combinations.

    Any solutions for that?

  • you have to check different keyboard with full QWERTY keypad integration or use an on-screen keyboard to send special keys, if still there is a problem send your query to the Teamviewer help desk.

  • dagan
    dagan Posts: 3

    Thanks Harold,

    Checking different machines, both as the TV client and server, plus multiple keyboards, indeed the behaviour is not identical, yet some combinations can never be sent.

    Specifically those including the ALT key.

    The problem exists in TV13 and TV14 on Linux (Ubuntu) as the client and does not exist on Windows clients. The remote server is always a Ubuntu machine.

  • This is still a problem in September 2019 using Teamviewer version 14.5.5819 on Linux and Mac OS 10.14.4. No command key key combinations can be sent from Linux (Ubuntu 18.10 in my case). Some system windows (most notably the connect to server window) will not accept an "Enter" command - not a combination, just "Enter". These problems have not always existed, but the Linux version has severely lagged behind in recent updates. The new features are completely useless if the underlying functionality keeps getting broken and addressing them is such a low priority. It really feels like Teamviewer is letting the sales team control development. Existing customers pay for the existing functionality and don't need new features forced on us, we need STABILITY. I'd love to pick a version and never update if that were practical, but it's not. If a newer version is being pushed on, that's what clients will want to use. It's also best practice to be up to date for security. So that latest version needs to be the most stable, not the experimental branch. At minimum there should be an enterprise version available that is striped down basic, security patches only but stable functionality. This is remote control software, we need to be able to control a system remotely. Beyond that it's fluff.
  • Any update on this? I'm using Mac to access Win. I have tried using on-screen keyboard on Win, Ctrl + / works there. But the combination just can't be passed. Ctrl + c/v/z/w all works. Only the "comment out" doesn't work. Anyone has this problem?

Sign In or Register to comment.