link icon
Ask The Community

TeamViewer 13 for Ubuntu 16.04.4 LTS connectivity problems

I'm usining Ubuntu 16.04.4 LTS (GNU/Linux 4.4.0-116-generic x86_64) in headless mode.

Installed TeamViewer 13 (13.1.1548) deb package sucessfully.

trying to run "temaviewer setup" few times and sometimes it just gives me :

"There was a connectivity issue. Please check your internet connection and try again."

and once I made it throught all the way to adding a machine to My contacts at Teamviever Management console and I can see my computer there but with final result saying: 

"Unable to add this computer to your account. Please contact [email protected] if the problem


Now if i run "sudo teamviewer setup" again I can see my computer in Management console coming up online for that brief time while I'm running setup and then it goes off line again when setup quites with message:


I have tried turning off my Ubuntu firewall help...same behaviour. I have tried restarting the daemon " teamviewer daemon restart" - no help. I have tried installing teamviewer-host 13 on the same machine ...and I get same behaviour. I have tried the same process on my other Ubuntu machine...exactly same behaviour.

and just to clarify on the same local network I have windows machines and connectivity to Teamviewer's servers is OK.

At this point not sure what else to try.

Link to logs:

Regards Stefan.


  • SamuelY
    SamuelY Posts: 1

    Yeah, I'm impressed :smileylol:. Can't even run setup on Ubuntu. How can I try TeamViewer when I can't even run a simple setup wizard? "There was a connectivity issue. Please check your internet connection and try again." There was?! Nothing else on this server has "connectivity issues". TeamViewer doesn't seem to interested in Ubuntu support either as I'm the first response. Look elsewhere I guess.

  • sabrex
    sabrex Posts: 1

    Having the same issue but on Ubuntu Server 18.04 LTS. Have either of you found a solution?  I've also tried this with two separate teamviewer accounts and after I enter the e-mail address and password, a few seconds passes and the same error is shown:


    Please enter your password:

    Initiating sign in
    There was a connectivity issue. Please check your internet connection and try again.


  • mzlr923
    mzlr923 Posts: 1

    I had the same problem. 

    I solved it by setting s password first using

    sudo teamviewer passwd yourPasswordHere

    After that, it worked. Hope it helps. 

  • tezgno
    tezgno Posts: 1

    I'm having this exact same problem on Ubuntu 18.04 LTS. Setting a password, uninstall reinstall, nothing appears to solve the problem. I have a Teamviewer ID, but the server appears offline. If I run the setup again, it shows up online. But, once the setup fails, it falls back offline. Only my Ubuntu server is doing this. My other computer is working fine (Windows). I'm wondering if the issue is because this machine doesn't have a GUI. The error message appears to be related to finding the external IP address and I'm wondering if it's returning null or returning an IPv6 address. Going to do some investigation now.

  • antmarot
    antmarot Posts: 2

    I'm experiencing the same issue. Setting a password didn't help.

    Anything new on that matter?

  • Thank you!

    Tested and approved!
  • ETN
    ETN Posts: 2
    Same problem here, there are no solution yet?
  • Is everyone here who's got this problem using headless server?     I can tell you that I've been using teamviewer 12 on ubuntu (NOT headless) for about a year and don't have these same issues,  just as a test what if you downgrade to version 12 to see.


  • ETN
    ETN Posts: 2
    I try it, but i'm having the same results :(
  • vectv
    vectv Posts: 1

    I have the exact issue on Raspbian. Worked around it by doing the same thing as @Digicrat but the error makes no sense since the temaviewer service is connected.
    Would be nice to have it fixed since it would make life easier when rolling out many rPi devices.
    @accordianguy, yeah headless. Haven't tried a dummy Xorg session or going back to 12/older

  • kieselbert
    kieselbert Posts: 13 ✭✭

    Works fine also for v14. Sadly they do not fixed this bug.

  • I'm having the same problem with TV 14. 

    I think it it **bleep** that this issue has existed for at least two years but has never been addressed/fixed by TeamViewer.

    I followed al the steps in this (Digicrat) post but the remote machine still cannot connect. If I restart teamviewerd on the host machine, the remote machine briefly shows a message that the host has come online. But, when I try to connect from the remote machine, the request times out and will not connect.

    I guess I will be forced to use some solution other than TeamViewer.


Sign In or Register to comment.