link icon
Ask The Community

Extra Large Cursor on external monitor connections to a remote

anyone else seeing extra large cursor (unusable actually) when having a teamviewer connection from an second monitor (ie from your laptop) to another computer?  If you drag that session to your primary screen, the cursor is the regular size. drug it back, it's oversized again. I can not seem to find any settings for this?





  • schmak01
    schmak01 Posts: 6

    I had the same problem, it has to do with windows and the DPI scaling.

    I just got a surface book 2, and the screen is 4k which is way too small on native resolution and it is set to 200% on scaling, I set it to 150%, but connected it to a dock with 2 1080p monitors.  Of course, it looks absurd there.  So I set those monitors to 100% and they look great, but some apps are blurry and others, like Teamviewer, have HUGE icons or menus.

    The "fix apps that are blurry" setting in the April Release of Windows 10 1803 didn't help.

    What did, oddly, is a compatibility setting.  Go to the icon you use to launch TeamViewer, right-click, and select properties.  From there go to the compatibility tab. Click on change high DPI settings and I checked the box at the top and selected to use the DPI that set for my main display when I open this program.

    THen I made sure to close it and re-open it (you have to exit from the systray) and whala, it's good. 


    I haven't tried the override yet though to just set it a standard, since it would be too small on the monitor with it's current DPI setting

  • Thanks...this was helpful!
  • chrisn
    chrisn Posts: 3

    Thanks a lot, this also worked for me. To clarify a little, I also had to tick on the option at the bottom: Override high DPI scling behaviour (scaling performed by system). It's not ideal because the mouse on my 4k laptop then becomes a little small, but at least the mouse on my secondary low res display is not humongous.


  • I cant find this compatiblity tab that you speak of - please help.

    *The only thing I see when you right click is Options - I dont see a Properties

  • chrisn
    chrisn Posts: 3

    I guess we are assuming you are running windows (win10 in my case). In that os, when you right click on a shortcut icon for a program, or a program exe itself, then select properties --> compatibility as follows:


Sign In or Register to comment.