link icon
Ask The Community

TeamViewer 13 Client Will Not Let me Sign In



  • mda400
    mda400 Posts: 2

    13.1 still works. its 13.2 that starts having this issue. I run a Server 2016 with MDT vm and Windows 10 pre-release vm at the same time, so I disabled automatic updates for now.

    I've experimented with removing the additional virtual ethernet connections, disabling Enhanced Session mode, disabling memory integrity (Win defender virtualization-based security), disabling/re-enabling Hyper-V feature as above (which teamviewer will allow sign in until i start a VM so it likely has something to do with a service Hyper-V is using that the new 13.2 TV version doesn't play well with). and no luck.

  • Hi,

    I tried this solutions and for a while it seems to be working. But when in the very moment i did put a VM to boot.. Boom! Teamviewer blocked the login fields! **bleep**!!!
  • Sorry @fcjbispo I don't run VM's so I'm of no help. :'(
  • This is not a SOLUTION it's a WORKAROUND!!!!

    Can someone please remove the "Solved" mark from this thread so devs come back to this issue again?

  • @stargate wrote:

    This is not a SOLUTION it's a WORKAROUND!!!!

    I would agree, but the story and "solution/workaround" is remarkably similar to my own issue as  described in this other thread I recently created.

    In my case involving the use of a Win7 HTPC, Windows Media Center (WMC) and "extenders" which are actually Remote Desktop clients that "connecting" to the HTPC through RDP. These extenders are actually RDP client systems making use of WMC running on the HTPC when they are powered on and connect, essentially facilitating WMC on the HTPC via RDP and the GUI of the extender as seen on the screen of the attached HDTV.

    Just as with the VM-being-active aspect of this thread seems to be the "culprit" which prevents username and password in the Computers and Contacts window from being usable to log into TeamViewer 13 environment, the exact same symptom occurs for me on my HTPC whenever any of my five WMC extenders are being used (i.e. when an RDP connection is active to the HTPC). As long as an extender is active, the Computers and Contacts window "goes blank", (a) showing none of the already active TeamViewer connections which were initiated prior to a WMC extender active and are actually still running , and (b) having an unusable Computers and Contacts username and password field and SIGNIN button.  And as soon as all WMC extender connections are terminated like magic the Computers and Contacts window once again becomes usable, and the username and password areas and SIGNIN button all return to normal functionality and I now can connect to TeamViewer again.

    I believe this is a relatively recent "new feature" of some recent TeamViewer version.  Until I discovered for myself the relationship between an active WMC extender RDP session to the HTPC as the "giant clue" that caused this to happen, I was simply mystified.  But I had discovered that if I re-boot the HTPC I could once again get the normal TeamViewer Computers and Clients functionality working properly, so that's what I would do (as obviously annoying as this was, since a re-boot had to be performed when there was no TV program recording going on at that moment). Of course what was actually happening as a result of the re-boot was that all WMC extender RDP sessions were not active (at least temporarily, until I once again started one or more of them again as I watched TV on my remote HDTV's via WMC and these extender RDP sessions).

    But now that I understand the external story (if not why truly TeamViewer is negatively affected by an RDP session being active, to the extent that the Computers and Contacts GUI simply "breaks") I no longer need to re-boot in order to get a newTeamViewer connection active and enabled.  I simply need to stop all of my WMC extender RDP session, and then use the once-again-active Computers and Contacts window to establish connection with one of my TeamViewer team PC's.  Then I can once again start the WMC extenders, since it is only the Computers and Contacts window which is negatively affected... not the actual already-active TeamViewer connections that might already be running.


  • I'm having the same problem in linux, runing Ubuntu 18.04.

  • It actually related to the Hyper-V network adapters, not Hyper V as a whole. Disable the Hyper-V network adapters. Then you can login. Once logged in, you can enable the adapters again.

    Update: Complete work around.

    1. Open Control Panel.
    2. Select Network and Internet
    3. Click Network and Sharing Center.
    4. Click Change Adapter Settings
    5. Right-click your Primary network adpater and select Properties.
    6. Click the Sharing tab.
    7. Check the Allow other network user to connect through checkbox.
    8. Under the home networking connection, select the Hyper-V Default Switch.

    For whatever reason, some programs (such as TeamViewer) want to use the Hyper-V Default Switch.

  • @Toast wrote:

    It actually related to the Hyper-V network adapters, not Hyper V as a whole. Disable the Hyper-V network adapters. Then you can login. Once logged in, you can enable the adapters again.

    If you are a licensed TeamViewer user, have you also opened an official support ticket with them so that you can communicate your findings?  I'm not sure they monitor this forum, so communicating amongst ourselves and passing around solutions or workarounds is great, but not what is really needed. What is really needed is to fix this recent new problem which has appears, to make it go away for real.

    I am a free TV user, so I cannot request support from them and can't submit a ticket.  We need licensed users to submit tickets.

    In my case, as I described earlier above in the thread, it was TV Computers and Contacts window "instantly going blank, prevening login" on my HTPC where TV was running, whenever a Windows Media Center extender connected to my HTPC.  This connection is through Remote Desktop Connection (RDP) and the extender actually is a remote RDP client user with the HTPC being the RDP host server.

    I suspect in your case of VM, and Hyper V and Hyper-V Network Adapters, I would guess this an exact conceptual equivalent of Windows Media Center (RDP host) and extenders (RDP clients).  WMC can support up to five extenders being connected at one time and as long as at least one is still connected the TeamViewer Computers and Contacts window remains unusable.  Once the number of connected WMC extenders drops down to zero, the TV window instantly becomes usable for login again and connection to users.

    And just as with your Hyper-V story, once RDP-connected extenders are all connected (i.e. activated and in use to watch TV at remote locations around the house), they can remain connected and will work just fine indefinitely even if the Team Viewer Computers and Contacts window is "blank and unusable" for all that same period of time.

    This same story with Wndows Media Centers and extenders and Team Viewer behavior in the presence of RDP connections, this has also been reported identically by other users on this Team Viewer Forum who are simply pure users of RDP client/server connections where Team Viewer is running on the RDP server.  As soon as an RDP client connects, the Team Viewer connection window goes blank and becomes unusable.  Once the RDP client disconnects, the Team Viewer connection window becomes usable again.

    I would like to communicate all of this information regarding RDP and its harmful impact on the Team Viewer connection window because of something they've recently changed in Team Viewer, but can't because I'm a free user and can't submit a ticket.  Similarly, your similar story about VM and Hyper-V client/server and Hyper-V adapters and its impact on the Team Viewer connection window needs to be reported to them in a ticket.

    So, if you are a licensed user... please submit a ticket and provide my RDP-related explanation here as well as your Hyper-V story. If you aren't a license duser, hopefully there is in fact some real licensed user experiencing the same RDP or Hyper-V symptoms, and WILL take the time to submit a ticket to Team Viewer providing both the symptoms as well as what we now know is the "solution" (i.e. our workaround, until they fix the Team Viewer product to not cause this behavior for us).


  • @Toast wrote:

    Update: Complete work around.

    1. Open Control Panel.
    2. Select Network and Internet
    3. Click Network and Sharing Center.
    4. Click Change Adapter Settings
    5. Right-click your Primary network adpater and select Properties.
    6. Click the Sharing tab.
    7. Check the Allow other network user to connect through checkbox.
    8. Under the home networking connection, select the Hyper-V Default Switch..

    Fabulous.  But I only understand 1-7.  I don't know what you're describing in 8.

    Is 1-7 one part of the recipe, intended to be followed by pushing the OK button and then going on to 8?

    Or is 8 something you then do after 1-7 and before pushing OK, such as pushing the "Settings" button on the dialog in order to check Hyper-V Default Switch which is presumably running as a service on your machine that supports Hyper-V to be selected?  And then you push OK on the Settings dialog after checking the Hyper V service and returning to the previous dialog, at which point you now push OK? I, of course, don't currently show Hyper-V on my own machine in that "active services" list available for checking, but then I don't run the product.

    Will the Hyper V service already be showing on your machine supporting it as an already active service, or do you have to ADD it?  Or does a Hyper-V adapter need to be active at the moment in order for the service to be showing?

    Again... please clarify where the OK button (once or twice) is pushed in your above recipe.  And what exactly do I do for 8?

    I'm trying to adapt this technique to my Windows Media Center extender/RDP story, which I suspect is identical in underlying concept to your Hyper-V story, and the overall issue with how Team Viewer is impacted.

  • As stated above I'm a licensed Teamviewer user.

    I contacted support even before I eventually came up with the workaround (read above) because I couldn't wait (customers needed my help :smileywink:).I sent them several log dumps and exlained my problems and findings in several emails after which they created a ticket.
    I have also pointed them to this thread where I told they could find more information from other users.

    I have not heard from them in a while though... been too busy!

  • @Toast wrote:

    Update: Complete work around.

    1. Open Control Panel.
    2. Select Network and Internet
    3. Click Network and Sharing Center.
    4. Click Change Adapter Settings
    5. Right-click your Primary network adpater and select Properties.
    6. Click the Sharing tab.
    7. Check the Allow other network user to connect through checkbox.
    8. Under the home networking connection, select the Hyper-V Default Switch.

    Tried to adapt this idea to my Windows Media Center / RDP / extender situation, and I'm not successful.  Again, I didn't quite follow what you 8 really was asking me to do.

    So I went to my HTPC where there actually is a hardware Ceton TV tuner card in it which utilizes a driver based on TCPIP connection to the MAC address in the hardware. In other words the tuner card has an IP address ( and the driver talks to it using internet protocol.

    And when I performed step 6 above I was presented with the following dialog. Note that it actually DOES show a "home networking internet connection" button (which I now assume is what you're referring to in 8) whereas on my earlier PC I had tried this recipe on this extra item didn't show.


    But if I select the Ceton hardware item and then check the box for "allow other network users to connect through this computer's internet connection" I get an error message when finally pushing the OK button on the dialog.  Cannot be done.  Obviously the Ceton hardware and the supporting hardware isn't designed to be "shared" in some way.

    So I left the first sharing option un-checked just as it was, with no selected private network connection.


    Note that the second option box is grayed out. The second box is pre-checked by default even if ICS (i.e. the first option box) is un-checked.  But apparently you can't modify anything for the second option using its SETTINGS button while in this state.

    However if the first ICS box is simply checked, without actually trying to select a private connection, then the second option box and its Settings button become un-grayed, allowing you do drill down into what Settings shows.

    And when I did that, remarkably there is a Remote Desktop item available for checking.


    So I tried simply checking the RDP box and pushing OK, returning me to the first dialog window with both option boxes checked but no private network connection item selected.  And when I pushed OK on this combination, again it errored out claiming that I MUST specify a private network connection in order to use internet connection sharing (ICS).

    Well, looking closer at the dropdown list items in that private network connection item, at the bottom there is a "local area connection 2", which is completely irrelevant in the current story.  I believe this may have come from when I was running my PC through a different router but which is no longer in use. Or, I believe my PC motherboard has a second wired ethernet port that I do not use.


    I then simply left the Remote Desktop service box checked and pushed OK in the second dialog, and then un-checked the ICS option box in the primary Sharing dialog (again graying out the items below it). Then I pushed OK.  And then trying to connect with my WMC extender sure enough once again the Team Viewer connections window went blank, so obviously I had accomplished ZERO in checking RDP service but not also activating ICS in the first box (because I couldn't).

    Bottom line: I can't see exactly what to do, if anything, to overcome the current Team Viewer issue as it applies to RDP. If you're saying things work differently in the VM Hyper-V situation I'm not surprised.  They're probably kind of similar to each other but obviously RDP has nothing to do with ICS and checking the first box, whereas the Hyper-V adapter for that situation apparently satisfies whatever is required to enable ICS and overcome the Team Viewer issue.

    Nevertheless, I think this is all caused by some change Team Viewer has recently made, and that is a complete disaster for users. It needs to be corrected by the vendor in its software, and not by requiring some change to the user computer setup if even possible (as it doesn't appear to be in my RDP situation).

  • There have been other posts about this before, but still no fix.

    When Hyper-V is enabled in Windows 10 Pro, I am unable to sign into my TeamViewer Account in the desktop app. This NOT is a new issue, been around for at least the last couple of months/weeks - I can't quite nail down when it started, but I'd say late July.

    I don't think the Hyper-V feature set within Windows should be preventing TeamViewers functionality - in fac,t it never used to, and I can still connect to remote systems via ID/password. It's just the account/contact list features - crazy.

    And before it's suggested - no, I don't want to remove and re-add the Hyper-V features and restart just so I can get my TeamViewer contact list - only to have it logged out and locked out when I use Hyper-V again. That's absurd.

    I find is rediculous that there is not whisper of a fix for this, after months and many posts.
    I'd love to enable Insider Builds on the off-chance this is fixed, but I can't sign in to enable this!

    TeamViewer, please advise us on a fix for this.

    Main other thread on this:

  • While i'm appreciative of @kimenemark posting this, this is not actually a solution, and it does not prevent the issue from recurring.

    TeamViewer should NOT require this for such incredibly basic functionality.
  • +1 Disabling/re-enabling Hyper-V feature as above works until I start a VM.

    Luckily, I only need VMs to do mission-critical operations. Not good enough.
  • DanZ
    DanZ Posts: 4

    Teamviewer is pile of dog **bleep**. What a fail. Can't you just fix the problem, it's been months as people were complaining and the problem is still there.

    I have the problem ON ALL OF MY PCs. All of them have the problem. EVERY SINGLE ONE has the problem. MacBook where I run windows (bootcamp), my windows desktop has the problem, and my ubuntu VM also has the same **bleep** problem. WHAT A PILE OF **bleep** seriously.

  • DanZ
    DanZ Posts: 4

    Even though it works, this absolutely cannot be marked as solution to the problem. It's a crytical bug in TV software that must be solved by them and not by us doing weird dances.

    I run VM all the time in HyperV, I absolutely cannot uninstall or turn it off, so TV sign-in for me basically does not work at all.

  • TWG
    TWG Posts: 1

    Hey Guys,

    I had a similar case and found out that in Options-->General(tab)-->Incoming lan connection I had "accept exclusively" selected.

    You might want to check that too.


  • I had the same issue

    os: ubuntu 16.04

    I went to Extras > Options > General

    in the 'Account assignment' I've tried to assign my account, but there was an error saying that niether name or password match (I double checked it was correct)

    rebooted pc

    after reboot I've started teamviewer, instantly saw the same arror message in the pop-up window and now I'm able to type in the inputs, nothing is greyed out.

    I hope it helps 

  • pacz
    pacz Posts: 2

    Hello DSperber,

    Did you ever resolve this issue?  I have the same set up with Ceton, WMC, HTPC.  TV will not let me sign in.  I just upgraded to TV14 and it still will not allow authentication?

    If it matters, TV worked perfectly before TV13.  So, something obviuously changed in these new versions.

  • No, this has still not been corrected by the TV engineers.  I, too, recently upgraded my HTPC to the new version 14 hoping if they might have fixed the problem there, but like with you I discovered that NOPE... no fix yet.

    Yes, I too had never noticed any such issue prior to version 13/14.  Same apparently with the many other users who use Hyper-V and VM session, which must be running into the same TV feature which causes problems with RDP sessions (i.e. WMC and extenders).

    Again, the symptom is that when the RDP session is started that the TV logon/connection dialog window to remote team members' computers goes blank (with all of the remote computers instantly disappearing and the login password field and button becoming inoperative). If you close the RDP session the remote computer window instantly re-populates and the login password field and button become usable.  It's not that any active TV remote connections are interrupted and broken when the RDP session becomes active, it's just that NEW connections are impossible because the remote computer window goes blank when RDP is active.

    So if you can temporarily close any active WMC extender (i.e. RDP) sessions, you should be able to connect to one or more of your remote computers... at least as long as you don't once again start an extender session (in order to watch TV somewhere in your home). 

  • I have WMC + Ceton Echos setup and have seen this issue as the few others above have.  the only way i am able to remote into the Main PC hosting the WMC content is by shutting down all the Cetons in the house and then i can remote just fine.  I agree this is not a solution and a very inconvient workaround but it works. And this does seem like it has started within the last few versions of TeamViewer.

  • pacz
    pacz Posts: 2

    Kind of defeats the whole purpose of remote sessions...Hard to shut down Ceton Echos and XBOX's when you are 3,000 miles away traveling and the family has a PC challenge.  :-)

    Is it possible to roll back to TV 12 or 11?

  • Same question. When I Try to connect Namecheap black Friday then it's not opening.
  • Hi Toast,

    Thanks for the  post, your solution fixed my login problem. Althrough I only did your steps 1 to 7 only. But it fixed my login stayed in blue. Thanks again

  • After updating to TV 14 (when it was a preview release), i was able to sign in again with Hyper-V enabled.

    However, it takes the client 10-15 seconds to connect to the teamviewer service (I assume it's trying to figure out which network interface has internet access on).

  • Hi,

    Seems to work for me too and I have reported back to support team.

    When the preview version came out however I had at least one time where it didn't work.
    The last week though everything seems to work except I sometimes have the same latency you expirence... not always.

    I run version 14.0.13880 (I'm a paying customer)


  • Just upgraded to the latest 14.1.3399 (free), having come from 14.1.13880 before this. And there is still no fix for the Windows Media Center (RDP) situation.  It still fails.

    In other words as long as a remote extender session is active the TeamViewer Computers and Contacts window is grayed out, with no entries shown and no new login connection possible. Furthermore on the main window my own ID and PASSWORD are also missing.

    As soon as all remote extender sessions are terminated my two TeamViewer windows instantly re-populate with the normally shown information, and remote login to any of my team computers is once again possible.

    I would appreciate it if somebody who is a paying licensed user would re-report this to the TeamViewer support group. If they have focused on fixing things for your VM Hyper-V users, they have very definitely NOT FIXED things for us Windows Media Center users (under Win7) which is actually an RDP session.  PLEASE!

    It's kind of mentioned in the latest new README (which now appears in a new window to show latest changes, when upgrading the version of TeamViewer) that with 14.1.13880 this was supposed to be fixed (I'm guessing it's being described ambiguously and vaguely as a firewall-related fix), but again I suspect if you Hyper-V users say it was fixed then you're the winners. It absolutely was NOT fixed for WMC/RDP users.

Sign In or Register to comment.