link icon
Ask The Community

TalkTalk Imposes Extensive Traffic Filter in the UK

Version 12 was installed a few months ago...Program has run fine for years. This evening I wanted to use, and I am greeted with the RED dot...'Not Ready. Please check your connection.' I know maintenance was preformed last night and infact sometime today an auto update v 12.0.72365 was installed. I have a good internet connection service and speed(Wi-Fi and Eithernet). I have stopped and restarted the program a few times and rebooted a couple of times...still unable to connect. Windows 10 Pro 64bit....Worked fine this morning! The only option I thought about doing was uninstall and reinstall. Anyone else have an issue?

In antication of help...Thanks


  • From FileLog I have this:

  • Same issue here. Think it's my internet connection or router. My mobile connects fine!

  • mikeKey
    mikeKey Posts: 4

    I had this problem on windows 10......

    closed teamviewer

    went into task manager

    found a running teamviewer task and ended it

    started teamviewer again and it seems to work.

  • I tried this, but it doesnt work still.

    It was working until last night, I re installed and restarted PC but still it doesnt work

  • ...closing everything in Task Manager did not work for me!

    I have looked at the logs and my last enty today is:

    2017/03/09 05:40:48.603 13728 12068 G2   CProcessCommandHandlerMasterConnect[68]::CreateMasterConnect():, Connection 68, proxy=''
    2017/03/09 05:40:52.806 13728  7404 G2   CKeepAliveClientClient::DoReconnectInternal: doing nothing, state = 1
    2017/03/09 05:40:53.639 13728 12068 G2   CTcpConnectionBase[68]::HandleConnectTimeout(). Connect timed out to
    2017/03/09 05:40:53.639 13728  7404 G2!  CProcessCommandHandlerMasterConnect[68]::HandleMasterConnect(): MasterConnect to failed
    2017/03/09 05:40:53.655 13728  7404 G2!!!Connect to Master / failed!
    2017/03/09 05:40:53.655 13728  7404 G2!! CMasterConnectorAsio::HandleMasterResponseLogin(): MasterConnect failed. ErrorCode=10
    2017/03/09 05:40:56.657 13728  2232 G2   Activating Router carrier
    2017/03/09 05:40:56.842 13728 12068 G2   CKeepAliveClientClient::HandlePing(): success
    2017/03/09 05:40:56.842 13728 12068 G2   Non-Commercial use
    2017/03/09 05:40:56.842 13728 12068 G2   Resource-Language: en
    2017/03/09 05:40:56.842 13728 12068 G2   Activating Router carrier
    2017/03/09 05:40:56.842 13728 12068 G2   CProcessCommandHandlerMasterConnect[70]::CreateMasterConnect():, Connection 70, proxy=''

    Yesterday the last entry was: ErrorCode=10

  • Update: 1021 UK. I have checked our 2 other win 10 Pro computers... same results as posted here. Recycled the Router again a few times and just went over everything I did yesterday to try and fix the problems...nothing works on all 3 devices to get TeamViewer to went to a neighbor and logged into their router...same problem!!

    I get a window about proxy settings...I have no idea, but automatic is 'recommended' and that is where the bullet is shown. I have sent TeamViewer 3 different "Feedback" requests with their 'Logs' attached and a screenshoot from our 3 devices... If anyone still has issues please send "Feedback".

  • jpeg1966
    jpeg1966 Posts: 6

    Is you ISP Talktalk by any chance? As there appears to be an issue with any one on Talktalk, and using teamviewer. The issue has been raised with Talktalk by an number of people if you look at the community on there web site. 

  • Yes it is - thanks - I'll have a look on their website,although it is only affecting 2 out of 3 PCs I have checked at home so far

  • NickB
    NickB Posts: 9

    My ISP is TalkTalk as I think are a few others (there is a second TeamViewer thread on this:

    I wonder what the nature of the issue is though as, when I connect to my work's VPN, I still cannot get through.  I would have expected the VPN to resolve the issue (another user reported that TunnelBear VPN enabled them to get around it.

  • Thank you jpeg1966 for the information. I am on Talk-Talk...and so is my neighbough. Lets hope this is the problem...& they get it fixed FAST!

  • jpeg1966
    jpeg1966 Posts: 6

    I have just tried a free VPN service called TunnelBear (it allows 500mb per month) and once I set that up the Teamviewer connection was working again. I will only use that if I really have to in an emergancy. 

  • AlanW57
    AlanW57 Posts: 1

    Yes, it is TalkTalk blocking access to the Teamviewer servers because some TalkTalk users have complained about being duped by fraudsters into installing Teamviewer on their computers !! There is an active thread on the TalkTalk community about thsi right now -

    Maybe if we all kick up a fuss then someone will notice ?

  • NickB
    NickB Posts: 9

    My TeamViewer connection has just come back online, just as I had finished drafting a complaint email to TalkTalk as well.

  • Esther
    Esther Posts: 3,811 Community Manager 🌍

    Hi Community and TalkTalk Customers,

    I would like to share our Statement with you:


    TalkTalk Imposes Extensive Traffic Filter in the UK

    Several organizations are affected

    Göppingen, Germany, March 09, 2017 – TalkTalk, a provider of telecoms and broadband solutions, responded to ongoing scam campaigns aiming at unsuspecting TalkTalk customers by bringing about extended traffic filtering in the United Kingdom. This step impairs the operation of various software products. Cyber criminals abuse legitimate software to rip off their unsuspecting victims. The measures deployed by TalkTalk may affect the use of the popular remote support software TeamViewer®. TeamViewer and TalkTalk are in a close and constructive exchange to address this issue. TeamViewer denounces criminal activities in any form.

     In the context of the current situations TeamViewer stresses:

    • Scams aiming at unsuspecting individuals are despicable. Yet – as a BBC-article suggests - what makes the current frauds particularly hideous is the fact that scammers are using TalkTalk customer data. Several news outlets including tripwire reported that TalkTalk experienced a data leak. The criminals apparently obtained this data and are now using it in their scam-scenarios. This provides them credibility and facilitates their cunning schemes. The fact remains, however, that large organizations would never cold call individuals to offer help with some unfounded issues. Users are strongly advised to apply extra care and a healthy dosage of scepticism with unsolicited calls.
    • The current impairments are not a sign of operational dysfunctions or a security issues at TeamViewer. It is a drastic measure brought about by TalkTalk. The filter affects several organizations.
    • TeamViewer and TalkTalk are in extensive talks to find a comprehensive joint solution to better address this scamming issue.


    Community Manager
  • Same for me. When I found that it's not working on iPad, iPhone and Laptop, I realised it wasn't me, it m,ust be TalkTalk. So I fired my VPN and bingo, works perfectly on everything.

  • Hi there. I had the same issue a few weeks ago. Getting ready to jump ship on tt. I actually posted a fix for this issue and some idiot admin("ferguson") removed my post , so I removed myself from the forum, as I will not need it. Not sure who made ferguson/tt gods?

    This was my fix:

    sign into your TT account: Hover your mouse over "My Services", Select "View Homesafe settings", Select the chrevon "Chose which site to block or allow" Turn "Kids safe" ON, In "specific website" enter  Select "Allow"....'Save changes'....DONE!

    BUT maybe tt have changed everything again. They seem very irresponsible! I am still getting Teamviewer up and running everytime with no issues. My main issue was trying to help someone who also has tt as an IP and needed help, and I was unable to access their device. Happy New Year.

Sign In or Register to comment.