link icon
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?

Download the new version and let us know what you think about it! 👉 Please click here 👈

Error Message: Waitforconnectfailed



  • This might be the best solution.
    I have had this issue on too much a variety os systems to pinpoint another source other than a TV issue.Rebooting, with no config change sorts it ALWAYS.
    As I see it, if a computer shows up as online, then some sort of comunication channetl is available to TV server (ie, not blocked in any way)
    I am sure that, through code, this channel could be used for a remote session (even if slower, or limited).
    I have TV 13 license, and was thinking about upgrading my account (I need mobile support more frequently), but now I think I'll invest my money on a alternative solution to install alongside TV, or eventually replace it.
  • zs
    zs Posts: 1

    This is real problem. I have two machines (out of 30-40) with this issue. I was able to connect this morning and I know that they are on line. Asking customer to reset is embarrassing. Installed version is version 13 HOST.  Must be TeamViewer bug of some sort. 


  • Any solution for this error yet?

  • Ok.

    That was it for me. I first noted this issue last year and it happened every now and then. Now, it occurs almost every day, on a variety of sistems. I am fed up with the ignorance of TeamViewer staff and whole the money I have payed for a connection sistem that is not worth it. 

    I am sorry but I cannot continue like this. I am a support business and in my TV console I have almost 100 computers. This issue affects almost 10% of my remote managed computers, on a daily basis, with any configuration, any type of connection so is nobodys fault except Teamviewers.

    I am pretty sure that it is something that can be easely fixed by a software update, but Teamviewer does not care.

    All they care is charging a lot of money.

    I am switching to **Third Party Product** as we speak.

  • this is hilarious, the forum automatic moderator replaced  **Third Party Product** in my previous post, but if you look above a few posts, someone else clearly states that name and it was not replaced.

    this is weird conspirational behavior from TV. 

    i am switching right away ...

  • MRP24
    MRP24 Posts: 1


    Mr./Madam TeamViewer 

    I had problem like Re: Error Message: Waitforconnectfailed, I was looking for resolve from forum teamviewer, but I didn't found conclusion for over come this problem.

    please from your employee team for resolve my problem

    Best Regrads



  • Natascha
    Natascha Posts: 1,378 Senior Moderator

    Dear @MRP24,

    Thanks for your post. 

    Is it possible, that you restart the service of the TeamViewer software for both sides?

    If you restart the services, the connection should be possible afterwards. 

    Looking forward to your answer. :) 


    German Community moderator 💙 Moderatorin der deutschsprachigen Community

    👉 Have you already tried out the new TeamViewer user interface? Do you want to give feedback? 👈
    ✅ GREAT - Go Ahead

  • hiroo
    hiroo Posts: 3
    How does one restart the services on the remote side, remotely? Your suggested solution assumes that somebody on the other side is available to restart it. That may be the case in some situations, but there are also many situations where the remote machine needs to be accessed right now, and there is nobody there, or nobody that has the technical knowledge to restart the service. So your proposed solution really isn't a real solution. If we didn't need reliable remote access, we wouldn't need TeamViewer. Please escalate this issue up the chain so it can get a true fix.
  • Agree...I posted a reply to @Natascha's comment, but somehow it didn't get through.

    You essencially sum it up, more often than not there's no-one at the other side, and many times restarting is not an option ( tasks are running and we need to see them through).
    Also, if it's a server, restarting handing out admin credentials to users ( not an option).

    Opening the logs you see stuff like:

    "CTcpConnectionBase[64]::HandleResolve(): Resolve failed,, Error: system:11001"

    and then you use an alternative software to connect remotely, ping, and it resolves.

    Error 11001 means nothing to us users, and during a 3AM call I don't want to google around for a possible solution. More meaningfull/usefull error would be nice.

    TV is a remote support tool, it must be resilient to computer issues ( to a point, obviously).

    In order to make TV more resilient to newtork errors,namely nameresolution, why not have a local copy of TV server's IP addresses?
    And if connecting to one server fail, why not "round robin" to another IP?

    If a certain host shows up ONLINE then it should be reachable remotely, because obviously it is communicating with TV somehow.

    I run a "one man show", providing IT support to nearly 40 clients, so I need a reliable IT support tool.
    Next week will begin testing an alternative solution, and not sure that I will upgrade to TV 14 ( I have used TV since version 11, and I am now on TV 13).

    Best regards from sunny Portugal,
    Cláudio João


  • On the same page with ClaudioJoao In his post just replace 40 with 70, and Teamviwer 11 with 9, and you got my case, so a little worse.

  • Hi,

    I am trying to use TeamViewer to connect to my home computer (a Windows 10 PC) from another computer (a Windows 7 PC). I have installed the software on both machines and have checked that it is indeed running, but every time I try to connect I get the following error

    "No connection to partner! Partner did not connect to router. Error code: WaitforConnectFailed"

    Your resource centre is not particularly helpful with this, because the advice is just to reinstall the software on both machines and/or shutdown and restart the software. I have done both of these things several times, but same error. Having read all of the other posts about this, it would seem that lots of people are having the same problem but nobody seems to have an answer (other than use other software).

    Please advise.


  • Hi,

    Can you give me informations about this "Third Party Product"? What is this and where can I find it?

    I have the same problem as you sinds years and years and TemvViewer staff never made anything for that.

    Problem is that I have nobody on site to "restart" my compuyters, miles and miles from home...


  • laurin1
    laurin1 Posts: 2

     He means like **Third Party Product** - I do the same as no one product is fully reliable when you have nobody on site. **bleep**, but a fact of life.

  • Specicying the DNS Server Addresses for the Windows Network Adapter resolved the issue for me, or I should say avoided having it again.  TV resetting on both sides needed to take place first.  Tracking the Event Viewer I came across the unresponsive DNS warning for teamviewer server request and that's why I went ahead and specified the DNS. Firewall issues can also cause it as one of the posts suggests.  Have you resolved yours ?

  • AMak
    AMak Posts: 1 Newbie

    Has anyone found a solution other than rebooting? I have this problem with one of my remote systems. Usually if I keep trying to connect eventually it will go through, but recently it has been taking around 10 tries which is frustrating and time consuming. Restarting does seem to help for a short period of time, but after 1 or 2 days the WaitForConnectFailed error comes back.

  • 2E0UCW
    2E0UCW Posts: 2 ✭✭
    edited June 21

    I setup a Raspberry Pi4 for use at a remote site - it was on my LAN (via a powerline adaptor) and HDMI to my bedroom TV. Setup Teamviewer Server as well as "Third Party Product" (as a backup) - I could get in as well as a friend outside of my network.

    I then moved the Pi4 to another location - still on LAN via a powerline adaptor. I get the same "WaitForConnectFail" error with Teamviewer and even "Third Party Product" fails despite IP scanner seeing the Pi4 and "Third Party Product" on my laptop picking it up (but won't connect).

    Very annoying as this was meant to be placed at a remote commercial site so we can control some equipment.

  • 2E0UCW
    2E0UCW Posts: 2 ✭✭
    edited June 21

    Found the solution on a post regarding "Third Party Product" - it solves the TeamViewer issue as well.

    This issue does not affect TeamViewer and "Third Party Product" on a Raspberry Pi3B+ possibly due to a different graphics setup.

    * * * * * * * * * *

    I assume "Third Party Product" relies on the being a GUI/desktop to access just like VNC does,

    but when the pi4 is booted without a screen connected then there is no GUI/desktop started, so you probably need to do the same as you would if you were using VNC and set a default screen resolution which forces the pi to run the GUI/desktop even though there is no screen connected.

    you need to run

    sudo raspi-config

    go to Advanced options > Resolution (I found that it should be the graphics option menu not the advance option menu)

    and set a default resolution that is not the same resolution as the screen you plug to the pi.

  • rshingala
    rshingala Posts: 0


    I have latest version of TV and I am connected to Internet, I can see on my TV Ready to connect but I am not able to connect to my ID as well as no outbound. Steps I have performed

    1. Un-install TV and re-install
    2. Un-install Anti-Virus
    3. Windows Firewall disabled (Public, Private & Domain)

    While connecting from outside to my laptop getting following error

    When I connect to from Laptop to outside getting error

    Could not connect to Partner

    If I am posting on wrong forum do guide me correct one.



  • PhilipArgy
    PhilipArgy Posts: 2 ✭✭

    This is still happening four years later and still no solution?

  • tmorgan1982
    tmorgan1982 Posts: 1

    I recently ran into this. After looking into it for a long time, I found out that you need to have a monitor connected to the device that you installed TeamViewer on when trying to connect to it remotely.

    My coworker found some old instructions stating that you had to edit a text file line (on the Pi OS that we are using), in order to bypass the monitor requirement. I'm not sure what the equivalent file is on Windows or Mac. But here is what I found for it on Raspberry Pi:

    1. Enable booting without HDMI
      1. sudo nano /boot/config.txt
      2. Remove # from hdmi_force_hotplug=1
      3. If it is still not working disable GL drivers
        1. sudo raspi-config
          1. Advanced Options
          2. GL Drivers
          3. Legacy

    I highlighted the fix for Pi. All I did was delete the # from that line, hit Ctrl+O and Enter. It saved the edit after that.

    I'm guessing you would see something similar in Windows but you would see a 0 instead of a 1, so you would just change the 0 to a 1 and save the file. That should force the graphics card online even though a monitor is not connected to it. Mac might be similar to Pi. I didn't have to use line c, but included it just in case.

    I hope this helps, or at least gets you going in the right direction. It's been a huge headache for me these last couple of weeks.