link icon
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?

Download the new version and let us know what you think about it! 👉 Please click here 👈

IoT Remote AppControl solution and Synology NAS boxes



  • arpitjindal
    arpitjindal Posts: 68 Staff member 🤠

    HI @Chiron

    At the moment, there are no other devices, in the pipeline, to support.

    If we get enough request for the support of any other device then maybe we will add support in next year.

  • lotht
    lotht Posts: 5

    I should have been a lucky guy, I could easily install the package on my DS414, and thought that this was a good opportunity to use my new TeamViewer business subscription for accessing my NAS.

    But I must have been an unlucky guy because TeamViewer said that my subscription (270-280 EUR / yr) was not eligible to access my new mobile (!) device, and additional package (240-250 EUR / yr) schould cover this demand. 

    Is my NAS acually a mobile device?


  • arpitjindal
    arpitjindal Posts: 68 Staff member 🤠

    Hi @lotht

    Thanks for the information. I will check it on my side and will let you know by the end of the week or next week. It should be accessible from every subscription.

    Could you tell me which TeamViewer windows version are you using?



  • Hi, thanks in advance.
    TeamViewer is up to date, my version is 13.2.14327.
  • Hi @arpitjindal,

    Did you find out something about the licensing requirements of the NAS access?

    Thank you,


  • arpitjindal
    arpitjindal Posts: 68 Staff member 🤠

    Hi @lotht

    Yes. We have found the problem and trying to fix it at the moment. Unfortunately, you have to wait for some time. I will update you when its being done.

  • Hi

    Can you kindly take me through the steps for Wake on Wide Area Network. I want to wake machines remotely 

  • Hi,

    Actually I'm a bit far from this solution. Actually I have installed the client on my NAS and my actual subcription license prevents me from accessing the device. As far as I'm aware, TW is working on the solution to provide access, the wake-on LAN problem comes then.


  • arpitjindal
    arpitjindal Posts: 68 Staff member 🤠

    Hi @Misheck

    Wake on LAN is not supported in the solution.

  • arpitjindal
    arpitjindal Posts: 68 Staff member 🤠

    Hi @lotht

    As I said earlier, we have identified as why you are facing the problem with your subscription license. We are working on it.

    I didn't get whats with "Wake-On-LAN" problem you are facing. Just for the information, we don't support Wake-On LAN in IoT at the moment.

  • Hi, the Wake-On-Lan was not my problem. It was asked by someone else.

  • Hi,


    I installed the package on my DS412+. I got it running, but my ID and password remain empty. Any suggestions? Am I doing something wrong here?

  • I have added the Synology into the list by "Add remote computer", but when i make it to "assign to account", it prompt the window as this picture,

    [The URL link has been removed by a moderator according to the community guidlines]

    But i have signed in my teamviewer account, the ID and the assigned password,

    Now I'm using the teamviewer with the version  13.2.14327

  • PatrickG
    PatrickG Posts: 40 Staff member 🤠

    Hi @shiyiii

    Unfortunately, hyperlinks are automatically removed, can you upload the screenshot to your post, so we can see the error message prompted?



  • arpitjindal
    arpitjindal Posts: 68 Staff member 🤠


    You have to enter the password shown in the Synology's TeamViewer GUI in the prompted password box.

    Access the Synology device and open TeamViewer app. In that, it will display the TeamViewer ID and password. Copy the password or take a note of the password and enter it in the prompted displayed box.

  • Tender
    Tender Posts: 2

    any update by when the solution will be available for MAC OS X and Android, so that we can use it to connect to DSM  ?

  • peten
    peten Posts: 3
    Will TV 14 support Mac OS X for this?
  • Unfortunately, TeamViewer 14 will not support this feature on macOS or Android. We have it on our roadmap, but I cannot give a definitive date, yet.

  • peten
    peten Posts: 3

    Do you want/need beta test sites?  I know of a volunteer....

  • It seems that. although on Intel Celeron J3455, DS 918+ is not yet supported by any spk's I've found here. Will there be a release available for this chipset?

  • arpitjindal
    arpitjindal Posts: 68 Staff member 🤠

    Hi @EgbertB

    Have you tried amd64 package? That should work on DS918+

  • Thx, this works! AMD was the only package I did not try as I assumed it would not work since AMD and Intel are competitors.... ;-)..!

  • Running on my DS 916+ but finally not working on DS 214 Play (Intel(R) Atom(TM) CPU CE5335) as reported by other users.

  • arpitjindal
    arpitjindal Posts: 68 Staff member 🤠

    Hi @mitri2 

    Could you please be more specific about the problem? What is not working?

  • romain49
    romain49 Posts: 1


    Any news/solution about the licensing problem (new mobile license) ?

    Anyone got it running on DS218+?

    My config:

    DS218+ , Windows 10, TW 13.2.26558

  • PatrickG
    PatrickG Posts: 40 Staff member 🤠

    Hello @romain49 

    You should no longer see the message that a mobile license is required in order to connect to your Synology Disk Station. Can you verify on your end and provide a feedback?



  • gautrand
    gautrand Posts: 3


    I wan't use teamviewer on dockey DSM synology or virtual DSM of synology, but the password was not reconised by teamviewer app.

    The password generate on app on synology could be not good.

    Thanks to reply

  • _Andreas_
    _Andreas_ Posts: 18

    Dear gautrand!

    Please make sure the device is assigned to your account. As stated with the password, it cannot be used to connect to the DS directly, you can only use it to assign it to your account.



  • rttm
    rttm Posts: 6


    anybody sucessfully tried with DS3617xs ?

    kind regards


    ps: works perfect with DS1817, DS916+, DS214+

  • arpitjindal
    arpitjindal Posts: 68 Staff member 🤠

    Hi Thomas

    What exactly are you facing the problem with DS3617xs?

    And about the model you mentioned, DS1817. It it DS1817 or DS1817+?