link icon
Ask The Community

Unable to connect to android devices from ubuntu

Hello everybody.

I can't connect to an android device from my teaviewer.
I use ubuntu 18 and I checked in version 13 and 14 preview.
When I need to connect to a customer tablet I must go to a windows system.

I have the Corporate licence.

When I enter the ID number to connect it try to connect, the tablet ask for permission, I accept and then disconnected. In my pc teamviewer I see "Connecting", "Autenticating", and "Autentication accepted", then it goes to "Ready to connect" again and the quicksupport appears also Ready to connect.

I try to connect to multiple devices brands (samsung, bq, huawei, etc) with the same result.

What can I do? Do you need more information about this issue?

Thank you a lot.



  • liyan
    liyan Posts: 2

    I have same problem. But it is successful that the teamviewer in ubuntu connect other teamviewer in windows 7 or 10. Why? 

    And WIN10's teamviewer is able to connect to android devices. I test it. It works.

  • liyan
    liyan Posts: 2
    I solved that. the version of the teamviewer in ubuntu must be v 12.
    But there is still a problem, I can't control my android, only share screen.
  • wakele
    wakele Posts: 5

    I can connect to windows clients with no problem from my ubuntu.
    The problem is to connect to an android tablet using quicksupport.
    I can't use tv12 because all my customers have v13 minimum.


  • Xofe14
    Xofe14 Posts: 2


    I'm experiencing the same problem with screensharing with an Ipad. Only teamviewer V12 is able to connect to my Ipad but screensharing isn't available.

    Teamviewer V13 on Ubuntu doesn't connect to devices running Quicksupport.


    C. Bellessort

  • wakele
    wakele Posts: 5

    "Teamviewer V13 on Ubuntu doesn't connect to devices running Quicksupport"

    Ok, but it is possible to connect devices running Quicksupport in V14? Or in a future version?


  • liyan

    May I ask which Teamviewer v12 version _exactly_ you are using? And where did you obtain it?

    The reason why I'm asking is that I came across this being mentioned in another thread on this forum. Unfortunately I am not on that particular Linux machine at the moment, so I can not check which v12.x version I tried. However, I tried it with that Linux Teamviewer v12.x version, my guess is that it had been a 64-bit *.deb package, but I experienced the very same things described in the first post of this thread.

    So, would someone please be so kind to provide more detailed information?

    Thanks in advance.

  • Hi,

    I just tried Teamviewer 14 on Ubuntu 18.04 and it can't connect to my Android device through Quick support. As soon as I authorize the connection on the device it goes back to the first screen.

    I hope this issue will be solved.

  • @liyan

    Ok, I have had the opportunity to check for the v12.x version I had found and had tried:

    Now if you could please share the version of the one that you are using and where you obtained it? Merci bien.

  • I finally got it to work!

    LM19 host to Android running Teamviewer Quicksupport.

    The first reply included this approach:


    Bear in mind though that using your regular distro's repositories remains more advisable.


  • Is this deb in version 14 or with the old version 12 commented in other messages?
  • Errm, well, Linux Mint is based on Ubuntu which itself is based on Debian.

    As the wget command indicates, it is a debian package - see file extension.


     And 'yes', this results in a 32bit v12.x Teamviewer download - architecture in filename - which I ran on a 64bit platform.

    Good luck and success.

  • Ok, it sounds good, but I need to use the last version of TV.
    Thank you anyway.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!