link icon
Ask The Community

Teamviewer service not startup


i have a problem with teamviewer, the service is automatique but didn't startup.

if i start the service manuel, teamviewer works.

i tried to check windows events log but everything is okay.

( teamviewer is allowed on my comodo firewall also i disabled comodo but the problem still exist )

Sans titre.png


Best Answer


  • HuolSamHuolSam Posts: 5


    Now i found that teamviewer not start because can't answer quickly to the start request or control, "event id 7000".

    Sans titre.png

  • HuolSamHuolSam Posts: 5

    Any Help ??

  • bxdobsbxdobs Posts: 3

    My guess is that one of the recent updates from MS for WX has messed with or confused the Teamviewer Service Startup Settings/Process ... Several machines that have been stable for months in WX just refuse to connect with no reason for the failure ... I basically have to RDP in to the machines and manually start TV which again fails on the next reboot ... looking at the process tree, it appears only one of 3 TV processes start with windows in this mode ... the only fix that worked for me was a complete Uninstall followed by a Reinstall of Teamviewer (didn't have to delete the Teamviewer settings)

  • bbaclebbacle Posts: 1

    I tried uninstall and reinstall with not joy.
    I tried the registry edit that was mentioned but still no joy.
    I am using Teamviewer 13 and it was working find up until the other day.
    Now, all of a sudden, it no longer starts automatically.

  • phlibbyphlibby Posts: 2

    I think you put 60,000 which is 16 minutes when 6000 (1.6 minutes) would be more appropriate?

  • bxdobsbxdobs Posts: 3

    mSec = 0.001 of a second so 60,000 mS = 60.000 Seconds not 16 minutes

  • phlibbyphlibby Posts: 2

    My Bad. You are right. 60 seconds, 1 minute. I have to go change that now.

  • Did you ever find a solution or cause for the issue?  We are running into the same thing.

  • Having never found a workable solution to the randomly missing Team Viewer service, I have resorted to use a free third party solution ... using autohotkey (WHICH ALWAYS STARTS after reboot when its configured to do so), I created a simple script to periodically watch for/monitor the Teamviewer service, if it isn't found, the AHK script physically kicks one back in to play ... this AHK script works on both W7 and WX machines to ensure that a Teamviewer Service is always available

     sleep, 60000
     process, exist, TeamViewer.exe
     if %errorlevel% = 0
      run, c:\progra~2\Teamviewer\versionX\Teamviewer.exe



  • Xavier75Xavier75 Posts: 2

    I had the same problem and it took me hours to solve it. In my case, my AVG anti-virus was not up-to-date and suddenly considered TeamViewer as a potential thread and blocked the service. I updated my anti-virus and it worked again. You also have the option to ask your anti-virus to not check your TeamViewer directory anymore. Hope this can help someone. 

  • drwhendrwhen Posts: 1

    Thankyou I nearly lost the will to live this method worked worked perfectly on 2016 Essentials Slight changes in paths and this link was useful



Sign In or Register to comment.