link icon
Ask The Community

Wake on LAN stops working

Today I've setup wake on LAN using a public IP.

All seems to be working fine. As indicated I have tested it and at first it didn't work. However, after a reboot I was able to put the machine to sleep and get it out of sleep again.
But if I wait a little longer, say half an hour, it doesn't wake up anymore. If I use the WMC remote (this is my HTPC) I can wake it up again. Then constantly it doesn't work through TeamViewer until I restart the machine.

Is this a known issue? The problem is: I don't get an error message....just nothing happens. I am not sure if I can check some logging to identify where things go wrong.
I have an Asus RT-AC66U router. And the machine is some HP machine with its own BIOS.

I was able to perform all the steps mentioned in the manual except for:
-deactivate fast startup (I simply don't have that option)
-I wasn't sure if the box to only wake using a magic packet should be checked



  • Found that I had to enable "hibernate" in order to be able to disable fast startup. Next to that I noticed that I was running TeamViewer 11 rather than 12 on the target machine.

    Updated that and now for some more testing when I'm back from work. All suggestions are still welcome

  • Did some tests this weekend, but if the machine has been asleep for a while it is only possible to wake it using the remote.

    Any thoughts?

  • Got a message that I earned a new rank in the community. Although I really appreciate that I would appreciate a real solution more :)

  • Plantje
    Plantje Posts: 13

    Still no solution here?

  • @Plantje Thanks for your contribution. 

    @elbea64 gave a great explanation on how you can test Wake On LAN setup in this thread

    However, you mention that your computer is on hibernate / sleep, which might be problematic. Could you try to wake up the machine after shutting down the computer completely?

  • Plantje
    Plantje Posts: 13


    Sorry, I didn't receive a notification that there was a response.I will go through the thread once more (since I already found that after a search)

    @Benjamin_B wrote:


    However, you mention that your computer is on hibernate / sleep, which might be problematic. Could you try to wake up the machine after shutting down the computer completely?

    I am not sure what you mean here. The computer is not in hibernate mode; it is in ordinary sleep mode.

    If I shut down the machine completely I cannot wake the machine. Then I really need to push the button on the machine.

  • kewalarun
    kewalarun Posts: 4

    I have the same problem, it worked for few months flawlessly, however it stopped working since yesterday. Any help will be much appreciated.

  • bartlanz
    bartlanz Posts: 315 ✭✭✭

    From what I've been reading there have been some updates pushed out that have caused issues with WOL. That being said, I actually went through and got it working on a few computers I have today.

    According to what I have read, A full shutdown of the system does not support WOL (from TeamViewer or other sources) Hybernate does not work either. The system must be in sleep, and it can not be hybrid sleep.

    If my post was helpful, Please throw me a Kudos.
    If my post fixed your issue, please mark it as the solution to help the next person find a solution quickly.
    Bart Lanzillotti
    We Do IT USA
  • Plantje
    Plantje Posts: 13

    What did you do to get this working again?

    For me the initial issue was (and still is): I can get it to work if the machine is asleep for about 20 minutes or so. If it is asleep longer (let's say for example the next morning and it has been asleep for a few hours) I can only wake it using the button on my mediacenter remote or the powerbutton on the computer itself. If it doesn't sleep that long TeamViewer is perfectly able to wake the machine.

    I will contact the guys from DVBLogic as well since they seem to be able to use something that does wake that machine at any given time to start a recording.

    The fact that a machine doesn't wake after doing a full shutdown is logical and I hope people don't expect that...

    Edit: I recently switched from Windows 10 Mobile to Android and I noticed the Kore app (official Kodi Remote app) has a feature to wake the system. And that seems to be working perfectly!

  • Plantje
    Plantje Posts: 13

    Can't understand what DVBLogic and Kodi do different. DVBLogic wakes the machine for recording. Kodi wakes the machine when I click on "Wake up"  on the Kore app on my Android phone.

  • klepp0906
    klepp0906 Posts: 16 ✭✭
    I have the same issue. Have spent way too long on it. 3 pcs all exhibit identical behavior. I wish I had something else to add.

    Trying to wake from regular sleep from within my own home network. Windows 10.

    No good.
  • Plantje
    Plantje Posts: 13

    Currently the only way is to use Kore on that specific machine.

    I appreciate Teamviewer being available for free for non business users, but if you offer this I think it should work...

Sign In or Register to comment.