link icon
Ask The Community

A Comunidade TeamViewer chega ao Brasil 🎉

Check out our brand-new Portuguese Community 👉 here 👈.

Not ready, please check your connection

I am trying to use TeamViewer 14.1.3399 on Arch (manjaro) Linux at home, to remotely connect to my work computer, which is an Ubuntu Linux system also running TeamViewer. I have all the login credentials and stuff, but my home system says "Not Ready. Please check your connection". It won't allow me to log in or attempt to connect to anything.

Internet is working fine. I don't have a firewall for outgoing connections. I am able to ping as well as other servers. If I tell it to accept incoming LAN connections, then the status changes to "Only LAN connections are possible" but that is useless, since the computer I want to connect to is remote.

There is a setting "assign to an account" which I have not done, since this is my home computer and I'm not interested in allowing remote management or access to it. I can't find any explanation or documentation of this setting.

I don't know what to look for in the logfile. I see things like

2019/02/03 19:57:48.696 30134 -- GX0 Opening local TCP connection to, tcp?
2019/02/03 19:57:48.697 30134 -- GX0!! Local TCP connection failed with error 111


2019/02/03 19:57:58.695 30134 -- GX0!! WorkingProxyListener::WorkingProxyResultHandler failed: 1
2019/02/03 19:57:58.695 30134 -- GX0! WorkingProxyListener::WorkingProxyResultHandler: setting default value ProxyType::Undefined

Things I have tried without  success:

  1. Setting DNS to google servers
  2. systemctl restart teamviewerd.service
  3. kill all teamviewerd to maek sure it is good and dead, then restart
  4. google searches on the topic

Best Answer


  • buluho
    buluho Posts: 3

    Hello I have similar experience, and I found that the daemon is not a working method even after authorizing the machine. This takes me weeks to debug. Eventually I turn to the tarball and just run the TV program and it works. I am using a Centos.

  • Thanks for this, the key for me was:

    1. sudo killall teamviewer

    Had some extra processes running in the back ground from previous starts. 

  • The solution that worked for me:

    On Teamviewer, Go to Extras > Options 

    Enable "Start Teamviewer with System"

    Click Apply

    Reboot Your PC

  • My old laptop linux system(s) were already running Teamviewer 12 and 13 sucessfully.. (I don't use them that much hence the old versions). However, when I tried to connect today from my Windows 10 laptop it refused because version 14 is incompatible. So I updated the linux system to version 14, and immediately got this error - same after a reboot. Looking on the Teamveiwer site, my laptop was already in the list of computers though showing offline. I found that I still had to run these three steps (thank you @barfoo ):


    • sudo killall teamviewerd
    • systemctl start teamviewerd.service
    • start the UI



  • Finally! I had to dig through way too many threads to find this. My solution was slightly different:

    1. sudo killall TeamViewer (had to be capitalised like this)

    2. systemctl restart teamviewerd.service (not sure if simply starting it would have done the trick)

    3. Start TeamViewer from menu like normal.

    I have no idea why this works, because restarting the computer did not help.

  • rhynzler
    rhynzler Posts: 1

    **bleep** @Fabian42, it works for me too, the key was the capitalized TeamViewer command

  • That worked for me too, thanks a lot!

  • BOlmosEC
    BOlmosEC Posts: 1

    In Archlinux you have to activate the daemon with the command:

    sudo teamviewer --daemon enable ... the console output is something like:

        Sun 19 Apr 2020 07:51:32 PM CEST
    Action: Installing daemon (15.4.4445) for 'systemd' ...
    installing /etc/systemd/system/teamviewerd.service (/opt/teamviewer/tv_bin/script/teamviewerd.service)
    Try: systemctl enable teamviewerd.service
    Created symlink /etc/systemd/system/ → /etc/systemd/system/teamviewerd.service.
    systemctl start teamviewerd.service

     Then just run Teamviewer.

    Ensure that the file /etc/gdm/custom.conf has the line 'WaylandEnable=false'  uncomented.

  • jcartee
    jcartee Posts: 1

    I had this same issue and this completely worked for me. 

    Thanks for the solution


  • thanost
    thanost Posts: 1

    is not work for me, anyone have another solution please.