unable to connect to android quicksupport or host

wuziq Posts: 4 ✭✭

I am posting here because this issue does not occur from my Windows machine on the same LAN.

When I use Ubuntu to connect to my Android device (all on the same LAN), both sides show the connection being made.  After the connection negotation, the Android device shows that I'm connected ("connected to kevin"), but no control window appears on Ubuntu.  Then, after about 5 seconds, the connection closes, and it just shows that I'm ready to connect again.

Here's the last part of the log:

*Logs Removed by Moderator*

Let me know if more of the log is needed.

I've also tried using my mobile data connection instead of wifi on the Android device - same result.

This is Ubuntu 16.04 running TeamViewer 13.0.6634.  Android device is ZTE Axon 7 running TeamViewer Host and QuickSupport 13.0.7847.  I also have the ZTE plugin for TeamViewer.

Any ideas?

PS:  I can connect from Ubuntu to Windows without issue.

Best Answer


  • wuziq
    wuziq Posts: 4 ✭✭

    Is there a way to tell why my post got rejected?  It is showing up in my rejected posts.

    I thought maybe it was because I included a pastebin link (it was just a TV log), so I removed that link.  But I don't think it made a difference.

  • Scotty
    Scotty Posts: 493 Staff member 🤠

    Hi wuziq,

    Sorry about that. Your post wasn't so much "Rejected" as it was "Spam Filtered".

    There are a lot of not so friendly people posting junk to the community, so we have a bot battling them, unfortunately you got caught in the crossfire.

    But, not to worry, we do check through the filtered stuff and pull back out stuff that is legitimate when they are occasionally caught. I pulled yours back out just now. And, yes, it was probably the logfiles that got you recognised as spam.

    Also, we do ask all users not to post logfiles as they can inadvertently give away to much info.

    Hope this helps!

    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • wuziq
    wuziq Posts: 4 ✭✭

    The last two lines of the log, which have no personally identifiable data, are:

    2018/02/04 09:51:15.690 6563 S! UdpConnection[90]: UDP statistics: nb=25
    2018/02/04 09:51:15.725 6563 S IProcessCommandHandler[65]::CmdEndSession(): Received CMD_ENDSESSION with reason: 1

    I tried searching for "reason 1" but didn't find anything.  Does anyone know what that means?

  • wuziq
    wuziq Posts: 4 ✭✭


    Is there something else I should be trying?

  • Suni
    Suni Posts: 1


    I have a same issue. Unable to connect from ubuntu to android phone.

    • Where can I download the ver 12 Teamviewer?
    • How can I install next to the latest version?


  • Any news?

  • Mark_F
    Mark_F Posts: 8
    So, I managed to obtain "teamviewer_12.0.93330_amd64.deb" to give that a try as it was mentioned on this thread. Unfortunately even with that one I don't seem to be able to establish a TeamViewer connection from Linux --> Android (running Teamviewer/Teamviewer QuickSupport). Now version 14 came out and I was hoping for it to offer this path for connecting again - unfortunately no. So I guess my question is: will there be a TeamViewer solution/offer to be able to connect from Linux hosts to Android mobile devices in the forseeable future? Thanks in advance. Regards
  • I am also seeing the same behavior trying to connect from Linux client 14.0.14470 to QuickSupport on Android 7.1.


    Carrier[41]::CmdEndSession(): Received CMD_ENDSESSION with reason: 1

    I found competing product to work in this application instead. It would be great if TeamViewer restored this functionality that has been dropped for over a year.

  • QPG
    QPG Posts: 23 ✭✭

    It's been over a year since this problem was posted here. Can we get an update on when we may expect to see this functionality return to the Linux client?

    Using Windows machines or TV12 isn't really feasible in a Linux shop running corporate licensed TV14.

  • TV team! We, Linux users realy need to get working TV with Android devices. We paid for licenses but din't got working solution!

  • I found this post after trying for hours to sort out this exact same issue (works connecting to Android from Windows PC but not from Ubuntu PC). Please fix this Teamviewer! And if it's an issue that has been known since v13 and won't be fixed then why not make the UI state something useful like "It is not possible to connect to Android on an Ubuntu installation of Teamviewer". At least then I would not have wasted hours trying to fix the problem!
  • Philip777
    Philip777 Posts: 2

    Actually, for me TV12 is working.

    The following constellation works: TV12 (.deb, i386, 18.04 Bionic Ubuntu) connects to my DotOS Android (8.1 Oreo, latest host apk running) via TV login.

    After installation of the .deb, I needed to resolve the missing dependencies ("sudo apt -f install") and then also restart the teamviewer daemon ("sudo service teamviewerd restart").

    Good luck ...

  • QPG
    QPG Posts: 23 ✭✭

    @Philip777 wrote:

    Actually, for me TV12 is working.

    Of course that feature is working in TV12. TV12 is essentially the Windows application packaged with its own bundled WINE libraries. This thread is about the feature not working on the Linux native clients, which start at TV13. For those of us who have kept our TV host deployments up to date, using obsolete TV12 is not an option since it cannot connect to TV hosts newer than TV12.

  • Philip777
    Philip777 Posts: 2

    @QPG wrote:

    Of course that feature is working in TV12. 

    Would you have read the full thread, you would have noted that users are trying to overcome the problem that TV13 and V14 does not work on Ubuntu with an Android running the host apk, and that at least one person had the issue that the suggested workaround of using TV12 instead was not working. I was merely assuring that person that the workaround is indeed a solution and working.

    If TV would fix the incompatability issues with TV14, we surely would not have that discussion. But for now, the TV14 on Ubuntu cannot access a TV host running on an Android phone as descriped in the initial posting.


    Btw. for the rest, I am running 18.04 64bit but used the TV12 i368 .deb ... amd64 was not working. Maybe this was the original issue of user @Mark_F ...?

    Good luck and have fun with controlling your Android devices from Ubuntu ... OpenSource, the only way to go!

  • iamit
    iamit Posts: 2 ✭✭

    Thanks for this work around..... but reeally? TV12,  Do i need to install 2 versions back to get this working? I pay a busines license to get things going smoothly. And how about ... does it work well with TV14 next to it, because my desktop users i wanna support... well this won't work with TV12. And i kind of surprised, a lot of developers I know work on linux, support to mobile devices (when developing android) seem like a very basic need to me..... But in 2 years, still not a resolved issue?????

  • Mark_F
    Mark_F Posts: 8

    Yes, so far it is the only working solution which I have found using Teamviewer.

    Linux host -> Android client (QuickSupport) = Teamviewer 12
    Linux host -> Linux/Windows client (Teamviewer) = current Teamviewer versions should work

    This is how I install(ed) Teamviewer 12

    wget http://download.teamviewer.com/download/teamviewer_i386.deb

    (Addendum: worked on Linux Mint 18.x and 19.x and since LM is Debian/Ubuntu based I wonder why it wouldn't work on Ubuntu. Regarding the dependencies, maybe this will help https://askubuntu.com/Questions/912872/Cant-Install-Teamviewer-12-On-Ubuntu-16-04-64bit-Dependency-Lib32asound2)

    The approach mentioned for running two different  Teamviewer versions on the Windows desktop in parallel is to have a regular + a portable Version. 
    For Linux I have come across this, which you will have to run through a translation service unless you do speak German:

    Bottom line: yes, a true pity that this hasn't changed in all this time. There are also issues with some keyboard commands not (properly) being "forwarded" to remote machines when Linux is involved.

  • normic
    normic Posts: 6 ✭✭

    @_Andreas_ would you mind telling us, which "upcoming release" and when it will be available?

    You're post is more than a year old, we are on TV 15 but still not able to support mobile devices. A feature which has been paid for.


  • Janiporo
    Janiporo Posts: 1

    Same problem still persists. Please developers do something about this!

    I am using TV 15.8.3 client on Linux Mint 19.2


  • TexZeTech
    TexZeTech Posts: 1

    I also have this problem in manjaro running Teamviewer v15.8.3 while trying to connect to Teamviewer QuickSupport v15.8.115 QS any fix?

  • 100i
    100i Posts: 1 Newbie

    Come on TeamViewer!!

    The OP first posted the question in Feb 2018. Then in the next 36 months, numerous people added comments saying that they too are struggling with the exact same issue; and yet we've not seen a proper answer from TeamViewer support so far!

    As of now, it has been 36 months and I too am dealing with the very same problem!

    On Ubuntu I have TV 15.14.3 (DEB) and on my Android I've tried TV Host v15.14.35 HM and also TV QuickSupport 15.14.35 QS.

    It looks like that it's not going to work for Linux users to remotely control their Android devices. So why not just say that in Play Store's About Section for the App or even somewhere within the app itself.

    Believe me when I say that at the end of the day, you easily will have saved hundreds of hours of people's time.

    Thank you,


    I'm the one who likes, all the pretty songs!

  • jackdinn
    jackdinn Posts: 23 ✭✭
    edited November 2021

    Teamviewer 15.23.9 on Manjaro KDE all up to date. I do have other computers but none of them are windows.

    Err, yea, So i have to come searching around the internet to find this problem is ongoing for years and years.

    So no news then?