link icon
Ask The Community

Business License new device added says Free License

I have a Business License subscription that I started back on Version 12, and have upgraded to each version since and am currently running Version 14 latest release.

Got a new PC, installed TeamViewer 14 today, double-checked / followed the steps at**Please do not post TeamViewer IDs**

However, the TeamViewer on my new PC still says "Free License (non-commercial use only)

I am definitely logged into my TeamViewer account both here on the site and in the full app on my PC, I definitely Added the new PC in Edit profile > License > Add new device and it shows both my TeamViewer ID and the new PC's name (and I have not exceeded my 3 device limit - in fact I even tried deactivating / removing an old PC I'm getting rid of) but still no luck.

Can someone please tell me what I'm missing?

I need to do Remote Support for my clients over the weekend from this new PC as I've transferred all of my important work info to it, so I would truly appreciate any assistance please.

Thanks very much!




  • AnotherDave
    AnotherDave Posts: 5 ✭✭

    PS - When I started this tonight, my TeamViewer Business Account said I had 8 moves left, and now it's down to 6. I'm getting pretty nervous over here :(

  • Yuri_T
    Yuri_T Posts: 2,006 Moderator

    Hi @AnotherDave ,

    Thank you for your post.
    In your situation, please restart the TeamViewer application.
    As long as you added the TeamViewer ID in Edit profile > License > Add new device in the Management Console it should work in this way.

    If you need any further assistance, please do not hesitate to contact our support team.

    Hope this will be helpful.
    Best regards,

    Community Moderator/ コミュニティモデレーター
  • AnotherDave
    AnotherDave Posts: 5 ✭✭

    Thank you for the reply @Yuri_T 

    Naturally the first thing I tried was logging in/out of the TeamViewer app, and of course completely rebooting my system, before I resorted to posting here. In fact I did this a couple times before coming here.

    Magically, it wasn't until after your response that the "Free - non-commercial use only" message went away. Strange coincidence eh?

    In any case, just relieved that it now looks and operates normal now.

    Thank you,

  • AnotherDave
    AnotherDave Posts: 5 ✭✭

    I'm having the same exact issue once again. Set up a new PC yesterday, followed the steps exactly as instructed, but the new PC is still showing "Free" instead of "Paid License" like on my other PC. Submitted ticket yesterday. Calling tech support phone number now.

    EDIT / UPDATE just in case this can help someone else someday: This time the issue was simple and my mistake - I didn't put the "1" before the 6 digit remote control ID of the system. TeamViewer phone support pointed this out over the phone. One the 1 was added in the online TeamViewer Management Console in my account > Edit Profile > Profile settings > License , all I had to do this time was - in the TeamViewer app on my PC, go to Connection > Exit TeamViewer and then re-open TeamViewer, it switched to "PaidLicense".

    (Still a bit odd that I didn't need to do that back in March when this happened, but in any case once again just glad to have it working).

Sign In or Register to comment.