Teamviewer initializing display parameters and hangs Version 12.0.71503



  • duane
    duane Posts: 7 ✭✭

    Not sure what you mean.

    @fometeo wrote:

    Teamviewer only connects when a monitor is attached and display is on, so to say screensaver or power save are the cause. As soon one uses the system, it wakes up, and so the display, and teamviewer does work again.

    I leave my PC on but turn the monitor off.  I can usually connnect with TeamViewer except when it intermittently gets this problem initializing display parameters.  But it can work for a week with no issue so I don't think it depends on the monitor being on.  Maybe I misunderstood you?

  • it seems the monitor being connected event if off is enough.
    most important is power safe is off for the graphics.
    some other software have the same issue, and some solutions even use dummy's plugs into graphics, check Google for how-to-create-dummy-plugs-for-your-graphics-cards.

  • MichaelG
    MichaelG Posts: 19 ✭✭

    I've had this issue a couple of times. Today, the solution was different.
    I have a power controller at the remote computer. I can power-cycle it if needed. I did that today and it did not solve the issue. When I tried to connect after the power cycle, I got a "You've trieds to connect too many times..." . SInce the  computer was just power-cycled, I know it was not the other computer.
    I found that if I kill TeamViewer_Service.exe AND tv_w32.exe and tv_x64.exe, then I was able to connect to the remote system.

  • MichaelG
    MichaelG Posts: 19 ✭✭

    It's happened twice today. Both times I was in a session when the mouse and keyboard ignored inputs - that is when problem started.
    The second time, I tried only killing the local services.  It didn't help, I needed to reboot the remote system too.
    Now I enabled remote desktop so that I may try more actions in the future.

  • Thanks .... the recommendation to " kill TeamViewer_Service.exe AND tv_w32.exe and tv_x64.exe"  is helpful information.  

    The following is just additional information on my experience and does not contain a remedy or fix:

    I use TV to connect to many of my customers that are running separate and distinct computers .... TV has been perfect except for one of my customers.  For that customer I experience the "Initializing display parameters" issue every time I try to connect.  I know I have a solid connection because I can open the File Transfer tool and I can see the remote drives and files perfectly.  I can transfer files as well.  As a test, I wanted to eliminate any installation issues that might be at my customer end.  I also wanted to insure that both ends of the TV software were up to date.  As such, I had my customer download and use the TeamViewer "Quick Support" tool ( The download link is: ) When I tried to make the "Quick Support"  connection,  it produced the same hang and message "Initializing display parameters" ... TeamViewer File Transfer was fully functional.  I run multiple monitors on my local system and my customer has single monitor.  While not a likely problem, I wanted to eliminate this as a potential conflict so I tried connecting from one of my computers that has single monitor .  Same hang and message were received.  

  • Timbo
    Timbo Posts: 4 ✭✭

    Having the same problem too - with different PCs it seems vary how often it will happen but now it's perhaps 80% of the time incredibly annoying.  Why is this marked solved it's patently not!


  • Timbo
    Timbo Posts: 4 ✭✭

    I've raised a support ticket for this seeing as I have corp. licence.


  • so5719
    so5719 Posts: 2


    I started to have this problem on a headless Mac Mini (TV set on HDMI) running El Capitan and version 11 of TV (since i upgraded to 12). For 4 years i connected like this to my Mac and since the latest update of macosx (i think) something is not right.

    After many failures i observed that if i let a finder window opened it works. If i close all finder windows i cannot connect.

    I used to connect from work (windows 7), from various iOS devices and my macbook pro. Until 2 weeks ago no problem.

    FYI, my computer at work is also headless (display off) and i can connect very well from home.

    So i think it's a mac os x problem for me

    THX for feedback

  • GongT
    GongT Posts: 1

     remote win10 pro headless computer have this problem .

    Solved by these steps:

    1. connect with TV VPN (you must enabled it before)
    2. connect RDP to remote ip address, login
    3. RDP and VPN will disconnect when login success
    4. TV remote desktop works now


  • When TV remote doesn't work, TV VPN does not work, either. Have tried this many times.
  • SAME! Any solution on your end?

  • Unfortunately no.

    I did recently change out my hardware, on my machine, from Intel to AMD, which required a Windows reinstall.  So far it hasn't been happening again, but what does happen is that when connected, via Teamviewer, Explorer.exe crashes and hangs up a LOT.  I think there's some kind of hook, or conflict, between the newest versions of Teamviewer and Windows Explorer, right now.  None of these crashes, lockups, ever happened in past versions, and I've been using since version 7 or 8.  Since the "unable-to-connect" issue seems to revolve around explorer.exe being locked up, on the remote side, I have a feeling that these issues are connected and I'll soon start seeing the inability to connect, like before.

  • obawe
    obawe Posts: 1


    I also had this problem with version 12 after updating from version 11 on two computers. After complet deinstallation und new installation of TV V12 on both Windows 10 computers this issue is solved.

    TV Version 12 now works fine again.




  • MichaelG
    MichaelG Posts: 19 ✭✭

    For me the problem is so sporadic, that I can't really comment on solutions. I haven't seen the error since my last report.

  • duane
    duane Posts: 7 ✭✭

    @MichaelG wrote:

    For me the problem is so sporadic, that I can't really comment on solutions. I haven't seen the error since my last report.

     I"ve been using it for over a week without the issue.  But yesterday I had the problem and when I got home I opened TV and it looked ok.  I tested it and it worked.  I noticed that my PC had a new software update and remembered that I had restarted it that morning before I left for work.  So I rebooted the pc again and TV didn't work after boot.  I opened TV and it started to work.

    Like you say, this seems to be pretty sporadic so I'm not sure if it's the actual problem but it looks like even though the service is restarted on a PC reboot that it doesn't wakeup unless I actually open it. 

  • brw111
    brw111 Posts: 29 ✭✭

    Same problem with latest version 12.0.75813. This is very serious since I was in the middle of working on a client computer and all the other employees in that office have gone home. Completely unable to finish the work!


  • addision
    addision Posts: 1

    Here is what I had to do to resolve the issue. I have to turn off the power saving functions on the monitor and I have to leave the screen on and the computer logged on.

    If I do not do this I can't connect to the computer from a remote location.

  • brw111
    brw111 Posts: 29 ✭✭

    That doesn't work for me. I had it happen with a computer where I've never adjusted power saving one way or the other. Normally I have no problem with that computer. It was a one-off issue. When the client came into the office the next day I asked them to tell me what they saw on the screen and it said "my name" unable to ... something or other. I had them close the popup and was able to connect. It hasn't re-occurred since!

  • barfgom
    barfgom Posts: 1

    I have this problem for more than a year, it only works when the TV or attached display has power on.

    I solved it by using another program: **Third Party Product**, works like charm.

  • Timbo
    Timbo Posts: 4 ✭✭

    I'm still having the issue after the Creators update for windows 10 - the symptoms are always the same:

    Connect to remote system, hang 'initialising display..'

    On remote system 'explorer.exe' is hung (crashed).   Resolving it is possible by killing the task and restarting explorer.  

    I've had this happen on 3 different systems now and the symptoms are always exactly the same - no explorer.exe crashes occur on any system except when using teamviewer (the system reliability monitor is an easy way to visualise this).   As a possible workaround you can setup a task to monitor 'explorer.exe' and kill/restart it when it hangs.  This gives you a fighting chance of reconnecting.


    I'm using Restart On Crash -

    I'd be interested to see if this helps any of you!



  • bekou
    bekou Posts: 3

    I have the exact same issue with Windows 10 after last updates (KB4015217). In one of my pcs, I have also received the creators update. I' ve never had this kind of problems before. The TV version is


  • alex-gru
    alex-gru Posts: 1

    I'm having the same problem here, very annoying, already happened twice!

    • TV running on Windows 10 or Ubuntu 16.04 (tried both)
    • Target running Ubuntu 16.04

    This issue appears when I'm switching display resolution in a remote session - the transmitted screen freezes and the connection drops. When I reconnect, the process hangs in the initialize display parameters part. 

    Update: Suddenly I could connect to the ubuntu machine again, after around 15 minutes - but the screen is just freezed, I cannot do anything. Really strange.

    The only working way to fix this, is to restart the target machine, which is very frustrating ;-)

    Please fix that!

  • Jon
    Jon Posts: 4 ✭✭

    I've installed this Restart-on-crash application, and after a week or so my experience is that it might work. I haven't had this error since I installed it. 

    I suppose it's not proof, because I may have had week long periods without crashes before, but at least I can't rule out that it works :)

  • thado
    thado Posts: 2

    Same here bekou, same version, Connected reliably from home for years, now my work machine freezes, won't allow input, close the connection and it hangs at initializing display parameters, and after a while it just goes to authentication rejected.  Super annoying.

    I've only noticed this since the Creators Update.

  • kadeschs
    kadeschs Posts: 1

    Solved?  Same problem here too.  Anybody at TeamViewer look at these threads?  Seems to be a long common bug.  I also think it's a resolution problem since TeamViewer seems to be terrible at switching resolutions properly.  I think it may be connecting.  It just can't make it pass the "Initializing display parameters" step in the process.

  • brw111
    brw111 Posts: 29 ✭✭

    Don't if others are having this problem but whenever there's an update to this subject I get the same email notification repeated multiple times! E.g., so far today I have received this same notification six times! TEAMVIEWER: ARE YOU PAYING ATTENTION???


  • bekou
    bekou Posts: 3

    Hi, I reverted to TV 11 for now and it solved my problem. This is not a solution but it works for now since I don't have time experimenting at the moment with different TV 12 versions. I send an email to people from TV and they told me to run an app (TV support collector) that they have to collect the logs from the host and target machines and send them the zip files. I'll do it when I have more time available but TV 11 seems to solve the issue for 2 w10 creators update pcs.

    ---edited ---

    Same issue in version 11 - authentication rejected like @thado said but without crashing. When I closed the message session timeout, I was able to reconnect! 

    Just in case that somebody is listening the error that I get in TV 11 log file is:


    CLoginServer::CheckIfConnectionIsAllowed: Incoming connection from xxx denied, because TeamViewer is not visible

    CLoginServer::runServer: Connection is not allowed


  • I suspect you installed TV over an RDP session originally.  Remove TV, gain direct console access to the server (not RDP access) then reinstall TV.  In my case I was able to uninstall TV then reinstall TV over supermicro IPMI Java based console and that got it working for me.  FYI Logme (now GoToMyPC I think they call it) had this same issue years ago before I switched to TV.

  • Mulsambe
    Mulsambe Posts: 8 ✭✭

    I have the same problem, although I am using version 12.0.77242.

    I am using TV on this PC both for login to another PC and for login to this PC from the other one.
    Both cases do not work anymore.

    From this PC I get initialization display then hanging window. From the other PC, after initialization, the connexion ends without any message.

    Everything used to work fine until some recent time. Hoever, I am unable to tell when the problem appeared. It may be after installing latest Windows 10 upgrade.

    Any solution available ?

  • bekou
    bekou Posts: 3

    @Mulsambe: For me in TV 12.0.77242, the issue remains.

    Try TV 11. This older version solved the problem.