teamviewer.com link icon
or
Ask The Community

Teamviewer initializing display parameters and hangs Version 12.0.71503

123457»

Comments

  • idsej
    idsej Posts: 1

    "Remove External Background" is NOT the culprit. I have toggled it on and off and I still get the "Initializing display parameters".

    There has yet not been a single fix in this thread.

  • tkuhmone
    tkuhmone Posts: 13

    still occasionally this error on connection attempt "initialising display parametrs" and connection is not made. Manually interrupt and then try another time, overrides issue temporalily. I use 14.2.8352 preview build (windows)....

  • hoogw
    hoogw Posts: 3

    I solved the same problem by change display device to old sony TV (2009).

    This issue only happen if you connect to some kind of moden monitor device.

    If the remote device HDMI port have no wire, or the HDMI wire did not connect to a monitor,

    Teamviewer will NOT working. I realize you must connect the HDMI wire to a real device and the device must turn power on.

    If I connect to ASUS monitor 2017, it will freezing hanging as "initializing display parameters." for ever. 

    If I connect to old 2009 sony TV(HDMI), solve the freezing problem. 

    So the issue is caused by the display device that you connect to. 

    Just try some other moniter, or TV, specially old Full HD tv, always solve this problem. 

     

  • hoogw
    hoogw Posts: 3

    I solved the same problem by disable screen saver, disable any kind of standby.

    Teamviewer only connects when a monitor is attached and display is on, so to say screensaver or power save are the cause. As soon one uses the system, it wakes up, and so the display, and teamviewer does work again.

    i think it's because mainly teamviewer cannot wake up the screen, so if the screen went to standby mode, teamviewer will not initialize the display.

    the only fix i could find in this is to keep your display awake at all time. disable it from the power settings to never turn off display.

    ( Off course, you can turn off the power button on your monitor, but on unbuntu, you must disable screen saver and disble turn off display after 10 min, keep display on all time)

    This is the ultimate solution. 

     

  • briangw
    briangw Posts: 1

    @hoogw wrote:

    I solved the same problem by disable screen saver, disable any kind of standby.

    Teamviewer only connects when a monitor is attached and display is on, so to say screensaver or power save are the cause. As soon one uses the system, it wakes up, and so the display, and teamviewer does work again.

    i think it's because mainly teamviewer cannot wake up the screen, so if the screen went to standby mode, teamviewer will not initialize the display.

    the only fix i could find in this is to keep your display awake at all time. disable it from the power settings to never turn off display.

    ( Off course, you can turn off the power button on your monitor, but on unbuntu, you must disable screen saver and disble turn off display after 10 min, keep display on all time)

    This is the ultimate solution. 

     


    Teamviewer DOES NOT need the monitor on to work. I leave my server's monitor off all the time unless I need to go to the basement to interact with it. When I'm done, I shut it off. I've been using it this way for many versions of TV. I just recently swapped out PCs for my new server and started getting this issue. On my old server with the same version of TV, it worked with the monitor always off. Going to try some of the things suggested in here but I can assure you that you do not need your monitor on for this to work. 

  • jbmac05
    jbmac05 Posts: 1

    As someone else suggested, opening a file or folder on the target Mac seems to get around the problem for me, at least between two Macs.  Hope TeamViewer and Apple can get this issue resolved.

Sign In or Register to comment.